Pixelfed not federated


Hardware: computer
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : NO! Why would I screw up someone else’s peice of art?

Description of my issue

Pixelfed installed smoothly as I’ve come to expect from Yunohost’s devs. It works and is very cool. Except that it wont show the other federated instances.
I made myself the admin
I have the .env file configured


And did the php7.2 artisan config:cache
Sill no federation. So I tried

php artisan cache:clear
php artisan optimize:clear
php artisan optimize

Then the artisan config:cache again.
SO I tried the post install deployment per Pixelfeds docs.
First command failed

composer install --no-ansi --no-interaction --no-progress --no-scripts --optimize-autoloader

Got no command found.
Next 2 worked

$ php artisan config:cache
$ php artisan route:cache


php artisan migrate --force

Returned nothing to migrate

artisan purge command was fine

Then storage command

php7.2 artisan storage:link
The “public/storage” directory already exists.

I even thought it might be because I limited the access to myself through the Yunohost admin and no other users.
I have no clue other than the composor install command isnt recognized. Should I try to
apt intsall composor? Then run the comoser install command?
Was there any changes during the packaging that I might need to be in a different directory when running some of these commands?

Uuuh I’m not sure about that, but from what I read here and there, it’s not so obvious that Pixelfed allows federation ? According to @yalh here : YunoHost-Apps/pixelfed_ynh

It sounds like Pixelfed account will be followable from Mastodon, but not from another Pixelfed instance (did I understand that right ?)

1 Like

Well crap! I didnt catch that. I shouldve just ran that whole thread through the DeepL Translator.
(I have that booked marked in the toolbar right at the top now, lol)
Guess I will blow that install away. I was kina liking it but if it wont federate then whats the point. Lol.
I dont want to be the only one on the instance. I like to talk but not to myself.

Pixelfed is still a beta version: https://github.com/pixelfed/pixelfed/releases/tag/v0.9.4

But as far as I’ve understood, federation between pixelfed instances is planned

I may revisit in the future when its implemented but for now I’m just going to join someone elses instance. Otherwise I will loose interest and end up going back to instagram.
And I cant let that happen, lol.

For 0.9.5 (or 0.9.6) which is nearly ready.


bonsoir mon anglais est approximatif il y a un patch récent qui permet la federation de pixelfed j aurais besoin aide pour l installer sur yunohost y a t il update en cours ?

You need to add AP_REMOTE_FOLLOW=true to .env, the previous REMOTE_FOLLOW variable was deprecated!

Hey @dansup welcome to the Yunohost community! Love your Pixelfed!
I started this thread a couple of months ago before Pixelfed was fully federated. I see its working now. But Im already on your instance. Im gonna give it another go once I move my Yunohost off my home server to a vps.
Again thank you for your work on Pixelfed!


Just wanted say hi and welcome to the community @philko!


Non, pas d’update en cours, le package est actuellement dans la derniére release disponible: la 0.10.0

No, no update in progress, the package is currently in the last available release: the 0.10.0

On a mis à jour la configuration qui était datée, plus besoin de faire des modifs, la fédération doit marcher directement (version 0.10.6).

We updated the outdated configuration, no need to manually change anything, federation should work right away (in version 0.10.6)

1 Like