Pixelfed "File Not Found"

Hello everyone!

YUNOHOST is fantastic, thanks everyone for the hard work on it.

My YunoHost server

Hardware: VPS, Racknerd
YunoHost version: 11.1.15
I have access to my server : through SSH and YUNOHOST interface
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:
If your request is related to an app, specify its name and version: Pixelfed - 0.11.4~ynh5

Description of my issue

A fresh Pixelfed installation only reports “file not found” after installation.

I was able to interact with it via SSH and create a user. I’m not sure what steps I can take to troubleshoot. I did uninstall and reinstall to see if that would help.

There are no errors during installation, but a few warnings:


Other applications have installed correctly on this server, such as nextcloud, roundcube and gotosocial.

(some have not, such as Mastodon and Writefreely)

Any help is appreciated, thanks again!

If you’re not in a hurry, could you wait for the release of Pixelfed 0.11.5 packaging in Yunohost ?
It’s in testing phase right now Testing : v0.11.5 by lapineige · Pull Request #205 · YunoHost-Apps/pixelfed_ynh · GitHub (you can actually try it with this URL in yunohost install screen : GitHub - YunoHost-Apps/pixelfed_ynh at testing).

Not in a hurry! I’ll keep my eye on it and try it out. (and uninstall in the meantime)

I reinstalled with the new 0.11.5 today and had the same result, which means it is probably something in my setup. Any advice on what to try, or where to look for issues.


thanks again for the response.

Can you check if the horizon service is running ?

I ran “systemctl status horizon” and it says horizon.service not found

Is there a better way to check its status? (apologies, I know enough Linux to get myself into trouble, but not enough to get myself out…)

edit: to add, just checked the services section on the YUNOHOST admin panel and it is not listed there either.

In fact I think now it’s supervisor service :thinking:

so. I took drastic measures and nuked the server and started over. Deb 11, fresh install of YUNOHOST, pixelfed as my first app installed, and it works.

No idea what I did to cause the issue. Are there conflicts with apps? could I have installed something that broke a part that Pixelfed needed?

Supervisor service is running, and Pixelfed seems to be up and running as well.

Maybe something related to the recent release bugs ? :thinking: (see Testing : v0.11.5 by lapineige · Pull Request #205 · YunoHost-Apps/pixelfed_ynh · GitHub)

Great to know it works ! :smiley:
Don’t forget to mark this topic as solved :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.