Pixelfed 0.11.9 - instagram import - no preview after import

So, big update is avaliable.
Of couse installed it and tried to do import. Archive has been uploaded, I was able to see photos when selecting first 100 to import, but when reviewing no preview is avaliable. And now, something is missing, some permissions are falling?

Oh, the file permission issue, again…

Can you first confirm that publishing a picture from Pixelfed works well in all situations ?
Then for the imports, what is failing exactly ? No preview but image is there when you show the post ? Can you see it from another instance of fediverse software ?

uh, just tested and just using www, when uploading pic also I get “no preview avaliable” and no picture. same as I want to review imported photos from instagram. no preview when looking at review queue and when clicking on view same “no preview avaliable”.

Ok, then can you connect via SSH to your server, and share with us the result of ls -l /var/www/pixelfed/public/storage/m/_v2/* ?
And the same for the subfolder that correspond to the date your imported these pictures.

We need to investigate if the rights have not been set correctly.

root@yh:~# ls /var/www/pixelfed/public/storage/m/_v2/*
186f813ba-297a89  bf0f52ff2-92677b  c51ea9690-856390  c537ce87c-f5971d

c51ea9690-856390 is folder created at the date of import, and in it are folders with jpg in it, like:



Sorry, I should have said ls -l instead, because here we can’t see anything regarding files rights :sweat_smile:

I would need an example or two of these folder with jpeg files.

(And also namei -l /var/www/pixelfed/public/storage/m/_v2/ could help having the full list of permission for folder and parent folders etc)

1 Like

last two folders with jpg in them

drwxr-x--- 2 pixelfed pixelfed 4096 Aug 22 13:44 ZDwEjJz7ztkA
drwxr-x--- 2 pixelfed pixelfed 4096 Aug 22 13:44 zqO55Tbyni7s

and for Aleks question:

namei -l /var/www/pixelfed/public/storage/m/_v2/
f: /var/www/pixelfed/public/storage/m/_v2/
drwxr-xr-x root     root     /
drwxr-xr-x root     root     var
drwxr-xr-x root     root     www
drwxr-x--- pixelfed www-data pixelfed
drwxrwx--- pixelfed www-data public
lrwxrwxrwx pixelfed www-data storage -> /var/www/pixelfed/storage/app/public
drwxr-xr-x root     root       /
drwxr-xr-x root     root       var
drwxr-xr-x root     root       www
drwxr-x--- pixelfed www-data   pixelfed
drwxrwx--- pixelfed www-data   storage
drwxrwx--- pixelfed www-data   app
drwxrwx--- pixelfed www-data   public
drwxrwx--- pixelfed www-data m
drwxrwx--- pixelfed www-data _v2

Anything else needed?

So my guess is that these files should either me group-owned by www-data (similar to parent folders) instead of pixelfed OR have the r flag enabled for others

That’s the thing : they are supposed to be owned by pixelfed:www-data.
That was fixed for pictures upload (@brandthedwarf can you confirm this works well ?), but it’s not working for imports… :thinking:

I was trying to upload via www and got the same result as with import “no preview avaliable”

Ok so there is a bigger issue here, that is probably linked to Yunohost app packaging…

One workaround to quickly fix it on your side is to run chown -R pixelfed:www-data /var/www/pixelfed/public/storage/m/_v2/1.

That will fix already uploaded pictures, hopefully Instagram imports too.
But that’s not solving the root of the issue, that should already be solved… :thinking:

Can you give me the content of /etc/php/8.2/fpm/pool.d/pixelfed.conf ? (group should be www-data https://github.com/YunoHost-Apps/pixelfed_ynh/blob/master/conf/extra_php-fpm.conf#L7)

Chowning of course worked.

contents of file:


user = pixelfed
group = pixelfed

chdir = /var/www/pixelfed

listen = /var/run/php/php8.2-fpm-pixelfed.sock
listen.owner = www-data
listen.group = www-data

pm = ondemand
pm.max_children = 8
pm.max_requests = 500
request_terminate_timeout = 1d

pm.process_idle_timeout = 10s

; Additional php.ini defines, specific to this pool of workers.

php_admin_value[upload_max_filesize] = 100M
php_admin_value[post_max_size] = 100M

; Group should not be pixelfed, unless image (folder) access rights are not working
group = www-data

Oh here is the thing… group is present 2 times. Remove the first occurrence.
Do you manually modify this file ?

No, I didn’t. I was for a moment on testing fork, there were some issues before.

Which occurence you are reffering to? In the beginning of file where

group = pixelfed

and in the last line

group = www-data


This one:

should be removed.

I don’t understand why it appears twice… nor why the second one doesn’t take any priority.
After doing that, and maybe reloading php8.2-fpm service, can you try to upload an image please ?

Yep, after removing
group = pixelfed

and restarting php8.2-fpm service uploading works good.

but importing not.

I had to chown again to pictures appear. without it still “no preview avaliable”

Ok so there is another issue, specific to imports…
I’ve asked on upstream repository for help, as I don’t understand how imports works.

Ok, if there is something more to test, let me know.

1 Like

Any news from upstream?