Piwigo: pas de thème, problème d'affichage

Mon serveur YunoHost

Matériel: Raspberry Pi à la maison
Version de YunoHost: 11.2.10.3
J’ai accès à mon serveur : En SSH et Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non
Si votre requête est liée à une applicatio, précisez son nom et sa version: Piwigo v14.3.0~ynh1

Description du problème

Bonjour,

J’ai installé Piwigo depuis l’interface web administrateur de Yunohost. Tout ok, juste quelques Warnings. Voir le log de l’installation: https://paste.yunohost.org/raw/habenisigu

Mais lorsque j’ouvre l’application piwigo, j’obtiens une page avec uniquement du texte sous fond blanc et quelques liens, type html, mais pas du tout une interface graphique, sans aucun thème graphique.

Problème de script php ou autre qui n’est pas appliqué?
Comment faire pour voir d’où vient le problème?

Merci de votre aide!

Olivier

Suite à un crash disque, j’ai dû réinstaller piwigo de zéro (avec accès public) et je rencontre exactement le même problème sur une architecture amd64.

En ouvrant la console de chromium, je trouve les erreurs suivantes :

Refused to execute script from 'https://[mon_domaine]/yunohost/sso/?r=aHR0cHM6Ly9iYW5xdWlzZS5taWlpLmZyL3luaHRoZW1lL2N1c3RvbV9wb3J0YWwuanM=' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
piwigo/:1 Refused to apply style from 'https://[mon_domaine]/yunohost/sso/?r=aHR0cHM6Ly9iYW5xdWlzZS5taWlpLmZyL3luaF9vdmVybGF5LmNzcw==' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled.
piwigo/:1 Refused to apply style from 'https://[mon_domaine]/yunohost/sso/?r=aHR0cHM6Ly9iYW5xdWlzZS5taWlpLmZyL3luaHRoZW1lL2N1c3RvbV9vdmVybGF5LmNzcw==' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled.

Ca ressemble à un problème de configuration nginx/ssowat (les js/css recherchés seraient remplacés à la volée par la page d’authentification du portail) mais après une brève consultation des fichiers /etc/ssowat/conf.json et /etc/nginx/conf.d/[mon_domaine].d/piwigo.conf, je n’ai rien trouvé qui me sautait aux yeux…

Je précise que cette conf est loin d’être ma tasse de thé et que si le problème vient bien de là, je ne suis pas sûr de savoir le détecter.

Est-ce qu’une bonne âme pourrait nous guider ?

Salut,

Il y a plusieurs causes possibles à ton problème.

  • Le thème Piwigo par défaut est peut être corrompu ou incompatible.
  • Des fichiers nécessaires à l’interface graphique peuvent être manquants.
  • Des erreurs dans le code PHP de Piwigo peuvent empêcher l’affichage correct de l’interface.

Tu devras donc effectuer des diagnostics en premier lieu. Tu peux essayer ces manipulations pour voir ce que ça donne:

  • Pour le problème de thème, essaie un autre thème, par exemple “Elegant”. Pour ce faire, accède à l’administration de Piwigo, puis va dans configuration et ensuite dans les thèmes. Si le problème disparaît, alors c’est bon.

  • Pour le problème des fichiers manquants de l’interface graphique, fait une vérification de l’intégrité des fichiers. Voici comment procéder:

  • Connecte-toi à ton serveur SSH.

  • Accède au dossier de Piwigo (ton_domaine.tld/web).

  • Lance la commande “php composer.phar check-platform-req”.

  • Croisons les doigts pour que la commande ne retourne aucune erreur. Dans le cas contraire, indique ici l’erreur pour que nous puissions chercher une solution ensemble.

  • Sinon, pour les erreurs dans le code PHP de Piwigo, tu dois activer le mode debug. Voici comment faire :

  • Dans l’administration de Piwigo, va dans Configuration / Général.

  • Coche la case “Activer le mode debug” et enregistre les modifications.

Normalement, en cas d’erreur, elle sera indiquée en bas de la page. C’est comme ça que nous pourrons corriger le problème.

Bonne chance

Bonjour

J’ai le même problème. Un ami qui a une installation Piwigo fonctionnelle a installé une seconde instance qui a aussi ce même problème (la première instance installée depuis longtemps continue à fonctionner normalement).

Merci @Flamm3 pour ton aide!

  • J’ai changé de thème (jai choisi “Elegant” (pas évident de naviguer sans interface graphique, mais on y arrive en tatonnant…): toujours pareil, même présentation sans menu, ni fenêtre, etc…

  • J’ai tenté de vérifier l’intégrité des fichiers. Pour cela, je me suis connecté en ssh à mon serveur, et je suis allé sur:
    /var/www/piwigo. En y allant lançant la commande php composer.phar check-platform-req, j’obtiens la réponse: Could not open input file: composer.phar.
    Et effectivement, ce fichier ne figure pas dans ce répertoire.
    Je ne suis pas au bon endroit?

  • J’ai ensuite essayé d’activer le mode DEBUG, sans succès.

Dans piwigo (avec uniquement un menu sans interface graphique…), je vais dans Admin / Configuration, et j’ai uniquement une liste à puces avec 4 options: Options / Menus / Langues/ Thèmes.

Je ne dois pas avoir accès à une véritable interface de Configuration pour l’adminstrateur. Est-ce possible de passer en mode DEBUG avec une commande ?

Merci!

Olivier

J’ai eu le même problème qui a été résolu avec la toute dernière installation que j’ai faite il y a 3 jours, mais reste le pb d’affichage des images, j’ai fait un post à ce sujet

Bonjour,

En ce qui me concerne, j’ai le même problème sur une installation faite à l’instant.

Mon VPS est tout neuf, l’install de Yunohost aussi du coup. J’ai testé sur deux navigateurs : mon Firefox habituel (avec pas mal d’extensions et de configs orientées vie privée, pouvant avoir un impact) et un Chromium qui lui est avec tous les réglages par défaut. Même comportement dans les deux cas.

Ci-dessous l’ensemble des requêtes exécutées pour afficher la page d’accueil de Piwigo.

J’ai trouvé une “solution”, il faut installer piwigo sur son propre domaine et ca passe…

J’ai testé et je confirme : même une install dans un sous-domaine du domaine par défaut est suffisante pour faire disparaître le problème.

Oui pardon quand je disais sur son prorpre domaine je voulais sans url après le domaine juste \ .

Bonsoir,

Comment fait-on pour installer une application dans un sous-domaine?

J’ai déjà d’autres applications installées dans mon domaine, avec un sous-chemin, du style: mon.dommaine.fr/nextcloud

Merci!

Depuis la liste des domaines, un sous-domaine se crée comme un domaine normal, c’est juste le nom qui change : si le domaine principal est mondomaine.tld, il suffit de l’appeler par exemple piwigo.mondomaine.tld. Il deviendra automatiquement un sous-domaine de mondomaine.tld

Ensuite, à l’installation de Piwigo, ce sous-domaine est proposé dans la listes des domaines sur lequel installer l’appli. Pour contourner le problème évoqué ici, il faut en plus s’assurer de l’installer à la racine du sous domaine (chemin “/” au lieu du chemin “/piwigo/” proposé par défaut)