Piwigo package updated!

,

Hello,
Could you please try to install piwigo from the command line interface, like this:

yunohost app install piwigo --verbose

and share the output (for example on https://paste.yunohost.org/)?

If you want to try another application that uses mysql, you can try to install Kanboard. But the mysql password will be different, as a unique password is generated for each application.

Will do tonight, at home, because impossible to copy from shell in a box to file…
but yunohost app install piwigo --verbose doesn’t work, (unknown application) I need to tape.

yunohost app install https://github.com/YunoHost-Apps/piwigo_ynh --verbose

does I have to update something (I use version 2.5.5).

OK, that’s not a problem. I assumed you had activated the community repository this way:

sudo yunohost app fetchlist -n community -u https://yunohost.org/community.json

It allows you to install community applications just by their name.

For the log, can’t you just copy/paste from shell in a box to paste.yunohost.org?

Nice trick :slight_smile: thanks. for shell in a box… dunno why but each lines are in a row or a html table so to copy… will do once I will on my private network (directly ssh connected).

here

https://paste.yunohost.org/leqayusece.diff hope it can help.

First, sorry that I misread your prior post, the command fails on mysql connection using root user: so the same password should appear in every app installation (that creates a MySQL database).
I was (wrongly) talking about the password that was generated for the MySQL user that is created during every app installation.

So for your problem: it seems your MySQL root password has changed…

  • Did you try installing another application?
  • Can you connect to MySQL this way?
sudo mysql -uroot -p`sudo cat /etc/yunohost/mysql`

pi@yunohost:~ $ sudo mysql -uroot -psudo cat /etc/yunohost/mysql
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

For installing another application… have a name… (just to try). the only thing I know, is I only used the interterface to install so…

For another application, you can try Kanboard.
But your test just proves that your MySQL root password has been changed: the /etc/yunohost/mysql contains the root password, so what you just tested shouldn’t fail… And any app installation (that requires MySQL) will fail as well.
Do you remember changing MySQL root password?

no… for wich reason I would like to change ? The only thing I do is install and uninstall applications via the interface and apt-get update apt-get dist-upgrade…

How can I repair ? must I have to reinstall everything ?

Hopefully you won’t have to reinstall everything, we’ll help you towards that goal. Yet, the fact that MySQL root password changed is puzzling…
Could you please change MySQL root password following Tostaki’s answer on this post here and report back: Kanboard installation error? ?
Good luck!

I like the good luck thing :-D… I’ will do that during the week … after a full copy of my memory card… (#yunoincase).

Hi guys,

I can’t even start the process… here the log. any ideas ? (tried as root and as user).
I continue to find but if something goes your mind.

https://paste.yunohost.org/malewuxemi.vhdl

mysqld process must be executed by mysql user:

sudo -u mysql mysqld --skip-grant-tables

Thanks, after looked, I ve already tried as root (–user=root) but I have this message

170302 11:29:06 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11
170302 11:29:06 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.
170302 11:29:07 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11
170302 11:29:07 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.
170302 11:29:08 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11
170302 11:29:08 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.

but when I tried to move as the fix says;

pi@yunohost:~ $ sudo mv /usr/local/mysql/data/ibdata1 /usr/local/mysql/data/ibdata1.bak
mv: cannot stat ‘/usr/local/mysql/data/ibdata1’: No such file or directory
pi@yunohost:~ $ ^C

I don’t have idbdata1.

So, if I understand well:

  • you managed to apply the commands in the first part of the solution, until the “Fix for MySQL “Unable to lock ibdata1” error” part, right?
  • if that’s the case, were you able to restart mysql and log in with root user with the newly defined password?
  • with which command do you produce the above error log (Unable to lock ./ibadata1)?

nothing…

I mean, just to be shure…

  • I stop/start the raspberry (to be shure)
  • I connect as ssh to the rasberry
  • tape sudo -u mysql …

that’s all

For information: I checked the mysql password with my img that I ve done 3 months ago (when I installed yunohost) it’s the same password. So I don’t think it’s an application who change it in fact…

here my terminal with ssh connection and the only command tape

WORD OF THE SESSION: GUISE
MEANING : OUTWARD APPEARANCE; FALSE APPEARANCE; PRETENSE

elekis@carla:~$ ssh 192.168.178.27 -l pi

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Mar 2 11:28:52 2017 from carla.fritz.box
pi@yunohost:~ $ sudo -u mysql mysqld --skip-grant-tables
170302 11:42:46 [Note] mysqld (mysqld 10.0.29-MariaDB-0+deb8u1) starting as process 1681 …
170302 11:42:46 [Note] InnoDB: Using mutexes to ref count buffer pool pages
170302 11:42:46 [Note] InnoDB: The InnoDB memory heap is disabled
170302 11:42:46 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
170302 11:42:46 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
170302 11:42:46 [Note] InnoDB: Compressed tables use zlib 1.2.8
170302 11:42:46 [Note] InnoDB: Using Linux native AIO
170302 11:42:46 [Note] InnoDB: Not using CPU crc32 instructions
170302 11:42:46 [Note] InnoDB: Initializing buffer pool, size = 128.0M
170302 11:42:46 [Note] InnoDB: Completed initialization of buffer pool
170302 11:42:46 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11
170302 11:42:46 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.
170302 11:42:46 [Note] InnoDB: Retrying to lock the first data file
170302 11:42:47 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11
170302 11:42:47 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.
170302 11:42:48 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11
170302 11:42:48 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.
170302 11:42:49 [ERROR] InnoDB: Unable to lock ./

OK, you have to stop mysql before executing the command (the idea is to launch mysql in a special mode):

sudo systemctl stop mysql

oki, everything works now. (I saved the password in my keepass also :-D).

  • new password ok
  • sudo mysql -uroot -psudo cat /etc/yunohost/mysql work
  • restart raspberry and check kanboard: work
  • piwigo installation… work (ouais…:-D).

thanks for all, I own you a chocolate box.

1 Like

Great news!
No need for a chocolate box, just spread the YunoHost love! :love_letter:

The Piwigo YunoHost app has been refactored and updated to version 2.9.0!

Changelog excerpt:

Design matters. This is what recent user testing sessions have clearly revealed. This is why this version 2.9 focuses on refreshing our design, for the administration pages. Of course we have also added a few features, improved ergonomy and made your Piwigo even faster. A few weeks after its 15th birthday, Piwigo releases its version 2.9. Happy update!

Screenshot

You can read the complete changelog here.

Happy upgrading! :wink: