Piwigo not working "out of the box"

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 11.2.12
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no special context
If your request is related to an app, specify its name and version: piwigo version: 14.3.0~ynh1

Description of my issue

Hi Folks,
First of all, thank you for any information and for creating this software/forum.
I’m looking for help with Piwigo. I did a fresh install (have never used piwigo), and then followed the recommended steps for adding a batch of photos (using filezilla), and I now apparently have a few hundred photos in a folder called “galleries”, at least according to filezilla and the linux terminal. But Piwigo disagrees. :wink: I’m getting an error but don’t know what to do about it:

List of errors
[./galleries/] PWG-ERROR-NO-FS (File/directory read error)

so does this mean piwigo doesn’t see the galleries folder?

Here’s the view from FileZilla, so you can see I’m not crazy (ok, maybe a little):
Screenshot_2024-06-03_12-18-01

Or maybe I’m not understanding how to use the Piwigo interface? Seems like a fresh install “should just work” - like I shouldn’t have to tweak the folder name (I assume that’s the error there).

Anyway, if someone could help me figure this out; no hurry, this isn’t life or death, right? Thanks again.

Hi Mango,

I think Piwigo has the same flow as Nextcloud in this regard:

  • use the website to upload; ok for single files, more cumbersome for many files, but have them recognized by the system directly
  • or use any tool to drop files via the back door, and manually push the system to scan for new items

On the Piwigo forum I found an old thread, that mentions:

(…) Then use the Tools/Synchronize to make Piwigo take into account your pictures/videos.

I don’t know Piwigo, and it’s an old thread, but maybe you can find that option with some clicking around in the interface.

Ok, yeah, I tried the “tools/synchronize” option, and it doesn’t seem to do anything. tried it several times.

I’m running into a lot of apps on yunohost that basically don’t work out of the box. like at all. it’s a bit frustrating, really.

If I don’t see a good option with piwigo, I guess I’ll just move on to another app. there’s got to be one that works, right?

Hahaha, I’d say so :wink:

It does not seem you are terribly lucky in your endeavors.

Reading your other posts, a recurring thread is problems with file access. Yunohost is built as an Internet facing server, and comes with tight security. One user can not ‘just like that’ access another user’s files, and one program can not ‘just like that’ access any user’s files.

Besides the direct owner/group/other permissions, there are access control lists in place. I just realize that could be your problem in this case when uploading photos as one user, and then asking Piwigo to scan those files: the system user for Piwigo may not have access to the files you uploaded.

Have you tried uploading using Piwigo’s interface?

As an aside, for other apps: do you want to create a publicly visible photo album, or ‘invite only’?

Hello,

For me, let alone this uploading issue, I could not really view anything in piwigo. The interface was broken, and since I imagine the intent for piwigo is viewing stored photos and not simply storing them, it’s in a completely broken state. see here.
I’m curious what your piwigo homepage looks like. Is it as broken as it is in the linked github issue? What hardware are you using?

Depending on your use case, I have a few alternative suggestions that I have found to just work:
Storage but has a preview:
filebrowser
nextcloud (the files section)
For viewing in a gallery setting:
Immich (active development)
nextcloud (gallery)
photoprism (paid for themes + limited settings)

There are pros and cons to each of these. Nextcloud, you may need to configure it further once you install it (install a plugin, but they have a nice web interface)
Immich is very nice, but since it is active development they suggest to not use it to back up, as files could possibly be lost. Photoprism by default removes ‘NSFW’ content uploaded, but I’m not sure what it deems to be nsfw, and it scares me if I’m trying to back up something and it gets a NSFW false positive. Can be toggled, but requires modifying a config file, no easily accessible setting. I’ve had it told me it’s removing something even though I guarantee nothing I uploaded was NSFW.

Things that don’t work for photos (or so I’ve found the hard way): Lychee (can’t log in), Piwigo (malformed interface).

I hope this helps.

2 Likes

thanks for confirming the broken interface with Piwigo. Maybe others will find this thread and realize “it’s not them”. :wink:

Best regards!

1 Like

was going for public and private photos:

  • public for sharing
  • and some private for family/friends only.