Pilea - A little dashboard to analyse your electricity consumption data from Linky


#21

Well data should appear on homepage on mobile too :frowning:
I’ve just solved another bug on date on december, it may solve you problem too.

I’ve not triggered a new release, i’m gonna do it next week


#22

Hello all,

Installation OK and it’s work !

thx for this application

martoni


#23

Hi,

I’ve just update this package to Pilea 0.2.3 which corrects some bugs :slight_smile:


#24

Hello @enuts,

How can i do to upgrade pilea ?
My installation is OK but it’s the first time that i install a no official package in Yunohost.
Could you help me to respect a good process ?

thx

martoni


#25

Hi @martoni35,

It should work as an official app:

  1. go to admin panel
  2. go to update system
  3. in the second section, you should see that an update is available for Pilea !

#26

Hello,

It’s not working for me :slight_smile:


image

Could you help me ?

martoni


#27

@martoni35

I don’t know exactly why you can’t do it via the admin UI :confused:

You can try via ssh launching this command:

yunohost app upgrade pilea -u https://github.com/YunoHost-Apps/pilea_ynh

#28

Hello @enuts,

Your cli process is better and works successfully :

Thx to help,
But, i check the release number and there is always the old version :

martoni


#29

Oops’

I haven’t updated the manifest, it’s now done !


#30

Hello,

Now, it’s OK, thx a lot !!

martoni


#31

I just tried to upgrade, but I have this error log :
https://paste.yunohost.org/mufoyudafi.php

Here are the last lines of the log :

2019-01-11 14:59:02,767: DEBUG - + sudo yunohost backup list
2019-01-11 14:59:02,768: DEBUG - + grep -q pilea-pre-upgrade1
2019-01-11 14:59:03,573: DEBUG - + sudo BACKUP_CORE_ONLY=1 yunohost backup create --apps pilea --name pilea-pre-upgrade1
2019-01-11 14:59:06,886: WARNING - !!
2019-01-11 14:59:06,893: WARNING -   pilea's script has encountered an error. Its execution was cancelled.
2019-01-11 14:59:06,894: WARNING - !!
2019-01-11 14:59:06,895: WARNING - 
2019-01-11 14:59:07,099: WARNING - Impossible de sauvegarder l’application « pilea »
2019-01-11 14:59:07,102: WARNING - Il n’y a rien à sauvegarder
2019-01-11 14:59:07,228: ERROR - Impossible de mettre à jour pilea

#32

@Mamie that’s strange !

I can’t do it right now, but I’m gonna do some tests to see if I can reproduce.

Have you tried just once ?


#33

I tried many times, from the web interface and with the command line, with the same result every time.
I also tried to just save the application with an error too :
Il n’y a rien à sauvegarder
Impossible de sauvegarder l’application « pilea »
!!
pilea’s script has encountered an error. Its execution was cancelled.
!!


#34

Nice ! Thanks @enuts for this application. Makes me want to package https://emoncms.org/ which can be used without linky. (and hopefully at some point the data can be used with the awesome visualisations pilea provide)


#35

@arthurlutz I answer you on the github issue


#36

Just for information, I manually saved the database using mysqldump, then uninstalled pilea, and then installed it, so I think I’m up to date now.

I then tried to make a backup from the web interface, with an error message “nothing to backup”.
So I think I’ll be stuck again in next update :frowning:

Just in case, I’m using YunoHost 3.4.0 (testing).


#37

I haven’t found time to test it yet, but last time I tried an update it seems to worked and I haven’t touch anything since :confused:

Last jobs in CI tell that backup feature is ok so it may comes from Yunohost 3.4.0 ?

I gonna try to test it this noon


#38

@Mamie on fresh install of yunohost, I’ve :

  • Installed Pilea and collected some data
  • Tried to backup and restore : ok
  • Tried to update : ok

Don’t know what’s wrong with your installation :confused:


#39

I have no idea, but I just tried again, with still the same result : nothing to save in Pilea


#40

Is there a way to fetch all old data without telling it a timestamp ?