Pi-hole - NO internet access

ynh 1.0.10.2
Pi-hole5.13~ynh1
raspi 4 homeserver

after Pi-hole installation i did go to
pihole/settings.php and clicked on the DHCP tab and enabled the DHCP server

in my Fritzbox router i disabled the DHCP server
https://docs.pi-hole.net/routers/fritzbox/
as written here
“So you need to turn off your router’s DHCP server and let Pi-hole manage your network.”

when i reconnect my devices to WLAN the don’t get internet access

What i 'm doing wrong?

What could I try - thanks for help

a router without dns? that sounds weird to me
where it should take a dns from?

where is your pi-hole installed on? computer? other device?
whats the structure?

1 Like

sorry - i 'm on a raspi at home

okay so the structure is like this->

router → raspberry → home computers
right?

yes

as if i do understand you well, you did disabled any dns’s on your router?
you should set your pi-hole ip instead of your ISP’s dns on your router

Yes - as you say - it is described here: Fritz!Box (EN) - Pi-hole documentation

but here they say “turn off your router’s DHCP server and let Pi-hole manage your network.”

How can i find the pi-hole ip ?

dont be cconfused with WAN DNS AND LAN DNS
there are two dns to be in use on routers interfaces,
one is the WAN what will connect to your IPS’s server that you don’t ever need to modify whatsoever, unless you want to change it to cloudflare or any other (but never local) otherwise you will not have an internet at all,

the other DNS on LAN is on the DHCP server option on your router,
that one you are allowed to modify with no fears,

your PI-Hole ip is the DHCP ip your router dedicated to it,
you go to dhcp server option, and you should see something like “clients list”
there you wll see all of your current connected devices including your raspberry pi, there should be a host name identifier what should make it easy to recognize it, and if not anyway you have MAC addresses over there, please take a look on my router how its looks like for example:

hope it helps, update me if you have any farther questions

by the way what’s the sense to “turn off your DHCP server” on your router?
what will distribute ip’s for the devices?!
DHCP always need to be enabled otherwise it will stop to be a “router” and will become a “HUB”

what’s the difference between routers and hubs :slight_smile: the DHCP.

i saw some interface photos of your router is the weirdest router i ever seen, its looks like no clients option,

go to your yunhost command line and type:
sudo ifconfig
it should show you your ip,

also i am not expert in pi-hole but i thnk you should see your pi-hole dhcp client ip on pi-hole admin

1 Like

THANKS

So mean i don’t have to do anything?

if i enable the DHCP server on Pi-hole i see this:

I have this kind of Router

What do I have to sett there?
Thanks for your help

METHOD 1:
go to your router and uncheck the DHCP server to stop leasing devices through it

on your pi-hole change the range segment to:
from 192.168.1.101 to 192.168.1.250
gateway: 192.168.1.100
domain name: piholeLAN

go to your one of your devices and try to ping the pi-hole router gateway,
ping 192.168.1.100

if you are on windows machine type:
ipconfig /renew
and then ping 192.168.1.100

if you’re getting a ping from the pi-hole its means the pi-hole connected properly to the network and you’re ready to get a DHCP lease from it,
type ipconfig /all (windows)

and check if your “default gateway” is the pi-hole gateway (192.168.1.100)
thats it you should get the internet from pi-hole try to brows,

if you have set a static ip and defined DNS manually at the past on your adapter card you need to change it to automatic
by right click on your internet connection icon



click on ethernet

change adapter settings

click properties

that’s it actually you should have a connection to the pi-hole

check ipconfig /all for your card adapter whether its a wireless cable and check if your getting the pi-hole gateway

if yes, and you have internet connection so you’re done

on linux machines there is nothing to do its already supposed to be set to automatic

oh and i forgot,
ipconfig /all should be executed by cmd
if you dont know how to reach cmd right click on your start button
and chose:
command prompt (admin)



in my case the default gateway is 192.168.1.1
in your case it should be 192.168.1.100

in my case the ip address is 192.168.1.10
in your case it should be 192.168.1.101 (or higher)

METHOD 2:
according to your router manufacturer instructions you have an option integrated into that specific router to implement an internal network DNS

on the “local DNS server”
you should set your pi-hole gateway:
192.168.1.100
disconnect your devices from the router by disable the adapter and re-enable on the same adapter page i pasted above to get a new lease from the router and make sure all set to automatic as mentioned above

now you will get the DNS from the pi-hole but your adapter gateway will not change it will the same as your router’s gateway
in such case it will be hard to know if you really gets the DNS from pi-hole
so i suggest you to block a website on your pi-hole and check if youre able to reach it on your browser

METHOD 3:
as you supposed to set the pi-hole ip address on your router’s “local DNS” option,
and i am not sure if its right to set the default gateway which looks none sense,
and becasue earlier i did mentioned you should know your pi-hole IP by going to clients and you dont find’s it on your router,

so now i am teaching you how to do some very deep scanning for your network,
and find all of your connected devices on the ring,

on windows machine download a tool called WNetWatcher its a nirsoft tool for scanning all of the devices on the network even the hidden once,
you can download it here:

open the scan tool and supposed to show you your PI-hole ip address
if you finds the pi-hole ip address set it to your router’s “local DNS” option as mentioned above

that’s not supposed to be like this its supposed to be simple,
average user will just go to the routers DHCP clients but in your case it require some advanced tasks

THANkS for your help.

I tried METHOD 2 and it does not work - do i have to activate blocking form adds exrtra in PI-HOLE?

please read all what i wrote you need to make sure you know the exact pi-hole ip on your router
thats why you need to check it out with the nirsoft executable,
if your pi-hole have an ip from the router (method 2) means your router dhcp is not diabled on your router and pi-hole should have its own ip, that ip have to be inserted into the “local dns option on your router”

in that case you should have internett connection anyway cause youre not disabling the routers DHCP
but to make sure your dns is served by pi-hole you need to renew the lease of your devices (computers) by disconnect them and reconnect and then block a website on pi-hole and check if youre able to reach it,

what do you mean by “not working” you dont have internet connection in method 2?
or you still using method 1 (without router dhcp) ?

i just installed pi-hole on debian (not yunohost) to check how it is working
i found where can see all the network devices on it including the pi-hole itself

as you can see in my case i did configured it to use a static ip as 192.168.1.30 on my router so i dont need to disable dhcp on my router, i can just use the pi-hole address as dns which is 192.168.1.30

in your case you need to check what is your address and paste it into the “local DNS” on your router
hope its clear,