phpLDAP "insufficent access" trying to perform ldap_modify_operation

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.3
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: phpLDAPadmin

Description of my issue

Previously (months ago) I have created an email alias for a group by adding the “MailGroup” value to the posixGroup object and then adding an email address.

Today I logged in to phpAdmin as the admin user (uid=admin,ou=users), navigated to the group I wanted to add an email address to, navigated to the “objectClass” area at the bottom, then clicked “add value” below the “posixGroup” object at the bottom. I then selected “mailGroup” from the list of valid values and clicked “add object” which took me to a prompt for the email address. After entering my email address, I clicked the “add objectClass and attributes” button, then the “update object” button on the next screen but was then presented with the error:

Could not perform ldap_modify operation.
LDAP said:	Insufficient access
Description:	You do not have sufficient permissions to perform that operation.

I tried logging out of phpLDAP and back in as myself (my own login is also a member of the Admin group) but got the same result.

What do I need to do to have the necessary permissions to update the LDAP database? I would have thought that being the original Admin user, or another member of the Admin group would be adequate?


Waikiki, Western Australia

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.