Php7.3-redis : Depends: libzstd1 (>= 1.3.2) but 1.1.2-1+deb9u1 is to be installed

My YunoHost server

Hardware: VPS bought online / Old laptop or computer
YunoHost version: 3.8.6
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

since some times (before end of december) I try to upgrade my v3 to v4 but the php7.3-redis package is stuck and I cannot go further in the upgrade

 php7.3-redis : Depends: libzstd1 (>= 1.3.2) but 1.1.2-1+deb9u1 is to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo yunohost tools upgrade --system
Info: Upgrading packages...
Info: Now upgrading 'regular' (non-yunohost-related) packages…
Info: + Reading package lists...
Info: + Building dependency tree...
Info: + Reading state information...
Info: + Calculating upgrade...
Info: + The following packages were automatically installed and are no longer required:
Info: +   linux-image-4.9.0-12-amd64 linux-image-4.9.0-15-amd64
Info: + Use 'sudo apt autoremove' to remove them.
Info: + 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Success! System upgraded

$ sudo yunohost tools migrations migrate --accept-disclaimer
Info: Running migration 0015_migrate_to_buster...
Info: Fetching available upgrades for system packages...
Error: Migration 0015_migrate_to_buster did not complete, aborting. Error: Your system is not fully up-to-date. Please perform a regular upgrade before running the migration to Buster.
Info: The operation 'Run migrations' could not be completed. Please share the full log of this operation using the command 'yunohost log display 20220221-144409-tools_migrations_migrate_forward --share' to get help

I tried both by direct command / ssh or through the webinterface, it gives an error when doing the migration because of the system not up to date

is there a way to force the migration ?

Can you share the output of apt policy libzstd1

$ sudo apt policy libzstd1
  Installed: 1.1.2-1+deb9u1
  Candidate: 1.1.2-1+deb9u1
  Version table:
     1.4.8+dfsg-2+0~20210302.3+debian9~1.gbp8effd2 200
        200 stretch/main amd64 Packages
 *** 1.1.2-1+deb9u1 500
        500 stretch/updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.1.2-1 500
        500 stretch/main amd64 Packages

Theeeeen let’s try to apt install php7.3-redis libzstd1

already done hat actually (first part of my message)

$ sudo apt install php7.3-redis libzstd1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libzstd1 is already the newest version (1.1.2-1+deb9u1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php7.3-redis : Depends: libzstd1 (>= 1.3.2) but 1.1.2-1+deb9u1 is to be installed
E: Unable to correct problems, you have held broken packages.

ok so I see that libzstd1 version 1.4.8+dfsg-2+0~20210302.3+debian9~1.gbp8effd2 is available so I forced it installation with

$ sudo apt install libzstd1=1.4.8+dfsg-2+0~20210302.3+debian9~1.gbp8effd2

then reinstalled php7.3-redis
then relaunched the migration and it pass the step …

thanks, hope it helps if some other fall on that small hole too :wink:

(edit : I also had added the buster-backport in the /etc/apt/source.list … maybe it helps for that version being available … )

(edit 2 : migration to v4 went all good after that :wink: )

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.