Photonix installation fails

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version:
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue


I’m trying to install Photonix through Yunohost. It fails and gives me the following error:

ERROR - Unable to install photonix: An error occurred inside the app installation script

I don’t know what this means or how to fix it. In the log, there are also two warnings. I don’t know if they are causing the error:

WARNING - W: GPG error: buster-backports InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 648ACFD622F3D138 NO_PUBKEY 0E98404D386FA1D9
WARNING - E: The repository ' buster-backports InRelease' is not signed.

Here is the full log:

Does anyone know how to go about fixing this? or working around it?


Hmokay that sounds like an issue that may have been triggered by something else before installing photonix …

Can you share the output of grep -nr '' /etc/apt/sources.list* ?

Thank you for your reply. I tried installing it again and got the same problem and the output looks identical. Nonetheless, here is the new output:

grep -nr '' /etc/apt/sources.list*

Doesn’t output anything. The file /etc/apt/sources.list only contains

deb buster main contrib non-free rpi

The file /etc/apt/sources.list.d/photonix.list contains

deb stable main

Does that help? I have other *.list files corresponding to other apps.

– Edit to add - -

The webadmin throws out an error when I try to update. And when I run sudo apt-get update on the command line I see that it’s the same public key error. So I update the distro, and then use checkrestart and clean up some old files. (I followed yunohost’s troubleshoot guide up until that point).

The public key error still persists, so I read up on keys and keyservers, and I try to add the keys in the error with

gpg --keyserver --recv-keys <PUBLIC_KEY>

Which gives me the following for both keys (except the first line, it only appeared when I ran the command for the first time)

gpg: keybox '/home/admin/.gnupg/pubring.kbx' created
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

And the error still persists. So based on this, it looks like the server can’t get the public keys for, or at least not from

Am I understanding the problem correctly or am I off on a wild goose chase?

– Edit again—

I tried getting the keys without specifying server:

$ gpg --recv-keys 648ACFD622F3D138
gpg: key DC30D7C23CBBABEE: new key but contains no user ID - skipped
gpg: Total number processed: 1
gpg:           w/o user IDs: 1

It still throws out the public key’s error.

Thanks for your help

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.