Persistent SSL Certificate Error for WWW Subdomain on YunoHost Server

Hey YunoHost Forum Community,

I’m encountering a persistent SSL certificate error for the WWW subdomain on my YunoHost server. Despite running system updates and diagnostics, the issue lingers.

I issued the SSL certificate using the web-admin, and HTTP is set to force HTTPS. The error affects all domains hosted with YunoHost. I’ve checked /etc/yunohost/certs, web-admin settings, and verified the server date and firewall settings.

I kindly request your expertise to identify the root cause and help me find a suitable solution. Your assistance is immensely appreciated.

Server Details:

  • Hardware: Lenovo M82 i5-3470, 8GB RAM, 500GB SSD
  • Internet: Gigabit fiber from Bell Canada
  • Hosting: At home
  • Access: SSH, webadmin, direct access

Issue Details:

  • Persistent SSL certificate error for the WWW subdomain on all hosted domains.
  • System updates performed and diagnostics show no major issues (ignoring non-relevant items).
  • Server date and firewall settings have been verified.

Troubleshooting Steps Taken:

  • Ran system updates and diagnostics (results show as “okay”).
  • Checked /etc/yunohost/certs and web-admin settings.
  • HTTP set to force HTTPS.
  • SSL certificate issued using web-admin.
  • Confirmed that DNS record flagged as missing in diagnostics exists in the zone file.
  • Verified server date and checked firewall settings.

Request for Assistance: Despite the above efforts, the SSL certificate error for the WWW subdomain persists. I kindly request assistance in identifying the root cause and finding a suitable solution. Any additional troubleshooting steps or insights would be highly appreciated.

Note: Your support and guidance in resolving this persistent SSL certificate error are greatly appreciated. Thank you for your assistance.

I had this issue while experimenting with YunoHost the other day as well. For some reason it seems that even when the primary domain correctly uses a LetsEncrypt SSL certificate, the www subdomain continues to serve the self-signed one. The workaround I found was to explicitly add as a secondary domain in the admin panel and request another certificate for that one as well.

1 Like

Did you also have to assign to the WWW the application running on the

I didn’t need to change the default application for the subdomain. After requesting certificates, it just redirected to the root domain which is what I wanted.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.