[Peertube] Video p2p streaming federated platform


I am happy to announce the addition of Peertube app on YunoHost.

Cl latest result: YunoHost Portal

Peertube is a federated (ActivityPub) video streaming platform using P2P (BitTorrent) directly in the web browser with WebTorrent. Know more here

Claims the following features:

  • Install
  • Remove
  • Upgrade
  • Backup
  • Restore
  • Multi-instance

Please feel free to test and open an issues here.

Note: Peertube is still in beta stage and there maybe bug yet to be fixed. These bugs are not related to packaging of the app. If you find any bug please open an issue on the Peertube issue page directly.


It would be helpful if someone can give a feedback on why Peertube should be served in private mode, when it has its authentication mechanism for the videos. Case maybe when you only want to seed keeping the main interface hidden :slight_smile: . I am not sure that it will work,or if its good idea.
If there is no use to keep app private, I will remove this option from the installation.

I will not have the time to do a review before several weeks, but I can tell you that the private “mode” will be useful, at least for me (well, actually it’s for a friend that want some videos to be viewable only by his YunoHost users, and not downloadable, so he doesn’t want to put them in Nextcloud)

Thanks for your job anyway ! Will try to review the app ASAP.

If the person know the seeding address of the video hosted, the video can be watched on other instances, I guess.

For eg. This e2651856-4809-408a-99d4-b85b01fefb09
can be viewed on (see the link address,its different for each video with same seeding address)

and here

These both instances are different but playing the same video originally hosted here.

So the interface will be private but the instance will be not private. You will have to close the port of the peertube to make it completely private. But this defeat aim of Peertube because there are other number of ways to host videos on client and server architecture. Peertube is for P2P sharing like torrents.

You can even download the video in a torrents client like uTorrent, transmission,etc.

Installation through interface doesn’t seem to work properly :confused:

Here are my logs : https://framabin.org/p/?ef647df90a7ad3c9#F3YPHWNF5K3mMx9V5rENYUZ1ZgPHwYZb0n00DstwaU0=

Can you install the app from command-line and show the logs please?

yunohost app install --verbose https://github.com/YunoHost-Apps/peertube_ynh

The logs : https://framabin.org/p/?11340af9a85768f5#aGPDz3yS5xBH3qM4FUvoZ2/ZvBjRMNl9reeO7uPBrI0=

https://cloud117.fr is a YunoHost main domain. You can not install an app on it because its take by SSO.

Thus it gives you : Attention : Cette URL n’est pas disponible ou est en conflit avec une application existante which is the cause of the error.

You will need a another domain or sub-domain like video.cloud117.fr or peertube.cloud117.fr ,etc.

Hope it clarify your issue.

Thank you so much, it works :slight_smile:

I want know how the apps like NextCloud and Piwigo handles large amount data stored in /home/yunohost.app/ folder while backup and remove script run. If the data is huge the app can take long time to backup while the upgrade run and if app folder is not included in backup script, failing an upgrade could remove the apps home folder thus corruption of the app while restore.
Should the remove script delete the apps home folder or it should be dome manually by the admin?

App is updated to version v1.0.0-beta.8.

Update from admin interface or use the following command in command-line:

yunohost app upgrade -u https://github.com/YunoHost-Apps/peertube_ynh peertube --verbose

1 Like


I’m running Yunohost 2.7.12 on a raspberry pi 3.

Installation from command-line doesn’t work for me.
sudo yunohost app install --verbose https://github.com/YunoHost-Apps/peertube_ynh
Here is my log : https://framabin.org/p/?5ff3449b05760d9c#Q443BysS1HbB5s3u2t3R3tN7+LneUn/5ARsHVPk3eoE=

Any ideas ?

Can you try to install the packages manually and see what is the issue?

apt-get install postgresql ffmpeg

I’ve installed these packages manually without any issues (I guess !).
However I’ve got a really bad internet connection at the moment, download was 70 Mbit/s then suddenly 3 or 4 Mbit/s, back to 20 Mbit/s, etc… It took me ages to install these two packages !
It may explain the issues with peertube. I run a new installation and let you now.

I ran a new installation this morning. It seems to work but I still have some issues.

First, through SSH my shell is stuck at + yarn install --production --pure-lockfile --silent --cache-folder /var/cache/yarn/, here is the entire log https://framabin.org/p/?74d7918409353917#JnQBx868OOxN7xiJH//By5H8U7UtX+cc1pm6h4QhUps=
I don’t want to do Ctrl + C, it’s going to purge the installation I guess…

Second, when I go to my peertube instance i got the message “Error. Token is invalid.”

Third, I must have missed something, I got the admin password but I can’t log in (I don’t know the admin username…).

Edit : Finally it works ! I wait… Got a broken pipe with my ssh connection, reloaded my instance and no more “Token is invalid”. I could connect as admin with his email address.

I think all the problems came from my hardware and internet connection. Thanks for your help.

Hello, did you try to use both SSO login and Peertube.
Because it seems the Token Problem appears when you are connected to the SSO.
For example if you have restarted your Instance, your are not login to the SSO, right ?

Yes indeed! I’ve seen a post about that in the forum. I don’t have much time at the moment to look for that. I’m just going to wait a bit for a final release maybe.

OK! I finally got it very well! (I found time to do it!)

It may not be the right place for this post!

What I did :

  1. A new installation of peertube through SSH (it looks like through the admin web interface it doesn’t work properly!) using yunohost app install peertube.
    The shell still got stuck but I got an email from peertube app with the admin password. I’ve just waited for my shell to have a ‘broken pipe’.

  2. I made sure I wasn’t connected with SSO, then I went to the link of my instance, logged as root, everything went well, made some configurations, everything is really responsive! Logged out.

  3. When I log to my SSO, I get the PeerTube app but through this link you inevitably have an error with Invalid Token and you’re instance looks empty. So disconnect from SSO, go back to your instance of peertube and everything should work fine again.
    I should warn all my users about this!

  4. I’ve added some others instances to follow.
    Here it’s a little bit tricky, I can follow complete instances (for example framatube.org) but I don’t understand yet how to follow a specific uploader from an instance of peertube. It looks like the user has to accept the request, but I’m not sure about that.
    For example I wanted to follow khaos_farbauti, his channel is at https://peertube.nsa.ovh/accounts/khaos_farbauti/videos so I had to follow this: peertube.nsa.ovh/accounts/khaos_farbauti but nothing appeared in my following list. My guess is that I have to wait a bit for my peertube instance to do the job :wink: .

Hope this would be useful for others. I really like how PeerTube is designed / developped. I have no intention to post any video at the moment, I just want to be part of the federation and help seeding videos!

1 Like

PeerTube has been updated to version v1.0.0-beta.9.

Upgrade from command-line :

yunohost app upgrade -u https://github.com/YunoHost-Apps/peertube_ynh peertube --debug