Peertube APP from 5.2.1 to 6.0.2 Doesn't work at all. Videos don't start

My YunoHost server

Hardware: DELL Optiplex 7010
YunoHost version: (stable).
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No.
If yes, please explain:
If your request is related to an app, specify its name and version: Peertube 6.0.2~ynh1

Description of my issue

Upgraded the app using Yunohost from 5.2.1 to 6.0.2 . The domain works, i can check videos, modify them and all, but if i try to watch any of them (old or new) they don’t start at all.: Tried to re-encode them with HLS , nothing works.

There are no error messages. Here is the website if you want to check.

Same problem for me.

we still not getting any logs :confused:

error[29/12/2023 10:39:16] Client log: HLS.js error: networkError - fatal: true - manifestLoadError
“tags”: [
“username”: “serge”,
“userAgent”: “Mozilla/5.0 (Linux; Android 10; K) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Mobile Safari/537.36”,
“url”: “

Voilà l’erreur retrouvée dans le journal après le lancement d’une vidéo (j’ai changé le nom de domaine).

can you share in PeeTube NGINX config/etc/nginx/conf.d/yourpeertubedomain.tld.d/peertube.conf
the line 223 starting with root ?

root /home/;

Typo :slight_smile:

Related Github issue upgrade from 5.2.1 to 6.0.2 / video cannot play · Issue #405 · YunoHost-Apps/peertube_ynh · GitHub

The update was reverted, as it was buggy.
Please do not update any production server.
You can help testing it here : Reapply "Merge pull request #390 from YunoHost-Apps/testing" : 6.0.2 + packaging v2 + fix install 502 error + timeout on slow hardware + wait for DB full init by Tagadda · Pull Request #408 · YunoHost-Apps/peertube_ynh · GitHub

1 Like

Same problem for me… I should have wait before installing the update…
I tried :
cd /var/www/peertube/
yunohost app shell peertube
NODE_CONFIG_DIR=/var/www/peertube/config NODE_ENV=production npm run create-generate-storyboard-job – --all-videos
but the problem still exist

Is there a way to solve the probleme manually ? Can I uninstall peertube and reinstall previous version (5.2.1~ynh1 ) without loosing the videos ? I m not a pro with yunohost, and I don’t want to make bad things.
May be the best for me is waiting for a new update in yunohost ??

Thanks in advance for helping :wink:

This only generate the preview thumbnails during playback. It’s not meant to fix the issue.

Yes, it’s adviced to do that. Peertube data shouldn’t be affected (the videos are still there), and you revert to the previous state before the upgrade (the backup make automatically before the upgrade). Any changed made after the upgrade would be loosed (including comments, …), but the videos shouldn’t change.

Uninstall and reinstall, and it does not work anymore (bad gateway when trying to acces to peertube) !!
The error message in peertube log is permision denied, I must have made some mistakes…

I reply to myself,
cd /home/
sudo chown -R peertube:www-data peertube

And it seems to work !

Many thanks for the help, i will wait before installing new peertube update !!!

1 Like

It seems to be working with the current status : Reapply "Merge pull request #390 from YunoHost-Apps/testing" : 6.0.2 + packaging v2 + fix install 502 error + timeout on slow hardware + wait for DB full init by Tagadda · Pull Request #408 · YunoHost-Apps/peertube_ynh · GitHub

:warning: no guaranty, but it might help for the people who already updated and have broken playback.

1 Like

hey !
I’ve got the same issue. And found that which could help some also. I’ll try everything later to solve my issue.

I found these issues too, but I don’t think it’s related : it’s a S3 storage issue, while here it was the case for any storage type (local or S3). It’s also not an issue with the videos disappearing (they still exist).
I think it’s a common error message for the case where the video is referenced, but impossible to find.

The pull request I mentionned, which is about to be merge and released as a normal update, will fix the issue.
If you have proper backups, you may try it to fix your issue with the broken version 6.0.2~ynh1. If you’re still in version 5.2.1, you may try the upgrade and give us feedback, or wait for the normal release.

I read that github issue topic and I’ve seen that 18h ago, the merge was ready to be done ! :smiley:
I’ve any activity on my peertube, it’s a brand new.
I could try to get the new version. If you need a user to test it, just give me the link and how to update from github (I’m kinda knew to all of that), otherwise I’ll wait the update quietly ! :smiley:

yunohost app upgrade peertube -u is the command you need :slight_smile:
Thanks !


everything’s working Teaser "Toile d'artisan" - Antheli - Curk

Thank you !

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.