ownCloud login failure after YunoHost update

I just ran a apt-get upgrade on my YunoHost instance, and after the update,

The following packages have been kept back:
  metronome nginx-common nginx-extras ssowat yunohost-config yunohost-config-nginx yunohost-config-others yunohost-config-postfix
The following packages will be upgraded:
  init-system-helpers lua-socket moulinette moulinette-yunohost python-bottle yunohost yunohost-admin yunohost-config-amavis
  yunohost-config-dovecot yunohost-config-mysql yunohost-config-slapd yunohost-predepends
12 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

my ownCloud app would not allow me to login, even though the YunoHost interface accepted my same credentials (for YunoHost profile, email, etc). I have a DigitalOcean server backup from a few days ago that I am restoring because I don’t have time to hunt down the problem and fix it; I just need access to my files again. But I wanted to make a note in case others have experienced the same problem.

Please run the upgrade again this way:

apt-get update
apt-get dist-upgrade
yunohost app fetchlist
yunohost app upgrade

After that, you should have a working server.

Detailled explanation

  • apt-get update because I just built 2 new versions of moulinette-yunohost and ssowat :smile:
  • apt-get dist-upgrade because some dependencies have changed, and apt-get upgrade only upgrade packages whom dependencies have not changed.
  • yunohost app fetchlist in order to ensure that you have the latest versions of the YunoHost Apps in the repository.
  • yunohost app upgrade will upgrade all your Apps, and should correct all the blank screen issues, related to the lack of this line in the Nginx PHP configuration blocks.

Thanks for the instructions. I’m making a snapshot before I attempt the upgrade again. I’ll let you know if it works.

I performed the update as you instructed, and it looks like everything works … except my access to the ownCloud web interface. My ownCloud sync clients are connecting and syncing files with no problem, but when I try to access the web interface I just get white screens, regardless of the browser or URL I use (domain.com/owncloud/, domain.com/owncloud, domain.com/owncloud/index.php, etc). The owncloud.conf nginx config file does include the line

fastcgi_param SCRIPT_FILENAME $request_filename;

Stupid question: did you emptied the cache of your browsers?

Good question. I did, and tried across several desktop and Android browsers.

You may want to take a look at your domain’s logs: /var/log/nginx/your.domain-error.log

I’m seeing a lot of errors like this one:

2015/06/03 11:07:14 [error] 29217#0: *20 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Class OCA\Contacts\Share\Addressbook contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (OCP\Share_Backend::isShareTypeAllowed) in /var/www/owncloud/apps/contacts/lib/share/addressbook.php on line 130" while reading response header from upstream, client:, server: reticu.li, request: "GET /cloud/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-owncloud.sock:", host: "reticu.li"

I still cannot use ownCloud after updating to the latest YunoHost release. I’m completely stumped here. The only lead I have is the error message I posted above. Somehow my ownCloud sync apps (Mac and Android) still work, but I can’t access the webpage. Also, when I try to visit a previously shared link, I actually get a webpage to load, but it says the following error:

Internal Server Error
The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears
multiple times, please include the technical details below in your
More details can be found in the server log.
Technical details
Remote Address:
Request ID: ef9ee8996f3750426fff4ed1ce812127

I fixed the problem using the helpful advice from someone on Red Matrix by disabling the contacts and calendar apps:

 su owncloud -c "cd /var/www/owncloud; php occ app:disable calendar;php occ app:disable contacts" 

Unfortunately I need those apps. To re-enable them, I had to first delete the apps manually:

rm -rf /var/www/owncloud/apps/contacts/
rm -rf /var/www/owncloud/apps/calendar/

and then re-enable them through the ownCloud web interface, which must have re-downloaded them.