Owncloud installation failed

,

I just downloaded the latest stable version and tried to install owncloud from the yunohost admin web interface.
Script ran and then told me it failed
I checked the log and did not find anything suspect, but as I am no linux expert, trusted it and tried to reinstall it. but this time the error in the log was visible: owncloud database already existed. So I started remove everything linked to owncloud that got installed:
remove the database
remove user owncloud and its group
remove /var/www/owncloud
remove /etc/php5/fpm/pool.d/owncloud.conf
(took me time to do so I tried reinstall the app several time and found that it could not because the database, then because the user existed, then because the folder ownclouded existed,…)
and reinstalled - again it failed, but this time i typed mydomain.tld\owncloud in firefox before trusting the error message and tada… owncloud was there up and running

Anyone as an idea why it is so ?
Is it safe to use it?

--------EDIT-----------

Welll it installed it using admin as the owncloud administrator name, but I had chosen an other user as administrator. Also the password is different from mine so I cannot login

What happened
how can we install owncloud? and integrate it with yunohost

note : last install log lines are:

sudo yunohost app setting owncloud unprotected_uris -v /+ sudo yunohost app ssowatconfSuccès ! Configuration de SSOwat générée avec succès+ curl -kL -H ‘Host: mondomain.tld’ -X POST https://127.0.0.1/owncloud/index.php --data ‘install=true&adminlogin=admin&adminpass=???&directory=/home/yunohost.app/owncloud/data&dbtype=mysql&dbuser=owncloud&dbpass=???&dbname=owncloud&dbhost=localhost’

note : I have replaced the password by ???

Hi, I have a similar problem, but in my case, if I type mydomain/owncloud it redirects me to my user dashboard.

In fact, I accessed it once before, but I clicked anywhere (I think it was on photos) and came back to dashboard.