Open Port for Docker App


My YunoHost server

Hardware: Contabo VPS
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: installed docker

Description of my issue

I installed Restreamer on my YunoHost Server using Docker, used redirect to access the WebApp. That worked without a Problem!

But now I wanted to stream to that app using OBS (port 1935), but can’t since the Port isn’t exposed to the public.
I already tried opening the Port in the Firewall and reloaded the firewall, but that changed nothing …

It also doesn’t show up in the Diagnosis

So it seems like I didn’t open it correctly …

(It works with disabled Firewall)

How can I fix that Problem?

1 Like


That’s quite weird. I have came across something similar earlier.
Is your server protected by a cloud provider firewall? Did you try to run nmap to see exactly which ports are opened / filtered?
Did you check the list of opened ports by YunoHost through its cli?

The issue was resolved in the chatroom:

  1. Their docker run command was missing the -p 1935:1935 flag, so the port was not exposed.
  2. The firewall needed to have its port opened with yunohost firewall allow 1935 TCP after launching the container.