[Onlyoffice] Erreur 502

Matériel: PC fixe
Version de YunoHost: 3.6.5.3
J’ai accès à mon serveur : complet
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Bonjour,

Depuis plusieurs semaines, onlyoffice ne fonctionne plus. Je l’ai réinstallé, ai redémarré le serveur (pour d’autres raisons), sans que ça ne résolve quoi que ce soit.

Ah oui, j’allais oublier le log.

https://zerobin.stemy.me/?1a12361125b645c8#cG9mDIGnMc7GqS3WTy6l3FkNXOsQf/AUNWeLtz47hNE=

Solution trouvée ici

apt-get purge -y erlang erlang-nox elixir esl-erlang

echo "deb https://dl.bintray.com/rabbitmq/debian trusty main">/etc/apt/sources.list.d/rabbitmq.list

apt update

apt install rabbitmq-server

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6B73A36E6026DFCA

Ou pas. Maintenant, à la place d’une erreur 502, j’ai un écran noir quand j’essaye d’ouvrir un document.

Bonjour,
tu as installé le paquet Yunohost de OnlyOffice ? C’est résolu ? pour moi ton serveur marche à cette adresse: http://onlyoffice.stemy.me/welcome/
Par contre chez moi lors de l’installation de OnlyOffice, j’ai du choisir un chemin ou dossier pour l’installation, du coup l’url ressemble plus à https://onlyoffice.m_n_d.tld/onlyoffice ou https://onlyoffice.m_n_d.tld/onlyoffice/welcome
Au fait tu n’a pas activer le ssl ? pour le sous-domaine onlyoffice.stemy.me ?

Onlyoffice me dit qu’il fonctionne, en effet, sauf que quand j’ouvre un document, j’ai juste ça:


Et oui, let’s encrypt est activé et les urls de nextcloud et d’onlyoffice sont corrects.

Est-ce que cela ne viendrai pas de la config dans Nextcloud => Paramètres => OnlyOffice => Adresse du service d’édition de document = https://onlyoffice.stemy.me
car dans tes logs, on voit une adresse http
c’est peut-être une piste ?

Ah et aussi on voit une adresse http://docservice/welcome/
Si tu as cocher Connect to demo ONLYOFFICE Document Server, je pense que ce n’est pas une bonne idée.

The 30-day test period is over, you can no longer connect to demo ONLYOFFICE Document Server.

Ce sont 2 fausses pistes. J’avais bien mis https dans la config et le serveur démo n’est pas coché (et de toutes façons, la case est grisée).

D’ailleurs, on voit la favicon d’onlyoffice dans l’onglet quand on ouvre un document.