Only 1 site out of 3 responds "DNS zone file not found"

Hey there,

I’m having trouble with only 1/3 of my domains coming up (the other two return a ERR_CONNECTION_REFUSED error). When I look in /var/log/yunohost the only errors I see is a bunch of:

Chown: invalid spec: ‘admin’

and one:

No passwd entry for user john

(john is not the administrator user)

I checked the domain registrar and the domains are all correctly pointing to the current IP address.

All of the main services (Nginx,PHP,Mysql etc) are running.

I tried changing the default domain and back again in the hope that it would rewrite the hosts file, but it just gave me two error messages:

  1. “DNS zone file not found for domain {SUBDOMAIN}”
  2. A blank red error message box.

I ran into a problem just after I installed, where Yunohost seemed to have a problem because the main user name was something other than “admin”.

I tried:

yunohost user add admin

…but I get “Error: Attribute already exists: ‘uid=admin’”

If I try:

yunohost user delete admin

I just get:

Error: An error occurred during LDAP operation

I’m guessing this is because the “admin” user was created with useradd rather than with the yunohost app.

Any ideas about how to either create the missing DNS zone file, get the domains up or recreate the admin user?

Looks like this was actually mainly to do with my new router blocking port 80 despite having DMZ set to my Yunohost box.