domain resolution issue - autoconfig resolving it to router not server


I am going through my first install - self hosting yunohost.

Most recent downloaded version of image. I’m using a raspberry pi 1 512mb. I ran the 5 commands during setup via SSH as instructed in the setup for raspberry pi 1.

I believe the dyndns auto configuration for a domain name did not work correctly. I don’t know if this will require an update to the dyndns records.

I have access to the server through SSH locally. And, I can access the server through the IP assigned on my LAN.

I was going through the diagnosis steps, and opened port forwarding and it confirms accessible via web. I was going to install the let’s encrypt cert, and it said that it appeared I was configured for that to be possible. However, that did not work and as I continued looking around I believe it is because it could not resolve through the domain name.

What I am trying to achieve is so that the configuration of the dyndns record resolves to the internet facing IP address.

Currently, mydomain-nohost-me resolves to my routers admin panel [perhaps because during install, prior to diagnosis, port forwarding was not enabled?].

192.168.10.XXX - inside the network resolves to server. From web, does not resolve.

98.XXX.XX.XXX outside the network this resolves to server. Inside the network it resolves to router.

So, I am looking to get that 2nd IP to map to Because this is what was established with the installation dyndns auto config, I don’t believe it has to do with me manually configuring DNS settings for any external domain.

Here is the log from the DNS tab that ran during diagnosis:
domain: null
dry_run: false
dyn_host: dyndns-yunohost-org
force: false
ipv4: null
ipv6: null
key: null
ended_at: 2022-05-21 18:51:36.586610
error: null
interface: cli
operation: dyndns_update
parent: null

    • domain
    • maindomain.tld
      started_at: 2022-05-21 18:51:34.362104
      success: true


2022-05-21 19:51:34,682: INFO - Updated needed, going on…
2022-05-21 19:51:34,711: DEBUG - Reusing IPv4 from cache: xx.xx.xx.xx
2022-05-21 19:51:34,715: DEBUG - Reusing IPv6 from cache: None
2022-05-21 19:51:34,825: DEBUG - Now pushing new conf to DynDNS host…
2022-05-21 19:51:36,580: SUCCESS - Updated your IP on DynDNS

Here is the log from the initial error of when I was trying to install the SSL cert, that prompted my connection to the issue of it maybe being the domain:
Certificate installation for mydomain-nohost-me failed !
Exception: Could not sign the new certificate
Wrote file to /tmp/acme-challenge-public/jpmhZDwLc5bgs0YaHmL1PcPjgy2GZIESIrfNhbfKf58, but couldn’t download mydomain-nohost-me/.well-known/acme-challenge/jpmhZDwLc5bgs0YaHmL1PcPjgy2GZIESIrfNhbfKf58: Error:
Url: mydomain-nohost-me/.well-known/acme-challenge/jpmhZDwLc5bgs0YaHmL1PcPjgy2GZIESIrfNhbfKf58
Data: None
Response Code: 404
w3 .org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

I also checked out support: (yunohost-org/en/dns_nohost_me)
And tried the ‘yunohost dyndns update’ command, although it only returned the message that no update is needed.

I hope you can help! Thank you

**Side question, security: has this inadvertently exposed my local router admin to the external web?

**EDIT: I changed some url formatting due to a 5 url’s in a new user’s post limit

Additionally, here is the log from dnsmasq - (hastebin)

Note the warning
“Warning: /etc/resolv.conf is not a symbolic link to /etc/resolvconf/run/resolv.conf”

That may be relevant.

Did you try to add     yourdomain.tld
::1           yourdomain.tld

to /etc/hosts file of you YH server before to generate the certificate ?

Regarding your router admin panel, can’t you change the port associate to avoid such conflicts ?

Thanks for responding.

I did try to edit my hosts file, although it did not seem to result in anything different. I think it is ‘hairpinning’ and after trial and error, appeared to be mostly a local, cosmetic issue. So disregarded.

On the latter one, this router firmware has very limited features. All I can do is open or close ports on the attached devices. I’m not sure how to change associations with it, it doesn’t look like it can.

Unfortunately, I encountered some subsequent obstacles I will make a new post for.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.