No (local) IP address

Hardware**: Raspberry Pi 4 (8 Gb) at home**
YunoHost version: should be latest stable available, as I upgraded everything Friday night.
I have access to my server: Physically
Are you in a special context or did you perform some particular tweaking on your YunoHost instance?: Swap increased to 2 Gb, no other known modifications

Hi, last night I had to power off my Raspberry to move it to a different location. Once I turned it back on, it was offline, it wasn’t showing on router’s webadmin.

Things I’ve tested:

  • I had bind the mac & ip on my router before, so I unbind it just in case, but still nothing.
  • I’m using ethernet, and both green and orange lights are up although they don’t blink
  • Router’s webadmin doesn’t list the Raspberry.
  • yunohost.local takes me nowhere.
  • I hooked the HDD to a different Raspberry 4 (2 Gb), but same luck
  • I tried assigning a static IP modifying /etc/dhcpd.conf and also copied the settings from this thread, but the server is still unavailable.

I have access to my server physically but I don’t know how to SSH into it without an IP to get the output from ip a and I’m running out of ideas. I’m ordering a UART serial converter.

Is there any information I can get from the boot screen (the only output I’ve got) or any other thing I could try to bring it back online?


Hi xabi,

How annoying your server does not come up!

Is the new location still in the same network, behind the same router?

If not, it could be that your Yunohost has its IP statically configured for the old network, but incompatible with the new one ( vs, for example).

You could try sudo dhclient, which will try to get an IP address on any available interface. If no connection is possible, it can take quite long before it times out (minutes, not seconds or hours). If all is well, it should take fewer than 10 seconds.

Run ip a(ddress) afder that, to see which addresses it acquired, if any.

You must have guessed that this is not a good sign. Do you have another cable to switch out, or a way to test this one?

The serial converter helps if you don’t have a monitor (and keyboard) attached; it won’t help you connecting to Internet (not in a conventional way, at least).

Normally, the boot screen would show the IP, if any:

  __   __  __   __  __    _  _______  __   __  _______  _______  _______
 |  | |  ||  | |  ||  |  | ||       ||  | |  ||       ||       ||       |
 |  |_|  ||  | |  ||   |_| ||   _   ||  |_|  ||   _   ||  _____||_     _|
 |       ||  |_|  ||       ||  | |  ||       ||  | |  || |_____   |   |
 |_     _||       ||  _    ||  |_|  ||   _   ||  |_|  ||_____  |  |   |
   |   |  |       || | |   ||       ||  | |  ||       | _____| |  |   |
   |___|  |_______||_|  |__||_______||__| |__||_______||_______|  |___|

 Local IP:
 Local SSL CA X509 fingerprint:
 SSH fingerprints:
  - SHA256:qD0ao35WEmzoaeuAavxgK8tHcTMoBV+PoryYGONmNAxA (ECDSA)
  - SHA256:GcbhrfhHcEmjthrRBBsH7tomktbwsbDrOrU (ED25519)
  - SHA256:uA4K/j/u46/ba4t10vaEojye8ssThqRcgGru3c (RSA)
yunohost login: 

(preferably it has an IPv6 as well of course, but it’s nice to have at least IPv4)
I never ran Yunohost on an RPi-image, is it the same for you (excluding the IP)?

Thanks for your reply!

It truly is :frowning_face: makes me feel so dumb

I moved my SBCs to a rack, but the setup is all the same. Only thing I did was power them off, move them to their new location and turn them back on. I didn’t change settings. They are connected to a switch and the switch is connected to the router. They have been working like this for years.

I cut the wires to size but I tested them beforehand and they were ok. I am currently using an off the shelf ethernet cable, just in case.

How can I do this if I haven’t got an IP for the device? It’s why I thought of getting UART.

My boot screen shows the following. I remember seeing the YunoHost ascii ages ago, but I don’t anymore.

After that, it puts no signal. Screen goes to black and that’s it.

At first I thought it could be a power issue since my YunoHost is installed in an external mechanical drive + usb thumb + fan. But after removing the usb thumb and fan, the issue still remains. I am using the official power adapter.

If it doesn’t work, it doesn’t work, no need to call yourself names :wink:

I’m confused… You have a monitor or screenrecorder attached, but you don’t have a keyboard connected?

The screen going black could be some kind of powersaving / headless setting?

That reminds me of your opening post,

Is any OS installed on that one? If you switch it the other way around, the ‘problematic’ RPi just boots I presume, pointing at a problem in the filesystem of your Yunohost-installation (if it does not complete boot, or falls asleep or something, as symptoms seem to indicate).

While writing I come to see the logic behind trying a serial connection.

To check whether I got things clear:

  • After (ordered) shutdown and reboot, Yunohost on the RPi does not come up anymore
  • Connecting storage / boot device to an alternative RPi yields the same result
  • Connected to the RPi are
    • External storage (also for boot? I’m not familiar with RPi4-boot-options)
    • Monitor via HDMI
    • Keyboard via USB
    • Network over ethernet / UTP
  • The boot sequence starts normally, but the screen turns dark before completion
    • The device does not react to keyboard entries
    • The device does not connect to the network

Is that correct?

You may know that Yunohost runs on Debian 11. Troubleshooting Debian boot on RPi has probably more hits than searching for Yunohost specifically.

Briefly before going to bed:

It’s a server so I use the web interface or SSH. I can connect a usb keyboard and a monitor. But I don’t see any prompt. After the initial checklist the raspberry won’t out put any signal. It could be some headless setting, but I don’t remember having changed this myself.

Yes, it’s running Home Assistant from a SD card.

  • If I hook the HDD (YunoHost) to the 2 Gb Raspberry, the Raspberry won’t get any IP.
  • If I put the SD (HomeAssistant) into the 8 Gb problematic Raspberry, it does get an IP address.
    This is what leads me to think that it’s a software issue, not a hardware one.

True. Will try this approach tomorrow.

Thank you

Oh, yes, I meant the current state, while troubleshooting. Keyboard/monitor are superfluous of course when running normally.

I had a short look; someone on Reddit mentioned a boot setting for changing the HDMI resolution, for another RPI-OS, though:

Yes, that file exists on YunoHost because it takes Raspbian or whatever is called now as a base. At least that’s what I believe. I’m not sure it’s used, though or YunoHost settings override/ignore whatever is contained in the config.

Anyway. I tried setting a static IP again today by editing both /etc/dhcpcd.conf and /etc/network/interfaces. Nothing.

I also edited the file you mentioned and enabled i-don’t-know-what to SSH into my raspberry via USB, but apparently it only works on Raspberry Pi Zeros.

Finally I hooked both the Raspberry and my computer with the ethernet cable to SSH into it but then again, what IP should I ping? yunohost.local doesn’t resolve, and neither does server’s hostname or the IP that allegedly is set as static.

My only hope at this point is using UART but I have never used it before. I’m getting the adaptor in a couple of days.

Oh, and I realised the YunoHost HDD stops spinning after a while (10 mins or so?), it goes idle.

Somehow I managed to boot.

The system lets me know that I am in emergency mode. After entering my root password, journalctl -xb puts out some 250 lines. Is there any location I can check on my HDD to find this file so that I don’t need to transcribe it from the screen/video to attach it here?

I am unable to exit the emergency mode.

ip a shows the following:

  1. lo: ‹LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet scope host lo valid Ift forever preferred_lft forever inet6 ::1/128 scope host valid_Ift forever preferred_lft forever
  2. eth0: ‹BROADCAST, MULTICAST> mtu 1500 disc noop state DOUN group default glen 1000 link/ether ma:ca:dd:re:ss brd ff:ff:ff:ff:ff:ff
  3. usb0: «BROADCAST, MULTICAST› mtu 1500 gdisc noop state DOUN group default glen 1000 link/ether ma:ca:dd:re:ss brd ff:ff:ff:ff:ff:ff
  4. wlano: ‹BROADCAST, MULTICAST> mtu 1500 gdisc noop state DOUN group default qlen 1000 link/ether ma:ca:dd:re:ss brd ff:ff:ff:ff:ff:ff

ip link set eth0 up makes the lights twinkle, but still no IP.

I have tried creating a backup: yunohost backup create but I get a warning:

the LDAP service is down, attempt to restart it…

and back again with the emergency mode.

Great, that’s a start!

Emergency mode is single user mode, with a minimum of devices mounted and services started. Single user implies no network.

My current log is in /var/log/journal/cf74d7eb2f3249c3bf2fcd3ee04c2b09/system.journal; yours will have another code, but system.journal would be there.

On a Stackexchange page I found that you could use journalctl --file [mountpoint]/var/log/journal/[code]/system.journal to read the log on another system.

The /var/log-directory would contain the messages-log, boot.log and the syslog as well of course.

Out of habit, my first attempt would be to see what /var/log/messages or /var/log/boot.log(.1) has to tell me, but journalctl is said to give the same and more information.

Focus on the last ten lines (counting from where you were dumped in the emergency mode) in the log first, it is likely that it has the reason for not being able to boot. Work your way up from there if there is no reason given there.

You probably tried, but exit, or Ctrl-d, would close the emergency mode and try to continue regular boot. Another option used to be telinit 5, but I’m not sure whether that is available in systemd.

Good luck!

Thanks for the follow up, unfortunately I gave up.

I installed YunoHost back in 2022 and not even then did I connect it to a screen, so I didn’t know what it was supposed to show. These last days, when plugged the HDMI to a TV it wouldn’t put out any signal. Until it did — it complain about being undervoltaged (official power supply bough off Kubii).

I connected my Raspberry to a phone charger (5V x 3A, too), and that’s when I saw the thing was in emergency mode. I read people fixing this by commenting out the partition but what happens when the partition that has the issue is /boot? Running fsck showed a few problems that I tried to fix unsuccessfully. I tried all six numbers but it seemed like superblock was corrupted. But I had no idea what I was doing :person_shrugging:

At that point I tried installing YunoHost on another HDD and then copying the content of the data partition from the old drive to the new one. But I didn’t get it to boot.

In the end, I reinstalled the system and copied the backup archives from the old system to the new one, although I wish I could’ve created new backups, but yunohost backup create wasn’t working either.

GoToSocial and Synapse were restored successfully, and even if I lost 5 days of data and interactions, they federate as they should, so not as bad.

By the way, this seems to be what I should be seeing on the screen if I connected the server. This was taken right after the first boot and I don’t see any prompt or message to proceed with the initial configuration. I did it via GUI.

Part of the messages I saw when I run journalctl -xb on emergency mode (sorry, OCR is not working as expecting):

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.