No connection via sftp: Could not connect to server

My YunoHost server

YunoHost version:
yunohost:
repo: testing
version: 11.1.2.2
yunohost-admin:
repo: testing
version: 11.1.2.1
moulinette:
repo: testing
version: 11.1.2
ssowat:
repo: testing
version: 11.1.2.4

I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …

Description of my issue

Recently (probably since the update to the testing branch) I can no longer connect with FileZilla via sftp to the server:

09:57:26	Response:	fzSftp started, protocol_version=11
09:57:26	Command:	open "admin@server-ip" 9777
09:57:47	Error:	Could not connect to server

I have configured the connection like it is described here: Exchange files with your server using a graphical interface | Yunohost Documentation
WIth the admin user I have access through SSH to the server.

Any hints for me?

Thanks
Papillon

@Papillone have you tried loging in as root?

So root@serveraddres.com

or

root@xxx.xxx.xxx.xxx

I had a similar problem. Do you log in with ssh using admin@ or root@?

dj

1 Like

(This is probably related to the change with the new admins group in Yunohost 11.1 … you should try to log using a member of the admins group instead of admin@)

1 Like

Thanks for answering and trying to help me.
Instead of using the IP I tried to use the domain name and that works.

But why not with the IP address? I also can not reach the homepage (ip-adress/yunohost/admin) via the IP address.

1 Like

Same issue here.
IP issue seems to be unique to when using VPS.

If I host locally on a spare computer, LAN IP does not have these issue.

Remote IP however… nothing works… not root, not user admin etc.

If it is the same problem (and it may not be as I force upgraded my_webapp 's to get the config screen working so it may be something else) I have it on all my web apps using filezilla either with an admin or my_webapp username. Previously all these worked.

Weirdly though, sftp still works in publii and over the command line.

sftp -P 666 my_webapp@blahblahblah works fine.

So this may be a Filezilla specific problem.

And, having installed 3.62.2 from Flathub it appears it is a Filezilla problem, or at least my one is. All my web_apps that don’t work under the old version of Filezilla 3.52.2 are working under 3.62.2.

If you are going to try this, don’t forget to backup your old Filezilla config folder (under ~/.config on Debian) as writing to it with the updated version will cause problems if you move back to the old. You can also export your config from Filezilla File/Export which is a good idea as well.

1 Like

Upgrading FileZilla to 3.62.2 solved the problem.
Thanks!

2 Likes