No access for users

,

Un débutant demande brièvement de l’aide : L’installation et la mise à jour de Yunohost ont fonctionné sans problème, tout comme l’installation des utilisateurs. En tant qu’administrateur, je peux me connecter au serveur sans aucun problème, mais cela ne fonctionne pas en tant qu’utilisateur. Message d’erreur : Le serveur est introuvable. J’exécute Yunohost sur un Raspi dans un réseau local.
Merci d’avance pour le soutien. (J’utilise DeepL pour la traduction de l’allemand).

A beginner asks briefly for support: The installation and upgrade of Yunohost worked without problems, as did the setup of the users. As an administrator I can log on to the server without any problems, but it doesn’t work as a user. Error message: The server cannot be found. I run Yunohost on a Raspi in a local network.
Thanks in advance for the support. (I use DeepL for the translation from German).

Hm so can you clarify how you access the server in both case (using the domain name, or the global IP, or the local IP ?)

The user portal cannot be reached using the local IP, it must be reached using the domain name you chose.

Hello, Alex,
Thank you very much for the quick feedback. I know: As admin I use the IP address (192.168.160.xxx) on Yunohost, as user I use the domain name (xxxx.local) or xxxx.local/yunohost/sso. I get the error message : This page was not found.
But I didn’t make a DNS entry for the local application, could this be the cause of the error?
Thank you for your kind efforts.
Best regards Michael
Bonjour, Alex,
Merci beaucoup pour cette rapide rétroaction. Je sais : En tant qu’administrateur j’utilise l’adresse IP (192.168.160.xxx) sur Yunohost, en tant qu’utilisateur j’utilise le nom de domaine (xxxx.local) ou xxxx.local/yunohost/sso. J’obtiens le message d’erreur : Cette page n’a pas été trouvée.
Mais je n’ai pas fait d’entrée DNS pour l’application locale, cela pourrait-il être la cause de l’erreur ?
Merci pour vos aimables efforts.
Meilleures salutations Michael

Traduit avec www.DeepL.com/Translator

Hmmm if that’s a .local domain it could/should work out of the box. Though did you choose some arbitrary name ? Somehow yunohost.local may work out of the box, but I doubt that foobar.local will work, you’d need to tweak some stuff in avahi’s configuration and I’m not really familiar with it …

Anyway maybe a workaround can be to tweak the /etc/hosts file on your desktop computer to declare (locally only) the binding between foobar.local and your local IP (see the last section of this page)

But keep in mind that if you want a public server, you should use a “real” domain name

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.