NGINX Reverse proxy is forcing yunohost scripts

Im not sure where else to post this as the issue is being caused by Yunohost.

I am using Yunohost on my network. It is the server that https and http forward to.

As such, I use the nginx service as a proxy for some other servers on the network, including my nextcloud server. They all take a while to load, and when looking at the console I found out that a bunch of yunohost scripts are trying to run on every page:


Anyone know how I can configure a nginx conf to not try and run those?

Looks like it is being caused by the .inc files in the main nginx/conf.d directory.

Still unsure how to ignore those.

It is unlikely these errors are the main cause of slowness. If you want to get rid of them disable the YunoHost tile overlay from the YunoHost global settings in your webadmin.

1 Like

You could try cutting Yunohost out for a while and replace it by a temporary machine running nginx as reverse proxy, to see whether the delay is caused by Yunohost or externally.

Do Yunohost-hosted services give a faster reply? They are dependent on the same reverse proxy, so should get the same delay.

How about network routing? Might the redirect travel via the external interface of your router, instead of directly from your Yunohost to the intended machine?

Does the network tab of the browser tools give any hint where the delay arises?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.