Nextcloud upgrade Issue

Hello everyone. I was doing some upgrades today and I ran into an error upgrading yunohost. The Log can be located at:

Is there anything specific I should look at? I tried from both the GUI and the CLI. I see its complaining about not being able to backup due to folder not empty or something but I dont understand? Any help is very appreciated!

Thank you!

The last lines of the logs seems to imply that the system did not succeed in creating the backup:

2019-03-05 17:30:34,071: DEBUG - + sudo BACKUP_CORE_ONLY=1 yunohost backup create --apps nextcloud --name nextcloud-pre-upgrade2
2019-03-05 17:30:34,272: DEBUG - + '[' 5 -eq 0 ']'
2019-03-05 17:30:34,272: WARNING - The output directory is not empty
2019-03-05 17:30:34,272: DEBUG - + ynh_die 'Backup failed, the upgrade process was aborted.'
    2019-03-05 17:30:34,272: WARNING - Backup failed, the upgrade process was aborted.
2019-03-05 17:30:34,272: DEBUG - + echo 'Backup failed, the upgrade process was aborted.'
2019-03-05 17:30:34,272: DEBUG - + exit 1
2019-03-05 17:30:34,417: ERROR - Unable to upgrade nextcloud 

Do you have enough space on the disk?
is there anything in /home/yunohost.backup/archives?

I think it’s the classical issue of/home/yunohost.backup/tmp/nextcloud-pre-upgrade2 already existing … Though one should be careful about deleting this brutally

I think @ljf knows how to handle this situation :stuck_out_tongue:

Hey, yeah I forgot to mention all the obvious. I’ve checked disk space, all that. Even rebooted the system and tried again. Same error.

There is another backup in that folder dated some 6 months ago. I guess that could be the issue then. Let me move it out and try again.

Thank you both for pointing me in the right direction. Upgraded just fine after moving that existing folder out. Case closed!

1 Like