Nextcloud upgrade and restore fails

Nextcloud upgrade and restored failed because of dependency problems:

The following packages were automatically installed and are no longer required:
55192 DEBUG   at libarchive13 libfl2 libgpgme11 libjansson4 libldb1 libsmbclient
55192 DEBUG   libtalloc2 libtdb1 libtevent0 libwbclient0 python-gpg python-ldb
55192 DEBUG   python-samba python-talloc python-tdb samba-common samba-common-bin
55192 DEBUG   samba-dsdb-modules samba-libs smbclient
55192 DEBUG Use 'apt autoremove' to remove them.
55192 DEBUG The following packages will be REMOVED:
55193 DEBUG   nextcloud-ynh-deps php-yac
55293 DEBUG 0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.

55293 WARNING E: Packages need to be removed but remove is disabled.
55294 DEBUG ++ tr '\n' ' '
55294 DEBUG ++ cat /tmp/tmp.lXu1jfo2Qz/dpkg_log
55294 DEBUG ++ grep -oP '(?<=-ynh-deps depends on ).*(?=; however)'
55294 DEBUG + local 'problematic_dependencies=php7.3-bz2 php7.3-imap php7.3-smbclient php7.3-apcu '
55294 DEBUG + [[ -n php7.3-bz2 php7.3-imap php7.3-smbclient php7.3-apcu  ]]
55294 DEBUG + ynh_package_install php7.3-bz2 php7.3-imap php7.3-smbclient php7.3-apcu --dry-run
55294 DEBUG + ynh_apt --no-remove --option Dpkg::Options::=--force-confdef --option Dpkg::Options::=--force-confold install php7.3-bz2 php7.3-imap php7.3-smbclient php7.3-apcu --dry-run
55295 DEBUG + sed --quiet '/Reading state info/,$p'
55295 DEBUG + ynh_wait_dpkg_free
55295 DEBUG + local try
55295 DEBUG + set +o xtrace
55295 DEBUG + grep -v 'fix-broken\|Reading state info'
55496 DEBUG + return 0
55496 DEBUG + LC_ALL=C
55496 DEBUG + DEBIAN_FRONTEND=noninteractive
55496 DEBUG + apt-get --assume-yes --quiet -o=Acquire::Retries=3 -o=Dpkg::Use-Pty=0 --no-remove --option Dpkg::Options::=--force-confdef --option Dpkg::Options::=--force-confold install php7.3-bz2 php7.3-imap php7.3-smbclient php7.3-apcu --dry-run
56098 DEBUG + ynh_die '--message=Unable to install dependencies'
56098 WARNING The following packages have unmet dependencies:
56099 DEBUG + local legacy_args=mc
56099 WARNING  php-apcu : Conflicts: php-yac but 2.0.2+0.9.2-4 is to be installed
56099 DEBUG + args_array=([m]=message= [c]=ret_code=)
56099 WARNING             Recommends: php-apcu-bc but it is not going to be installed
56099 DEBUG + local -A args_array
56099 WARNING  php-yac : Conflicts: php-apcu but 5.1.17+4.0.11-1 is to be installed
56099 DEBUG + local message
56099 WARNING            Conflicts: php-user-cache
56099 DEBUG + local ret_code
56099 WARNING  php7.3-bz2 : Depends: php7.3-common (= 7.3.19-1~deb10u1) but 7.3.23-1+0~20201008.68+debian10~1.gbp30f6c3 is to be installed
56100 DEBUG + ynh_handle_getopts_args '--message=Unable to install dependencies'
56100 WARNING  php7.3-imap : Depends: php7.3-common (= 7.3.19-1~deb10u1) but 7.3.23-1+0~20201008.68+debian10~1.gbp30f6c3 is to be installed
56100 DEBUG + set +o xtrace
56100 WARNING                Depends: libc-client2007e but it is not going to be installed
56100 DEBUG + ret_code=1
56100 WARNING Unable to install dependencies
56100 DEBUG + echo 'Unable to install dependencies'
# aptitude why php-yac
Manually installed, current version 2.0.2+0.9.2-4, priority optional
No dependencies require to install php-yac
# apt-get install php7.3-bz2 php7.3-imap php7.3-smbclient php7.3-apcu 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'php-smbclient' instead of 'php7.3-smbclient'
Note, selecting 'php-apcu' instead of 'php7.3-apcu'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php7.3-bz2 : Depends: php7.3-common (= 7.3.19-1~deb10u1) but 7.3.23-1+0~20201008.68+debian10~1.gbp30f6c3 is to be installed
 php7.3-imap : Depends: php7.3-common (= 7.3.19-1~deb10u1) but 7.3.23-1+0~20201008.68+debian10~1.gbp30f6c3 is to be installed
E: Unable to correct problems, you have held broken packages.
root@anmol:/var/www/webtress# apt-get install php7.3-bz2 php7.3-imap php7.3-smbclient php7.3-apcu 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'php-smbclient' instead of 'php7.3-smbclient'
Note, selecting 'php-apcu' instead of 'php7.3-apcu'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php7.3-bz2 : Depends: php7.3-common (= 7.3.19-1~deb10u1) but 7.3.23-1+0~20201008.68+debian10~1.gbp30f6c3 is to be installed
 php7.3-imap : Depends: php7.3-common (= 7.3.19-1~deb10u1) but 7.3.23-1+0~20201008.68+debian10~1.gbp30f6c3 is to be installed
E: Unable to correct problems, you have held broken packages.