Nextcloud Talk - Video- and Voice-Calls not working

  • READ ME AND USE THIS TEMPLATE IF YOU WANT TO GET HELP ! You may ask your question in english or french, whichever is easiest for you… But please use one of the templates provided below :wink:
  • LISEZ-MOI ET UTILISEZ CE MODÈLE DE TOPIC SI VOUS SOUHAITEZ OBTENIR DE L’AIDE ! Vous pouvez poser votre question en anglais ou français, selon ce qui est le plus simple pour vous… Mais de préférence en utilisant l’un des deux modèles fournis ci-dessous :wink:

:uk:/:us: Message template (english)

The “support” category is meant to ask for help or troubleshooting related to installing or using YunoHost or its applications. It is not to ask assistance on general system administration, network administration or special use cases that goes beyond the scope of the project. If you wish to discuss more advanced use case, please post in the “Advanced Use Case” category.

Before posting, please :

My YunoHost server

Hardware: Virtual Box VM
YunoHost version: 4.1.6
I have access to my server :

  • Through SSH
  • through the webadmin
  • direct access via keyboard / screen
    Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
    If yes, please explain:

Description of my issue

I want to use the Nextcloud-App together with its Talk-Extension to facilitate Chat-Messaging, Voice-Calls and Video-Calls.

Chat-Messaging is working correctly. On my router I have enabled all ports directing traffic to the Vm.

From the outside I can also connect to the admin gui and also use SSH.

However neither Voice- nor Video-Calls are working. If I call someone it does not ring on the other side and vice versa.

I am quite fluent in working with other Linux-flavours like Arch-Linux/Ubuntu/CentOs, but I do not understand YunoHost good enough to know where to look even for logs.

If you know this problem and know what files are important give me the list and I can update my post with the contents.

Thanks in advance

I had similar problem.
Resolved after a reboot of the yunohost server. I think it had been fixed by upnp that mapped the correct ports.

Nope, a reboot did not help at all.

Also I enabled UPnP under Tools → Firewall.

Still does not work.

BTW: i cant edit my first post. I get Internal Server Error 500.

Hi,

Did you try with another web browser? Talk doesn’t work for me with the latest Firefox releases.
Maybe a coturn server would be useful for you.

Did you use the android app?

On Iphone the Talk app cant connect to my Yunhost.

I think its a bug in the Iphone app, because with the android app I can connect to my yunohost server.

I tried with Chrome and with firefox. In both also chat messages only appear when the user clicks on the chat with the specific user which sent the new messages.

A reboot did not help at all.