Nextcloud remove after failed upgrade

My YunoHost server

Hardware: A VM in my old gaming computer
YunoHost version: 11.1.18 at the moment of the upgrade, now I’m in 11.1.19
I have access to my server : Through SSH and through the webadmin and eventually direct access. The server is in a closet ^^
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Today, I’ve tried to upgrade Nextcloud (25.0.5 to 25.0.6). Something went wrong. I’ve decided to ignore it and i’ve done an other upgrade. When this one was over, I’ve noticed the update of Nextcloud was not in the list.
At first sight, I thought that the failed was a mistake. But, I noticed that the app was remove !

I’ve checked the log, but I’m not an expert. It seems it was removed but I don’t know why.

Do you have an idea ?

1 Like

The upgrade failed due to :

2023-05-13 15:17:25,455: DEBUG - + sudo -u nextcloud php8.1 --define apc.enable_cli=1 occ --no-interaction --no-ansi maintenance:mode --on
2023-05-13 15:17:28,359: WARNING - PHP Notice:  fwrite(): Write of 1916 bytes failed with errno=28 No space left on device in /var/www/nextcloud/lib/private/Log/File.php on line 89
2023-05-13 15:17:29,026: DEBUG - An unhandled exception has been thrown:
2023-05-13 15:17:29,026: DEBUG - PDOException: SQLSTATE[HY000]: General error: 1021 Disk full (/tmp/#sql-temptable-281-19f-8c5.MAI); waiting for someone to free some space... (errno: 28 "No space left on device") in /var/www/nextcloud/3rdparty/doctrine/dbal/src/Driver/PDO/Connection.php:82

(ie your disk got full somehow)

and then YunoHost tried to restore the pre-upgrade backup (which implies to first remove the app), but the restore failed due to :

2023-05-13 15:20:13,482: DEBUG - 52602 + mysql --user=nextcloud --password=********** --batch nextcloud
2023-05-13 15:22:32,307: WARNING - 191426 ERROR 1114 (HY000) at line 2290: The table 'oc_filecache' is full

i.e. it was trying to restore the mysql dump I guess … Not sure what the “table XXX is full” … probably a disk space issue as well I would say

Soooo probably : free up some space on your disk somehow, then try to restore the nextcloud pre-upgrade backup

1 Like

It’s weird. I’ve got issues with the remaining space on my disk. I’ve resize the virtual disk (32 Go to 50 Go) before the upgrade.

Then can you check with df -h that the corresponding partition did get effectively resized

Hello @Aleks, do we have to update Nextcloud ourselves? Since there is a new version already, what longer probably.
Nextcloud Hub 3 (25.0.6)Update A new version is available: Nextcloud 26.0.1A compatible version is available for all apps.
But before my whole Yunohost system breaks down again, I’d rather get a Raspi ready and mirror the whole thing on my big server and then, when everything has worked out, upload from a Raspi back to my original server. Then maybe more will remain intact. Ps. Alex, nice to see you jumping around in the forum again. I have missed you. And that is meant seriously. I hope you are well.

Translated with DeepL Translate: The world's most accurate translator (free version)

@carrabelloy : this topic is not about version 26.x, it’s about a specific issue regarding a failed upgrade …

Yes, I have read that. But I had thought that it would go in here anyway. I apologise. Nevertheless, it’s nice to see you here again and that you’re doing well.

1 Like

Oh ! Thank you !

When I check, the size is 32 Go not 50 Go. I know what to look for now ^^

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.