Nextcloud kaput car service Redis-server non lancé


#1

Configuration de mon YunoHost

Matériel: Cubox-i4 Pro + disque externe
Accès Internet: ethernet à la maison
YunoHost version:
yunohost: 3.3.3
yunohost-admin: 3.3.1
moulinette: 3.3.1
ssowat: 3.3.2
As tu modifié ton yunohost avec des configuration spécifiques ou bien utilise tu uniquement la web administration et/ou la ligne de commande yunohost ? basique

Description de mon problème

Salut,

[edit: le problème semble être côté serveur, pas client. c.f. mon 2ème message]

Je tourne Nextcloud sur mon serveur yuno depuis des mois, avec un client owncloud sur mon desktop pour synchroniser les fichiers.

Ce matin, plein de bonne volonté, je décide de passer au client nextcloud.

Désinstallation du client owncloud et installation du client nextcloud (desktop sous kubuntu 18.04). Première configuration de mon compte nextcloud. Le client se connecte bien et me présente mes répertoires à synchroniser (côté serveur). Je fais mon choix et, lorsque je lance la synchro, seuls les répertoires sont créés en local. Aucun fichier n’est copié et j’ai droit à des “Le serveur a répondu “500 Internal Server Error”” pour chacun des fichiers.

Des idées sur comment investiguer pour régler cela ?

(si j’accède via l’interface ouèbe, je vois bien tous mes fichiers).

Merci !


#3

J’ai creusé un peu et en fait :

  • en webdav : si je vois bien la liste des fichiers, je ne peux pas lire leur contenu ni les copier
  • via l’interface ouèbe : je peux voir mes fichiers images mais pas les pdf ni les fichiers txt, ni les télécharger

Si je veux ajouter un nouveau fichier ou synchroniser, j’ai des erreurs "Redis server went away"

et dans les log Nextcloud, j’ai des tas de :

Redis::connect(): connect() failed: Connection refused at /var/www/nextcloud/lib/private/RedisFactory.php#84

Cette ligne 84 contient :

$this->instance->connect($host, $port, $timeout);

J’ai tenté de rescanner les fichiers :

$ sudo -u nextcloud php occ files:scan --all
Scanning files for 4 users 
Starting scan for user 1 out of 4 (user1) 
Exception during scan: Redis server went away
#0 /var/www/nextcloud/lib/private/Memcache/Redis.php(103): Redis->setnx('f678f87b48d68b4...', 0) 
#1 /var/www/nextcloud/lib/private/Lock/MemcacheLockingProvider.php(77): OC\Memcache\Redis->add('files/33d02c953...', 0) 
#2 /var/www/nextcloud/lib/private/Files/Storage/Common.php(709): OC\Lock\MemcacheLockingProvider->acquireLock('files/33d02c953...', 2) 
#3 /var/www/nextcloud/lib/private/Files/Storage/Wrapper/Wrapper.php(592): OC\Files\Storage\Common->acquireLock('scanner::', 2, Object(OC\Lock\MemcacheLockingProvider)) 
#4 /var/www/nextcloud/lib/private/Files/Cache/Scanner.php(331): OC\Files\Storage\Wrapper\Wrapper->acquireLock('scanner::', 2, Object(OC\Lock\MemcacheLockingProvider)) 
#5 /var/www/nextcloud/lib/private/Files/Utils/Scanner.php(239): OC\Files\Cache\Scanner->scan('', true, 3) 
#6 /var/www/nextcloud/apps/files/lib/Command/Scan.php(161): OC\Files\Utils\Scanner->scan('/user1') 
#7 /var/www/nextcloud/apps/files/lib/Command/Scan.php(234): OCA\Files\Command\Scan->scanFiles('user1', '/user1', false, Object(Symfony\Component\Console\Output\ConsoleOutput), false) #8 /var/www/nextcloud/3rdparty/symfony/console/Command/Command.php(264): OCA\Files\Command\Scan->execute(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))  
#9 /var/www/nextcloud/core/Command/Base.php(162): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))          
#10 /var/www/nextcloud/3rdparty/symfony/console/Application.php(874): OC\Core\Command\Base->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))           
#11 /var/www/nextcloud/3rdparty/symfony/console/Application.php(228): Symfony\Component\Console\Application->doRunCommand(Object(OCA\Files\Command\Scan), Object(Symfony\Component\Console\Input\ArgvInput), Object(
Symfony\Component\Console\Output\ConsoleOutput))
#12 /var/www/nextcloud/3rdparty/symfony/console/Application.php(130): Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\Consol
eOutput))
#13 /var/www/nextcloud/lib/private/Console/Application.php(173): Symfony\Component\Console\Application->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput
)) 
#14 /var/www/nextcloud/console.php(90): OC\Console\Application->run() 
#15 /var/www/nextcloud/occ(11): require_once('/var/www/nextcl...')
#16 {main}

#5

J’ai fini par :

  • désinstaller Nextcloud (“SUCCESS - nextcloud a été supprimé”)
  • effacer le répertoire “/home/yunohost.app/nextcloud”
  • ré-installer nextcloud (“SUCCESS - Installation terminée”)

Le problème “Redis server went away” est toujours présent.
Nextcloud, non accessible via l’interface ouèbe juste après ré-installation l’est à nouveau après une nuit.

Le problème semble bien être que Redis est en carafe (voir ci-dessous).

Pfffff :tired_face:
Qui pourrait m’aider à régler ce problème de Redis ?
Merci !

Edit, quelques indices : redis-server et rspamd.service sont dans les choux
Cela ressemble d’ailleurs à ce sujet : Impossible d’installer Nextcloud (redis “failed”)
L’erreur Redis est présente depuis le début de mes soucis Nextcloud et me semble en être la cause.
Y’a moyen de reconfigurer proprement / réparer Redis ?

# systemctl status redis-server
● redis-server.service - Advanced key-value store
Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-01-03 21:15:47 CET; 24s ago
       Docs: http://redis.io/documentation,
       man:redis-server(1)
Process: 7715 ExecStart=/usr/bin/redis-server /etc/redis/redis.conf (code=exited, status=1/FAILURE)
Process: 7712 ExecStartPre=/bin/run-parts --verbose /etc/redis/redis-server.pre-up.d (code=exited, status=0/SUCCESS)

Jan 03 21:15:47 kipos systemd[1]: redis-server.service: Unit entered failed state.
Jan 03 21:15:47 kipos systemd[1]: redis-server.service: Failed with result 'exit-code'.
Jan 03 21:15:47 kipos systemd[1]: redis-server.service: Service hold-off time over, scheduling restart.
Jan 03 21:15:47 kipos systemd[1]: Stopped Advanced key-value store.
Jan 03 21:15:47 kipos systemd[1]: redis-server.service: Start request repeated too quickly.
Jan 03 21:15:47 kipos systemd[1]: Failed to start Advanced key-value store.
Jan 03 21:15:47 kipos systemd[1]: redis-server.service: Unit entered failed state.
Jan 03 21:15:47 kipos systemd[1]: redis-server.service: Failed with result 'exit-code'.

# systemctl status rspamd.service
● rspamd.service - rapid spam filtering system
Loaded: loaded (/lib/systemd/system/rspamd.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-01-03 21:18:45 CET; 1s ago
     Docs: https://rspamd.com/doc/
Process: 7884 ExecStart=/usr/bin/rspamd -c /etc/rspamd/rspamd.conf -f (code=exited, status=1/FAILURE)
Main PID: 7884 (code=exited, status=1/FAILURE)

Jan 03 21:18:44 kipos systemd[1]: rspamd.service: Failed with result 'exit-code'.
Jan 03 21:18:45 kipos systemd[1]: rspamd.service: Service hold-off time over, scheduling restart.
Jan 03 21:18:45 kipos systemd[1]: Stopped rapid spam filtering system.
Jan 03 21:18:45 kipos systemd[1]: rspamd.service: Start request repeated too quickly.
Jan 03 21:18:45 kipos systemd[1]: Failed to start rapid spam filtering system.
Jan 03 21:18:45 kipos systemd[1]: rspamd.service: Unit entered failed state.
Jan 03 21:18:45 kipos systemd[1]: rspamd.service: Failed with result 'exit-code'.

#6

Tentative du matin : relancer le service redis :

# systemctl start redis-server.service                                                                                       
Job for redis-server.service failed because the control process exited with error code.                                                               
See "systemctl status redis-server.service" and "journalctl -xe" for details.    

Du coup, je tente de lancer Redis à la main :

# redis-server /etc/redis/redis.conf&

Il se lance, le processus est bien là :

# ps aux | grep redis
root     22589  1.8  0.0  28980  1540 ?        Ssl  08:26   0:09 redis-server 127.0.0.1:6379                                                          
root     25537  0.0  0.0   3760   544 pts/0    S+   08:34   0:00 grep redis

Magie ! Nexcloud recommence à synchroniser les fichiers comme il faut…

Mon besoin : que le service redis-server se lance par lui même. Qui pourrait m’aider sur ce point ? Merci d’avance.

Ci-dessous les log quand j’essaye de lancer le service (après avoir tué le processus lancé manuellement) :

# systemctl start redis-server.service 
Job for redis-server.service failed because the control process exited with error code.                                                               
See "systemctl status redis-server.service" and "journalctl -xe" for details.                                                                         

# journalctl -xe
Jan 04 10:00:45 kipos systemd[1]: redis-server.service: Failed with result 'exit-code'.
Jan 04 10:00:45 kipos systemd[1]: redis-server.service: Service hold-off time over, scheduling restart.                                               
Jan 04 10:00:45 kipos systemd[1]: Stopped Advanced key-value store.                                                                                   
-- Subject: Unit redis-server.service has finished shutting down                                                                                      
-- Defined-By: systemd                                                                                                                                
-- Support: https://www.debian.org/support                                                                                                            
--                                                                                                                                                    
-- Unit redis-server.service has finished shutting down.                                                                                              
Jan 04 10:00:45 kipos systemd[1]: redis-server.service: Start request repeated too quickly.                                                           
Jan 04 10:00:45 kipos systemd[1]: Failed to start Advanced key-value store.
-- Subject: Unit redis-server.service has failed                                                                                                      
-- Defined-By: systemd                                                                                                                                
-- Support: https://www.debian.org/support                                                                                                            
--                                                                                                                                                    
-- Unit redis-server.service has failed.                                                                                                              
--                                                                                                                                                    
-- The result is failed.                                                                                                                              
Jan 04 10:00:45 kipos systemd[1]: redis-server.service: Unit entered failed state.                                                                    
Jan 04 10:00:45 kipos systemd[1]: redis-server.service: Failed with result 'exit-code'.

#7

Bonjour,

Même problème chez moi avec Yunohost 3.3.3, Nextcloud 13.0.6 : redis-server (et le rspamd tout pareil !) failed en tant que service mais peut être démarré manuellement.
Je ne m’y connais pas assez pour corriger ce problème. Du coup en attendant j’ai désactivé redis sur nextcloud comme proposé dans ce post : Problème Nextcloud - Redis server went away

Merci d’avance pour votre aide !
Guillaume


#8

Même problème ici!


#9

Qu’as-tu fait pour y pallier ?