Nextcloud Fresh Install unable to connect by W10 WebDAV

Hardware: VPS bought online
YunoHost version: 4.3.5
I have access to my server : Through SSH + through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain:
SSH config untouched by Yunohost, rest default; diagnosis gives no issues aside from “insecure” SSH config modified by me

Description of my issue

Trying to connect Nextcloud client or WebDAV endpoint

I installed yunohost with the curl | bash approach on a clean debian 10 VPS
Set up mostly over commandline, set the DNS records; mail works great
Added Nextcloud app, Web UI works great

Nextcloud client gives
Failed to connect to Nextcloud at https://correct.url/customcloud
Trying to add the endpoint https://correct.url/customcloud/remote.php/dav/files/myuser/ under windows fails with
A device attached to the system is not functioning
Trying to add via elevated cmd prompt (net user syntax from nextcloud website)
System error 67 has occurred. The network name cannot be found.
Trying to use curl to list contents gives following error: (curl -L -X PROPFIND -H “Depth: 1” -u myuser:mypass https://correct.url/customcloud/remote.php/dav/files/myuser/ )

<html>
<head><title>405 Not Allowed</title></head>
<body bgcolor="white">
<center><h1>405 Not Allowed</h1></center>
<hr><center>nginx</center>
</body>
</html>

I’m all out of ideas. Tried to add the registry key for basic auth, tried two different machines, did all windows updates. Sadly have no Linux desktop here to test if its a windows-only problem

Did you add visitors permission to nextcloud and nextcloud api ? It is required for external tools to connect to nextcloud

2 Likes

I did not, and adding the permissions resolved the problem I had. Thanks!

1 Like