[Nextcloud] Erreur APCu

Bonjour,

J’ai un petit souci de fonctionnement sur nextcloud qui rencontre un bug avec APCu.

J’ai voulu appliquer la procédure indiquée dans la Doc concernant keeweb.

Lorsque j’exécute

sudo -u nextcloud php /var/www/nextcloud/occ files:scan --all

J’ai un retour :

An unhandled exception has been thrown:
OC\HintException: [0]: Memcache \OC\Memcache\APCu not available for local cache (Is the matching PHP module installed and enabled?)

Pourtant j’ai vérifié, le module APCu est bien installé (php -m, apt list --installed | grep apcu).

En fouillant un peu, cela ressemble à un bug identifié chez nextcloud

Je n’ai pas osé aller plus loin de peur de casser l’install avec yunohost

Mon serveur YunoHost

Matériel: VPS acheté en ligne (OVH)
Version de YunoHost: : 4.2.8.3
Version d’OS : Debian Buster
J’ai accès à mon serveur : En SSH et par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

C’est que ce n’est pas activé pour la ligne de commande.
Il faut modifier le fichier de configuration de Nextcloud:

  • sudo nano /etc/php/7.3/fpm/pool.d/nextcloud.conf
  • ajouter php_value[apc.enable_cli]=1 si l’entrée n’existe pas (php_value[apc.enabled]=1 existe probablement, pour indiquer que c’est actif hors ligne de commande)
  • service php7.3-fpm reload

Merci du retour,

La ligne php_value[apc.enable_cli]=1 existe déjà. J’ai quand même reloadé, mais pas de changement…

Bonjour,

J’ai exactement le même problème que @KaTeznik. Est-ce tu as trouvé une solution ?

J’ai installé un Yunohost tout neuf, effectué toutes les mises à jour système. Si j’essaie d’installer Nextcloud j’ai ce souci. Si j’essaie de restaurer une sauvegarde d’un Nextcloud qui fonctionnait sur l’ancien serveur : idem.

[edit] Yunohost 4.2.8.3 sur Rapsberry Pi3B+

En ce qui me concerne, ni la ligne de commande, ni même Nextcloud ne fonctionnaient malgré la variable php_value[apc.enabled]=1 dans le fichier /etc/php/7.3/fpm/pool.d/nextcloud.conf

La solution qui a fonctionné pour moi est celle que j’ai trouvée sur le forum NextCloud:

  • Ajouter php_value[apc.enabled]=1 dans le fichier /etc/php/7.3/cli/php.ini
  • service php7.3-fpm reload