Nextcloud can't find ocdata and creates huge logs

My YunoHost server

Hardware: VPS bought online
YunoHost version: 4.2.6.1
I have access to my server : Through SSH | through the webadmin

Description of my issue

Nextcloud cannot find .ocdata file anymore and creates (huge) nextcloud.log file in data directory.
When I try to reach nextcloud I cannot, the webinterface says
Your data directory is invalid Ensure there is a file called ".ocdata" in the root of the data directory.
However, there is a file called .ocdata there. This datadir first does not mount properly on boot because nextcloud quickly places a nextcloud.log file that grows and grows and grows… I can delete it, quickly mount my datadir to it and the .ocdata file is there, owned by user nextcloud.

What went wrong? It worked fine yesterday. I put back a backup of my server from a few days, still no luck.

I noticed onlyoffice.mydomain.com was gone, but it came back with the backup too.

I did install that plugin generate previews - it did that for more than 24 hours on < 200GB. But how do I stop this now? Also, with the backup installed, that plugin should be gone and I can’t find it in /var/www/nextclouds/apps/