[Nextcloud] A cloud for personal or group use

Ok, I tried edit /etc/php/8.2/fpm/php.ini with this value and restart php8.2-fpm, but still the same warning…
Wait ! I was looking not the good server, it works like this !! Hourra !

I can’t find this config/config.json file :thinking:

@JfmbLinux, in the nextcloud installation directory!

Complete path: /var/www/nextcloud/config/config.php

Ah, that’s just it… I realize now that my question sucked.
Sorry :man_facepalming:

well, the warning come back, this time saying I must define opcache.memory_cosumption more than 128…

I found some interesting reading

1 Like

You could try a higher value for opcache.memory_consumption and see if this helps. Be aware that opcache.interned_strings_buffer needs to be at least 25% of the opcache.memory_consumption value, otherwise you will see the other warning again, see

On the other hand these are just warnings (not errors) and as long as your Nextcloud instance is working well you may also just ignore the warnings.

In any case it doesn’t change anything, the warning always comes back.

I uncommented the two lines in /etc/php/8.2/fpm/php.ini

The OPcache shared memory storage size.

opcache.memory_consumption=128

The amount of memory for interned strings in Mbytes.

opcache.interned_strings_buffer=32

I don’t know if that’s good, but it seems to solve the problem :

I don’t know, the problem I see is obviously with other apps using also php8.2, because the parameters in php.ini will interact with all these apps…

In fact, I think I have got this issue because I have tried add some opcache.jit values to the nectcloud.conf (in fpm/pool.d) like

php_value[opcache.jit_buffer_size]=128M
php_value[opcache.jit]=1255

But is not well configured like this…
I remove them ans restarting the fpm service is fine for now.

I reset to default to avoid problems with other apps.

well, I keep just the first you said

It seems to disabled the message…

When you go to the Administration Settings, click on Basic Settings, then on Security and go back to Security Warnings & Configuration.

Is the warning still disabled?

yes it is !

In my case, the warning does not turn off. It comes back, all reset to default, but that doesn’t change anything. I just keep the first one too.

I have this on /etc/php/8.2/fpm/pool.d/nextcloud.conf

[nextcloud]

user = nextcloud
group = nextcloud

chdir = /var/www/nextcloud

listen = /var/run/php/php8.2-fpm-nextcloud.sock
listen.owner = www-data
listen.group = www-data

pm = static
pm.max_children = 32
pm.max_requests = 500
request_terminate_timeout = 1d


; Additional php.ini defines, specific to this pool of workers.
env[PATH] = $PATH
php_admin_value[memory_limit] = 512M
php_value[upload_max_filesize] = 10G
php_value[post_max_size] = 10G
php_value[default_charset] = UTF-8
; OPcache is already activated by default
; php_value[opcache.enable]=1
; The following parameters are nevertheless recommended for Nextcloud
; see here: https://docs.nextcloud.com/server/20/admin_manual/installation/server_tuning.html#enable-php-opcache
php_value[opcache.enable_cli]=1
php_value[opcache.interned_strings_buffer]=32
php_value[opcache.max_accelerated_files]=10000
php_value[opcache.memory_consumption]=128
php_value[opcache.save_comments]=1
php_value[opcache.revalidate_freq]=60
; https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/caching_configuration.html#id1
php_value[apc.enabled]=1
php_value[apc.enable_cli]=1

and also have uncomment and edit in /etc/php/8.2/fpm/php.ini

opcache.interned_strings_buffer=32

In /etc/php/8.2/fpm/pool.d/nextcloud.conf I have the same thing, but not for /etc/php/8.2/fpm/php.ini I put it back to default to avoid problems with d other Apps.

When I only use ‘systemctl restart php8.2-fpm.service’ without modifying the files, and I return to Nextcloud, the warning is no longer there.
But when I click on other Settings and go back to Security Warnings & Settings, the warning appears again.

On the other hand, when I uncomment opcache.interned_strings_buffer=32 in /etc/php/8.2/fpm/php.ini, that completely solves the problem.

[French]
Bonjour,

de mon côté j’avais 3 erreurs en passant à la version 28. J’ai réussi à en résoudre 2 grâce aux posts précédents (opcache et maintenance_window_start).
Mais il me reste cette erreur :

  • La vérification d’intégrité a été désactivée. L’intégrité ne peut pas être vérifiée.

Je ne sais pas si c’est grave docteur? Comment peut-on la résoudre?
Merci d’avance.

[English]
Good morning, For my part, I had 3 errors when upgrading to version 28. I managed to resolve 2 thanks to previous posts (opcache and maintenance_window_start). But I still have this error:

  • Integrity checking has been disabled. Integrity cannot be verified.

I don’t know if it’s serious, doctor? How can we solve it?
Thanks in advance.