Newsletter plugin of Wordpress complains about cron

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH + through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I’m trying to send newsletters using the Newsletter plugin to Wordpress. The test ones are sent correctly, but when I try to send a newsletter normally, it gets stuck on 0 messages sent, and a warning message appears at the top of the page saying The are issues with the delivery engine. Please check them here. Here points to a page that says that the ‘Delivery background job’ is not working, with the explanation ‘The engine schedule is late. You probably need and external scheduler trigger.

Lower in the page it says that The constant DISABLE_WP_CRON is set to true (probably in wp-config.php). That disables the scheduler auto triggering and it's good ONLY if you setup an external trigger. And, indeed, inside wp-config.php I see this

/** Disable the wordress cron because it's managed by the system */
define('DISABLE_WP_CRON', true);

On the same page there is a button to run the scheduler manually and, when clicked, it does send the emails, but there are still things that don’t work properly, like showing the open/click rates of the newsletters.

So, I guess that my questions are

  • why was the Wordpress cron disabled?
  • what was it replaced by?
  • how can I get the Newsletter plugin to be able to use that other cron? Or should I enable the wordpress cron instead?

Thank you!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.