Newbie questions / Questions de débutant!

,

Bonjour :smile:
Je tente ma chance à nouveau en installant Yunohost sur mon petit serveur. Je ne suis pas un pro de linux, mais j’apprends vite et j’aime bien :smile:

J’ai quelques petits bugs que je crois simples… votre aide serait vraiment appréciée!

1 - J’ai installé le serveur exactement tel que décrit sur le site. J’ai mis comme domaine “henrinet.nohost.me”. Or, rien à faire, j’ai beau taper ça dans mon navigateur, rien n’y fait… Mais si je tape l’adresse locale du serveur et même l’adresse ip de mon modem , ça passe! Est-ce que j’ai oublié d’activer quelque chose?

2 - Pas moyen de me loger en autre chose qu’admin quand je me connecte via l’IP locale ou distante. Pourtant j’ai crée un compte usager… ? Si je veux créer des utilisateurs, il doit bien y avoir une façon de m’y connecter, non?

Merci d’avance de votre aide! Si possible, me donner les références s’il y a un marche à suivre ou assez de détails pour qu’un newbie comme moi puisse s’en sortir :wink:

Hi guys!
I’m trying Yunohost again. I’m a newbie on Linux but I’m a fast learner and I like it.

I have a few bugs I think are easy to solve… your help would be very appreciated! I installed the server exactly as described on the website.

1 - I chose a domain name (henrinet.nohost.me) but I can’t access it with the adress. I can connect via local ou external ip addresses. Is there something I can do for this?

2 - When I connect via ip, all I can log into is admin. I have created a user account but all the server asks me is the admin password.

Thanks! :smile:

Bonjour,

Pour la 2e partie : comment essaies-tu de te connecter ? en ssh ou par le navigateur ?
Si tu parles du portail pour les utilisateurs il faut aller à l’adresse tonadresseipoutondomaine/yunohost/sso
Après tu arrives sur l’interface pour les utilisateurs.
Pour administrer via l’interface du navigateur c’est tonadresseip/yunohost/admin

Salut Niltugor! Merci pour ta réponse.

Malheureusement, quand je tape l’adresse que tu suggères, ça me ramène à monip/yunohost/admin/#/login instantanément…

Je vais essayer de réinstaller le serveur pour voir si j’ai sauté une option… !

Salut,

1 - Je ne sais pas trop comment on configure un nom de domaine nohost.me, mais tu peux commencer par vérifier que ce nom de domaine est bien associé à ton ip (de ta box/modem). Pour ce faire tu peux taper host nom.de.domaine, ou ping nom.de.domaine. Il y a surement des outils en ligne qui font des résolutions DNS - au cas où tu doutes de la config des resolvers DNS de tes machines.

2 - Contrairement à ce qu’indique @Niltugor, je ne crois pas qu’on puisse se connecter sur le SSO avec juste l’ip de la machine. Il faut passer par le nom de domaine, i.e. avoir nom.de.domaine/yunohost/sso dans la barre d’url de ton navigateur, et non l’IP ! Ce qui est embetant par rapport à ton point n°1 si le DNS ne marche pas pour le moment … :slight_smile: Cependant tu peux contourner le probleme temporairement en ajoutant au /etc/hosts de ta machine qui essaye d’accéder au serveur une ligne comme :

192.168.x.y nom.de.domaine

en remplacant 192.168.x.y avec l’ip locale de ton serveur. Le fichier /etc/hosts est lu avant toute résolution DNS, donc tu peux t’en sortir comme ça en attendant ;).

Good luck

J’ai réinstallé le serveur pour voir si c’est quelque chose durant l’installation qui a foiré mais je vois bien que les 2 mêmes problèmes demeurent.

CaptainSqrt2: Merci pour ta réponse. Selon le guide d’installation de Yunohost, si je mets un domaine .nohost.me tout est supposé se faire tout seul. On dirait bien que non…? Pourtant, je vois le nom choisi sur la console du serveur quand il est allumé. Mais rien ne semble pointer vers mon serveur: henrinet.nohost.me

Il me semble qu’à chaque fois que j’essaie d’avoir un petit serveur sous linux, c’est l’enfer! J’ai l’impression que je vais finir avec un serveur Windows… :frowning:

Quelqu’un d’autre aurait une idée de comment régler mon problème?

Merci! :smiley:

Hm, le problème de DNS n’a pas grand chose à voir avec Linux ou Windows si ce n’est que Yunohost est effectivement censé pouvoir fournir un nom de domaine .nohost.me automatiquement :smile:. Je ne sais pas trop quel est le status du truc, peut-être qu’il faut contacter les admins, mais en attendant j’imagine que le plus simple est de prendre toi-même un nom de domaine. Il me semble que ça coute moins d’une dizaine d’euros par an, donc c’est relativement accessible surtout pour un serveur sur le moyen/long terme.

Est-ce que tu as essayé la solution du point n°2 en éditant ton /etc/hosts ? Si tu es sous Windows, normalement le fichier est situé dans c:\WINDOWS\system32\drivers\etc\hosts.

salut hlabelle,

J ai testé ta propagation dns de ton nom de domaine.
https://www.whatsmydns.net/#A/henrinet.nohost.me
ton nom de domaine n’est pas présent

Ton serveur est hébergé physiquement chez toi?
As tu ouvert les ports de ta box/modem ?
je te fais part de cela car tu peux accéder à ton serveur en local mais pas sur l’extérieur.
https://yunohost.org/#/isp_box_config_fr