New official package: ShellInABox (GateOne deprecated)


GateOne having shown some issues during its time in the official App list, I have decided to replace it by ShellInABox, which has a very similar goal: Accessing a secure shell on his server via a Web interface.

I believe that having an easy command-line access is the key to learn more on your system, its functionning and its structure. Demystifying the system administration has always been one of the core concept of YunoHost, and a web shell is, in my opinion, a great entry door.

So no more Python, no more fancy HTML5 interface and no more Google code injection (all brought by GateOne). ShellInABox only brings a simple shell access. It reduced drasticaly the complexity of the packaging, therefore the maintaining.

One issue remains though, some keyboard keys are not detected on ShellInABox if you are using it on Firefox 23+, like the “/” and the “:” keys. Leading the shell to be actually painful to use on Firefox.
ShellInABox developers are aware of this issue, and will hopefully resolve it some day. You will find more information on the bug report page.

In the mean time, you can use ShellInABox on any other web browser (yes, even IE8).

ShellInABox is already part of the official App list. You can install it via your YunoHost’s administration interface or by running:

sudo yunohost app install shellinabox

As always, connect to your server via SSH with the admin user and your administration password.

All your feedbacks are very welcomed :blush:

I started to test.
It seems that it is not possible to use key authentication.
Feature that is present in gateone.


@nino Good catch ! Although I don’t think that it will have a huge impact on this tool’s goal.

The GateOne’s repository will still be available at for this purpose.

I installed it on my server and tried access to my root account, and an error is the outcome :

So I tried with my current user successfully, prompting me for the password, then I enter the password and same error again.

What can I do?


You have to login as admin first then you can login as root.
eg. login: admin
admin@yunohost:~$ su