New installation no network

Hi people, I finally got a dedicated machine for home server, and of course, want Yunohost on it. No luck after fighting with it several hours, so I’m turning to community for help.

My YunoHost server

Hardware: usual pc
YunoHost version: 4.1.8
I have access to my server : direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

After installation finishes, I cannot access the machine through network.

I host at home, with a casual router and dedicated domain name. Port forwarding works well: I even tested manjaro on the same machine, and web server was accessible without need to configure.

In router’s DHCP client list I see yunohost machine on correct local IP.

ping produces Temporary failure in name resolution
ping responds Network is unreachable

Checked contents of /etc/resolve.conf. The only uncommented line is nameserver

I have no idea what else to do… Anyone has a clue what could be happening?

What the output of

ip -br address


ip route

You can also watch log to search driver error about ethernet

ip -br address

lo UNKNOWN ::1/128
eno1 DOWN

(I hope I didnt mistype anything)

ip route does not produce any output.

Did you have internet on this machine before the install finishes ?

Can you try to maybe run ip link set eno up and see if that changes the output of ip -br a ?

After failing to install Yunohost a couple of times, I installed manjaro to see if the hardware is ok. Manjaro worked perfectly, with internet too. Previously the machine was a reasonable windows workstation.

ip link set eno up
Cannot find device "eno"

By eno I was meaning the interface name reported by ip -br a earlier … Or is it en0something ?

My mistake, it was eno1.

ip link set eno1 up says
RTNETLINK answers: Operation not permitted

I tried it with sudo. ip -br address response is still the same.

I guess you’re running this command as non-root, maybe from the admin user ? If so, first run “sudo su” to become root, then retry the “ip link” command

ip link

1: lo: <LOOPBACK, UP, LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000 
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 
2. eno1: <NO-CARRIER, BROADCAST, MULTICAST, UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000 
link/ether 20:25:64:0c:37:33 brd ff:ff:ff:ff:ff:ff

I was meaning retry ip link set eno1 up

ah, sorry and thanks for your patience.
Nope, ip link set eno1 up does nothing when called from root… ip -br address output remains the same.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.