New install of Jellyfin fails

My YunoHost server

Hardware: Old computer
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: Jellyfin 10.8.11~ynh2

Description of my issue

Hi !

I used to have a working instance of Jellyfin on my server. I migrated to a different computer using the built-in backup and restore process of Yunohost, and everything went smoothly. Except I noticed Jellyfin didn’t reinstall. I tried reinstalling afterwards but the install fails :
I tried purging Jellyfin related packages using apt but the result is the same. Unfortunately, in the logs provided by Yunohost, I don’t have more infos beyond that the install scripts fails.
Any idea about what’s happening or how to get more infos about what failed in the install script ?

Thanks a lot !

Sounds similar to Funky cases in ynh_multimedia_* ... The whole story about multimedia is confusing and should be reworked/clarified · Issue #1981 · YunoHost/issues · GitHub

… I’m guessing there’s a bunch of broken symlinks in there, though it’s not clear how this may have happened

Can you try sharing the output (or just an extract, feel free to redact names etc) of

ls -ld /home/yunohost.multimedia/*/{Torrent*,Podcasts,Playlists}

such that we can confirm this is the issue

1 Like

(Might be fixed by this commit to be included in next release … Though a workaround can also be to cleanup the broken symlinks probably … multimedia: fix again edgecase where setfacl crashes because of broke… · YunoHost/yunohost@1ce606d · GitHub )


Thanks a bunch ! I removed the symlinks and Jellyfin is installed and working !
Side note : I removed Airsonic and Transmission a while ago. Shouldn’t they have removed themselves their symlinks at that moment or something ?

Yes, that’s part of the “The story about multimedia is fraking mess” :sweat_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.