My Yunohost drastically reduces my internet connection speed

My YunoHost server

Hardware: Raspberry Pi 4 with 8GB
YunoHost version:
I have access to my server : Both through the webadmin page and through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi all,

for the last few days I’ve observed a strange phenomenon: Whenever my Yunohost is online (connected to my router by cable), my internet connection speed drops from 20 Mbps to 5 Mbps or less, to the point where I cannot use a browser on my desktop or open a twitter feed because loading the images takes forever.

If I turn off the Yunohost, or if I cut off the Yunohost by disabling port forwarding (80, 443) on the router, the speed returns to 20 Mbps.

I’m not doing anything unusual or bandwidth-heavy on the Yunohost. I have Nextcloud and Jellyfin installed, but all Nextcloud files are fully synced, and I’m not actively using Jellyfin. Besides those, I only have Roundcube installed for internal use.

This internet speed drop never happened before. I had been using this setup for several months (under v4).

The webadmin > Diagnosis reveals one strange issue in DNS records:

Could this error and the drop in speed be related?

I tried fixing this issue as the Diagnosis suggests by running sudo yunohost dyndns update --force on the Yunohost, and the command completese successfully, but the issue persists.

Thanks for your help!

The DNS issue is unrelated and will be fixed in next Yunohost micro-release

I guess sciences can’t explain many things but claiming that Yunohost itself reduces your internet connection speed is eye-rolling … But who knows …

If I turn off the Yunohost, or if I cut off the Yunohost by disabling port forwarding (80, 443) on the router, the speed returns to 20 Mbps.

So were you really able to reproduce this multiple times and not just once which could be just random fluctuations ?

If disabling port forwarding yet keeping the server up consistently shows a difference, then it would sounds like the issue is somehow with inbound traffic (maybe bot attacks or a lot of visitors somehow trying to reach your website idk) and not outbound traffic, hence less likely to be caused by the server itself …

Did you observe this just disabling port 80/443, or did you also disable port 22 ?

1 Like

I agree, it seems very odd that port forwarding for running Yunohost would slow down my internet speed so dramatically.

But here is what I observed. I have uninstalled all apps on the Yunohost that I don’t really use. Now only Nextcloud, Jellyfin, and Roundcube are installed.

Webadmin > Diagnosis demands that for these apps, the ports 22, 25, 80, 433, 587, 993, 1900, 5222, 5269, 7359 are open. I enabled port forwarding for all of them - and the Diagnosis recognized all ports except 1900 and 7359 as open.

In that setting, my internet speed (as evidenced with was down dramatically.

I do not run a web site, therefore I think there should be no incoming traffic affecting speed. Are bot attacks on a Raspberry Pi with 3 apps actually a real possibility?

To bring the speed back to normal, I can either turn of Yunohost, or disable the port forwarding.

By experimenting, I figured out that if I keep open only ports 80 and 443, I can actually run Nextcloud and Jellyfin, and in this configuration, my internet speed is normal.

I cannot exclude the possibility that the observed drops in speed were caused on my ISP’s side. When the problem first appeared, I opened a ticket at ISP, but they claimed that my line is technically in order. They factory-reset my router, which removed all port forwarding. After the reset, the speed was back to normal.

I am just now experimenting with enabling all port forwarding again to see whether this reproduces the speed drop problem.

I really don’t understand much about port opening, TCP, so I appreciate any explanations of which ports are truly necessary to forward and wich arent, or any other elucidation of what is going on here.


Hmmmmmokay my biggest suspicion would be towards Jellyfin, mostly because I don’t know much about it and it seems related to torrenting stuff …

If you want to investigate, you can try running sudo iftop on your server (or sudo iftop -i <interface> for a specific interface), which is a terminal-based interface to monitor network activity … Though this is not gonna tell you exactly what PID is involved … But you should be able to get some info regarding what machines / hosts your machine discuss with, and see if there’s indeed an unexpectly large RX / TX rate

If iftop is not already installed, you can probably just sudo apt install iftop

Alternatively you could just disable the port forwarding for ports 1900 and 7359 which are related to Jellyfin and see if that changes stuff

Thanks, I’ll explore and report if I find anything relevant!

These ports are actually for local service discovery and should only be opened on the server, not the Internet. That’s a mistake I made in the package. I will fix that soon.

If it’s Jellyfin fault, maybe it’s a bot spamming these discovery ports?

Is there a (not too complicated) way how I can find out if bots are spamming? I’m not an advanced expert in this …

I don’t use jellyfin, but if it is about torrent, try reducing the number of connections. I had similar issues with a torrent client that killed my connection, and I fixed it by reducing the number of connections in the settings of the app

As Aleks stated, close these ports on your modem and see if that improves your connection.

@jarod5001 Jellyfin doesn’t really show connections like a torrent would. I’m not even sure there are so many similarities: AFAIK, Jellyfin isn’t for downloading media files, only for managing and streaming them. At the time the described speed issues occurred, I wasn’t streaming anyhting on Jellyifn.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.