My_webapp: Can't connect using SFTP

My YunoHost server

Hardware: Raspberry Pi 4B at home
YunoHost version: 11.2.5 (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I can’t connect and access the www folder using SFTP. I tried with Filezilla and the Gnome file manager (Nautilus I think?).

Filezilla says:

|Status:|Connecting to yunohost.local...|
|Response:|fzSftp started, protocol_version=11|
|Command:|open my_webapp__4@yunohost.local 22|
|Error:|ssh_init: Temporary failure in name resolution|
|Error:|Could not connect to server|

I use these to connect:
Protocol: SFTP
host: yunohost.local
port: 22
Logon type: Normal
username: my_webapp__2

For the password, I tried multiple times to change it though the YNH web admin. I even tried to install another instance of my_webapp and that doesn’t work either.

Any idea what I’m doing wrong?

Hi narF,

Did you enable SFTP for the account that you use to connect?

There are separate permissions for SSH and SFTP. If SFTP still does not work afterwards, you could try enabling SSH for that user, and run ssh -v (or -vv) when connecting, to see where the trouble arises.

Sounds like Filezilla is not able to resolve your .local name, I would rather use the “actual” domain name of the server ? (Or the IP …)

Thanks for the tip! Indeed, using the ip adress, I can now connect. But then I get access denied.

$ ssh my_webapp__2@yunohost.local
my_webapp__2@yunohost.local's password: 
Permission denied, please try again.

So I tried to reset the password using the YNH webadmin (…/yunohost/admin/#/apps/my_webapp__2/main) but I still get permission denied…

Is it possible that changing the password through the webadmin fails silently??

After more testing, it does seem to be the problem. The UI in the webadmin to change the password doesn’t work.
I created a new my_webapp with a password, then changed the password through the webadmin, then I tried connecting. The new password didn’t work, but the old one did. Which is why I think the webadmin password change UI doesn’t work.

Update: It seems like I’m not the only one: Bug: Changing SFTP password in config panel is not working · Issue #126 · YunoHost-Apps/my_webapp_ynh · GitHub
At least the weird workaround proposed does seem to work for me.