My_webapp broken after migration to 11.x

My YunoHost server

Hardware: Other ARM board
YunoHost version: 11.0.9.14
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

as per Unable to install my_webapp - #3 by Aleks i went through with the migration, which mostly worked. seems pretty wild to force a migration merely to install a generic web app, especially when there are warnings about how it might break stuff, and i don’t want my services to go down.

now my previously existing my_webapp, a flask app, has its venv broken. i tried yunohost app upgrade --force APP_NAME as per the docs, but it doesn’t work for a my_webapp? is there any other way to force a venv upgrate?

uwsgi is broken, it reports venv/bin/uwsgi: error while loading shared libraries: libpython3.7m.so.1.0: cannot open shared object file: No such file or directory. the flask command also fails with ModuleNotFoundError: No module named 'flask'

it’s beyond my knowledge of python. any pointers appreciated.

i fixed it myself, following Rebuilding a Virtualenv | PythonAnywhere help.

  • if needed, generate a requirements.txt file in your app dir with your venv activated. [ideally you already have one don’t you.]
  • move or remove your app’s venv
  • create a new venv
  • unlike the link above, you need to activate your venv before the next step!
  • pip install -r requirements.txt to install everything.
  • if anything fails, check the version number and try using the install candidate mentioned
  • make sure nginx conf is correct
  • restart nginx if its happy [check with sudo nginx -t]
  • restart your app if its a systemd service or similar.