Moving Accounts between Mastodon on Yunohost / Password not accepted

My YunoHost server

Hardware: VPS rented online
YunoHost version: &
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I’m running Mastodon on an older Yunohost (that’s the I set up for temporary use and testing, which will soon be taken down. I had started a Mastodon account on that server which I now intend to move to another newer server (the one I run Yunhost on.). So you’re supposed to be able to move accounts from one server to another. This generally seems to work, as I’ve done it before on
So I’ve set up a new mastodon server, made a new account and linked that account to the old account on the other server. That part worked fine. You are then however asked to initiate the move on the source server. You’re asked to enter the address to the new account/server and your current password. When I do that, the password is not accepted with an error message (password not valid). I’ve made sure it is the right password. I can use it to log in, just not to initiate the move. I also cannot change it from within Mastodon, because of course it’s set in the sso within Yunohost. So I believe the reason I can not initiate the move with my password might be the LDAP authentication Mastodon uses. Has anyone ever gotten this to work or is there something I’m doing wrong? As I wrote I did the same thing on and it worked fine. I could not find a general issue for the LDAP integration for Mastodon that mentions this problem. The authentication method is the only difference I’m aware of. I did look at some logs but there are no error messages I could find. I did change the password in the sso and tried again, still can log in to Mastodon but can’t initiate the move. It specifically highlights the passwort box, so I’m certain that’s the problem. Not sure what to do now.

1 Like

Same here. I moved my account from another instance cause its of an easy task in general and I thought I’ll test it in some RL enviroment. Now I am stucked and I cannot move my account back or to another instance, as password/api/etc is not working when moving accounts.

ATM I am forced to keep this instance up and running or start over again and lose all followers. Maybe not a big problem, but at least very annoying, as its a standard feature of Mastodon and the fediverse. And being locked in is actually the opposite of what the fediverse is meant to be^^

I am really in hope of a solution to appear.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.