Mise à jour impossible?

Bonjour la communauté,

je viens d’installer Yunohost via l’iso qui va bien sur mon raspberry (le B avec 512 Mo) à des fins de tests pour un serveur plus classique.
Après installation, tout répond bien (domaine créé, utilisateurs, …) mais quand je veux mettre une application (peu importe laquelle d’ailleurs), j’ai droit à ce message :
Les pré-requis ne sont pas satisfaits, le paquet yunohost (2.5.3.1) doit être >= 2.7.2

Ceci étant, je suis allé dans “Mettre à jour le système” et après quelques minutes, il me dit que plusieurs paquets seront mis à jour “durant l’heure suivante” :

  • yunohost-admin
  • moulinette
  • ssowat

Donc, j’attends que tout se mette à jour … mais depuis maintenant 24h que j’attends, ils ne sont toujours pas à jour. Du coup, pas moyen d’installer quoi que se soit.

Est-ce que par hasard cela est déjà arrivé à l’un d’entre vous ?

En vous remerciant,

Bonjour @Metal ,

Tu peux faire un tour ici Image 64bits en download pour raspberry.
J’y ai remis le zip en téléchargement pendant 10 jours.
A toi de jouer :wink:

ppr

Bonjour,

merci pour ta réponse, je suis en train de télécharger tout ça mais une autre question me vient : le processeur du premier raspberry est en 64 bits ? Il me semblait que c’est limité au 32 bits non ?

@Metal ,

Tout est en 32 bits pour le moment.

ppr

Cool, je test tout ça et je reviens pour vous tenir au courant :wink:

I’ll be back … et malgré deux tentatives (en reprenant la deuxième fois de 0), je bloque toujours au moment de l’installation de yunohost via le script : il commence à télécharger les paquets qu’il faut et il revient au point de départ en m’indiquant : Unable to update the system

Malgré un système bien à jour, impossible de l’installer. Je commence à sécher là …

@Metal ,

Est-ce que tu es bien en sudo pour lancer le script d’installation ?
Sinon, lorsque tu redémarre, comme le script d’installation est enregistré dans le répertoire /tmp, alors il est effacé. Il te faut donc le recloner pour pouvoir ensuite lancer l’installation.
Je dirais que tu peux alors tenter ces commandes :

sudo apt-get install -f
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get autoremove apache2.2
sudo git clone https://github.com/YunoHost/install_script /tmp/install_script
cd /tmp/install_script
sudo ./install_yunohost

ppr

Re,

j’ai déjà testé la plupart des commandes avant (et les autres après) mais à chaque fois, tout est OK et même en rebootant, en reprenant le script, rien, toujours la même erreur (et oui, je suis en root pour tout ça)

Erf, c’est bizarre :confused:

Donc si tu fais yunohost --version tu es en 2.5.x, mais si tu fais un apt-get dist-upgrade ça ne change rien ?

@Aleks je n’ai plus le premier test mais oui, c’était le problème original.
Pour le dernier en date, je n’ai même pas réussi à installer yunohost

@Metal , @Aleks ,

Effectivement, ça à l’air de bloquer lors du script d’installation et le message d’erreur est le suivant :

root@YunoHost:/tmp/install_script# ./install_yunohost
Failure !
The following error was caught during YunoHost installation :
Unable to update the system
Installation logs are located in /var/log/yunohost-installation.log

En fait il bloque sur cette commande afin de mettre à jour les firmware, sans doute parce que la question est posée ainsi :

Would you like to proceed? (y/N)
<au lieu de (Y/n)>

Bref, il faut passer ces quelques commandes manuellement avant de lancer le script d’installation :

apt-get install rpi-update
rpi-update
reboot

Je refais le tuto rapide alors :wink:

Formater la carte SD en FAT32, puis y dézipper le fichier compressé ZIP pesant environ 250 Mo (http://ovh.to/kBbF1PG et dispo pendant encore 7 jours - le couple utilisateur/mot de passe est pi/raspberry - pi/rqspberry avec un clavier azerty).
Lors du premier démarrage, cocher l’installation pour YunoHost.
A la fin de l’installation valider pour redémarrer le tout.

Changer le mot de passe de l’utilisateur pi et en choisir un autre suffisament fort pour procéder à une partie de l’installation

sudo passwd pi

Connaître et noter son adresse IP locale

hostname -I

Connaître et noter son adresse IP publique

curl ifconfig.me

Passer en root

sudo -i

Créer un mot de passe fort pour l’utilisateur root qui soit différent de l’utilisateur pi

passwd root

Installer sed, nano et git

apt update && apt install sed nano git

Activer SSH

raspi-config
Menu 5 ; sous-menu P2

Autoriser root à se connecter en ssh [ /!\ Pour la commande sed, devant le s et après le g, il faut mettre l’apostrophe du 4 ]

sed -i ‘s/PermitRootLogin without-password/PermitRootLogin yes/g’ /etc/ssh/sshd_config
service ssh restart

Mettre à l’heure

dpkg-reconfigure tzdata

Définir la langue

dpkg-reconfigure locales

Installer rpi-update

apt install rpi-update
rpi-update
reboot

Se reconnecter avec root en ssh (facultatif si tu as un clavier et un écran de branché au Raspberry Pi car tu pourras te reconnecter directement avec le mot de passe défini au début : root/mot_de_passe_root_défini_au_début)

ssh root@ip.du.raspberry.pi

Retirer l’utilsateur pi

deluser -remove-home pi

Vérifier que la version de Rasbian sera bien mise à jour sur la base Jessie [ /!\ Pour la commande sed, devant le s et après le dernier “pipe” |, il faut mettre l’apostrophe du 4 ]

sed -i ‘s|stable|jessie|’ /etc/apt/sources.list
sed -i ‘s|stretch|jessie|’ /etc/apt/sources.list

Mettre à jour le tout

apt update && apt --assume-yes dist-upgrade && apt-get autoremove && apt-get autoclean

Enlever eApache

apt-get autoremove apache2.2

Cloner le script d’installation de YunoHost dans le répertoire temporaire, s’y rendre et lancer le script

git clone https://github.com/YunoHost/install_script /tmp/install_script
cd /tmp/install_script
./install_yunohost

Lancer la post-installation

yunohost tools postinstall

Redémarrer pour finir

reboot

ppr

Re,

après test, ta commande rpi-update faite manuellement corrige le problème. La post-installation vient de se terminer et tout fonctionne correctement (utilisateurs, domaines, applications, …)
Un grand merci pour votre aide :wink:

@Metal ,

Si la solution fonctionne, tu dois pouvoir mettre une coche résolu à mon message.
Cela afin que les autres utilisateurs puissent s’y référer le cas échéant.

Sinon, pour avoir commencé sur une Raspberry Pi 1B comme toi, ça va bien pour les applications légères. Par contre, si tu installes NextCloud ça risque de “ramer”, tout comme si tu installes trop d’applications.

ppr

Plop,

ok, je clos comme il faut le topic. Le raspberry est là à des fins de tests avant de passer sur un vrai serveur qui sera largement plus puissant.