Minetest - port 30000 will not open

Good morning from chilly southern Maryland, USA!

My YunoHost server

Hardware: Intel NUC 12
YunoHost version: 11.2.5
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

I am attempting to install Minetest on my own home server. My server is provisioned with a Cloudflare domain name and all of my apps work as expected except Minetest. The Diagnosis shows Port 30000 - the port on which Minetest listens - is closed. However, I have opened the port on my router (I am confident the router is set up correctly) and in the firewall on the web admin.

I ran Nmap on both TCP and UDP against the server. It shows TCP 30000 is closed (despite how I have the firewall set) and reports nothing about UDP 30000 (suggesting it is open). Whether I go directly to the server internally (IP) or externally (domain name), I cannot access minetest. The Minetest service shows it is running and the logs show it is listening on port 30000.

Does anyone have any suggestions or experience? It appears one other person might have had this problem but their setup was complex.

Thank you!!

Hi Phil,

Welcome to the forums!

Nice that you run Minetest, we already had lots of fun with it before we got our Yunohost. Pity you can’t connnect :frowning:

I remember from the install back then, that sometimes I’d mess something up between the automatically started server and a manually started world, giving a conflict on port 30000 and both worlds unavailable.

This won’t be the case in your situation of course, but my workaround might help you further: we just stopped bothering with port 30000, and ran our worlds on ports 30001 and higher. The children shared the URL including the correct port with their friends, so it was no problem it was not on the default port.

I imagine this is not a totally satisfactory solution, but it would either get Minetest running (push the ignore-button in diagnosis for the default port to hide it), or will also give an error on the next port as well. In the last case something fishy is going on, but having more than one port blocked might give more strings to grasp while troubleshooting.

Thanks so much for the help. I deleted the apps so I could do a fresh install using your idea and wouldn’t you know it, it worked! Sooooooo cool…

Thank you again for your time and willingness to help out a fellow Yunohoster!

1 Like

Haha, great that it worked out. Your reaction was more than worth the time!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.