Migration Wordpress vers Yunohost + https


#1

Je suis dans la configuration où je veux migrer un wordpress d’un hébergeur mutualisé, accessible en http, vers Yunohost en https. J’ai suivi toutes les étapes décrites dans ce post, et là je bloque à la dernière étape :

Mon site est bien accessible en page d’accueil et admin en https sur mon serveur Yunohost, tout bien, mais l’accès aux autres pages du site renvoie l’erreur 404.

La modification du fichier my_webapp.conf tel que décrite avec arrêt et relance de nginx ne fonctionne pas, dans ce cas tout le site devient inaccessible…

Bref, là je suis bloqué et je n’ai pas trouvé de solution pour aller plus loin… :face_with_raised_eyebrow:


Probleme nginx erreur
#2

Que raconte nginx -t ?


#3
$ sudo nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

#4

Uh mais du coup tu parlais d’un problème qui survient si tu modifies le fichier my_webapp.conf ? (Ou bien tu as enlevé les changements que tu as fait ?)


#5

Oui pardon, j’ai remis le contenu dans le fichier et j’obtiens :

$ sudo nginx -t
nginx: [emerg] duplicate location "/" in /etc/nginx/conf.d/xxx.d/my_wepapp.conf:1
nginx: configuration file /etc/nginx/nginx.conf test failed

#6

Hmokay du coup il faudrait comprendre cette histoire de “duplicate location”.

Si tu fais cette commande ça raconte quoi ?

grep -nr "location / " /etc/nginx/conf.d/xxx*

#7
$ grep -nr "location / " /etc/nginx/conf.d/xxx*
/etc/nginx/conf.d/xxx.d/my_wepapp.conf:1:location / {
/etc/nginx/conf.d/xxx.d/my_webapp.conf:1:location / {

#8

Uh donc la meme ligne apparait deux fois ? C’est exactement la meme ligne ? o.O


#9

Non je ne la vois qu’une seule fois avec nano… C’est exactement le copier/coller du contenu de la page citée dans mon premier post.


#10

J’ai trouvé ce qui clochait dans la double réponse, il y avait 2 fois le même fichier avec presque le même nom !

$ ls
000-acmechallenge.conf  my_webapp.conf  my_wepapp.conf

J’ai supprimé, remis le code dans le webapp.conf, stop et start nginx, maintenant j’ai une erreur “502 bad Gateway” quand j’essaie d’accéder au wordpress…


#11

Okay …

Je suppose que systemctl status php7.0-fpm raconte que le service est down/failed ?


#12

Non c’est actif

$ systemctl status php7.0-fpm
● php7.0-fpm.service - The PHP 7.0 FastCGI Process Manager
  Loaded: loaded (/lib/systemd/system/php7.0-fpm.service; enabled; vendor preset: enabled)
  Active: active (running)

#13

Hmokay, et si tu fais systemctl restart php7.0-fpm est-ce que ça aide ?


#14

Non rien de mieux. J’ai même rebooté la machine, pareil…


#15

Je vois que le tuto date d’avant Stretch, du coup dans la conf nginx (my_webapp.conf) il te faut remplacer /var/run/php5-fpm-my_webapp.sock par /var/run/php7.0-fpm-my_webapp.sock je pense


#16

Non, même résultat… 502 gateway…


#17

Toujours 502…


#18

up !

Comment on fait pour debugger ce type de message ?


#19

Après avoir désinstaller / réinstallé Custom Webapp je retrouve la page d’accueil et l’admin de wordpress et l’erreur 404 sur les pages.

Par contre je me rends compte fortuitement que le fichier my_webapp.conf est remis par Yunohost plein du code que le tuto proposait d’y mettre sans que j’aie à le refaire…

Donc là je n’y comprends rien du tout, comment se fait-il que Yunohost restaure une modification lors d’une suppression / réinstallation ?

Même si ça ne résoud toujours pas le soucis technique, c’est curieux…


#20

Toujours bloqué… Ma migration vers Yunohost n’avance pas d’un poil…