🇬🇧 Migration to Buster Error

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking ? : no

Description of my issue

I know im pretty late to the party, but i just now tried to upgrade to debian buster / yunohost 4.x
As per documentation i tried to upgrade instead of installing from scratch.
So i go to the webmin -> tools -> migrations and click “run” and get this error message

Seeing lines 29, 44, 53 i switch to ssh and run apt --fix-broken install.
This recommends i do apt autoremove and remove 47 packages that are no longer in use.

So i try anew, this time from cli with sudo yunohost tools migrations migrate --accept-disclaimer
This now gives me this error message, which is now out of my comfort zone.

The most important lines i think are the following: (since they are in german i will try to translate them a bit)
:de: 145: 2020-12-09 12:13:10,153: WARNING - E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

:us: 145: 2020-12-09 12:13:10,153: WARNING - E: Problems can't be solved. You have defect held packages.

And in the following lines:
:de: 146: 2020-12-09 12:13:10,153: INFO - + Hängt ab von: python-bottle (>= 0.12) soll aber nicht installiert werden

:us: 146: 2020-12-09 12:13:10,153: INFO - + Depending on: python-bottle (>= 0.12) but shouldn't be installed

I would be thankful for any help.

Hmokay not sure what happened …

First I would run :

apt install unscd=0.53-1+b1 --allow-downgrades

Thank you for you reply :slight_smile:

I did that and the upgrade seemed to be running fine, until i got this Error

So i guess i need to run a similar command to the one before, but with what version?
Or do i need to change something in the apt sources?

I just saw:
4717: 2020-12-09 13:32:23,773: WARNING - E: The method 'ftp' is unsupported and disabled by default. Consider switching to http(s). Set Dir::Bin::Methods::ftp to "ftp" to enable it again.

So in /etc/apt/sources.list is switch the
deb http://ftp.debian.org/debian-security/ buster/updates main contrib non-free
to deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
and now it’s continuing until i get this error

Hmokay, regarding postgresql i believe you need to

apt install postgresql-11

Not sure what to do about the nftable stuff … But if you don’t have any super specific network stuff (or for example docker installed), simply reloading the firewall as usuall (with yunohost firewall reload) should be enough and you could probably skip the migration

Hello Aleks,

installing postgresql-11 solved the problem with migration17.
And since everything else seemed to be running fine and you told me to i skipped 18.

Thank you very much for your help.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.