Migration de 4.x to 11.x. / Migrate from 4.x to 11.x

:uk:/:us: English

Hi,
I am trying to upgrade my yunohost server from 4.x to 11.x.
I installed MobaXterm and successfully connected to the server via SSH.
I logged in as the admin and sent the following command :

sudo yunohost tools migrations run

(from Migrating from 4.x to 11.x | Yunohost Documentation)

The response from the server is confusing me. It seems that I am missing a step :

Info: No migrations to run

Can someone point me in the right direction to upgrade my server ?

Thank you !

My YunoHost server

Hardware: Dedicated computer
YunoHost version: 4.4.2.14
I have access to my server : Through SSH, through the webadmin, direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no


:fr: Français

Salut,
J’essaie de mettre à niveau mon serveur yunohost de 4.x à 11.x.
J’ai installé MobaXterm et je me suis connecté avec succès au serveur via SSH.
Je me suis connecté en tant qu’administrateur et j’ai envoyé la commande suivante :

sudo yunohost tools migrations run

(de Migrating from 4.x to 11.x | Yunohost Documentation)

La réponse du serveur me laisse perplexe. Il me semble qu’il me manque une étape :

Info: No migrations to run

Quelqu’un peut-il m’orienter dans la bonne direction pour mettre à jour mon serveur ?

Merci !

Mon serveur YunoHost

Matériel: Ordinateur dédié
Version de YunoHost: 4.4.2.14
J’ai accès à mon serveur : En SSH, Par la webadmin, En direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Ça ressemble à un truc où tu aurais volontairement skippé la migration à un moment …

Oui, exacte. Je l’ai volontairement skippé à un moment. Il n’y a pas de moyen de l’installer manuellement ?

Il faut bricoler Ă  la main, ouvrir sudo nano /etc/yunohost/migrations.yaml (ou un truc du genre), et supprimer uniquement la ligne correspondant Ă  0021_migrate_to_bullseye

Hello folks, hope you don’t mind me adding on.

This sounds like the issue I have. Is there a version of this in English?

I appreciate us english people are rather thick and uncultured! :joy:

:us: translation of @Aleks’ answer :
You have to use the command line to open sudo nano /etc/yunohost/migrations.yaml (or something similar), and delete only the line corresponding to 0021_migrate_to_bullseye

2 Likes

It worked perfectly. Thank you. Try mxtthxw