Migration 15 failure (buster)

Mon serveur YunoHost

Matériel: VPS acheté en ligne
Version de YunoHost: 3.8.5.9 (stable)
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Hello !

J’ai rencontré un problème lors de la migration de stretch vers buster. J’ai d’abord mis à jour le système vers la version 3.8.5, qui s’est bien passée. Mais la migration ne veut pas se faire a priori. Le système semble avoir passé les sources.list à buster (cf. contenu en bas de page) mais il y a l’air d’avoir un problème avec le paquet unscd. Any clue ?

Merci d’avance !

args:
  allow_yunohost_upgrade: false
  system: true
ended_at: 2021-02-18 20:29:42.179078
error: "Impossible de mettre \xE0 jour tous les paquets"
operation: tools_upgrade
related_to: []
started_at: 2021-02-18 20:29:34.944318
success: false
yunohost_version: 3.8.5.9

============

2021-02-18 20:29:34,963: INFO - Mise à jour des paquets du système (non liés a YunoHost)…
2021-02-18 20:29:40,654: DEBUG - Running apt command :
DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt-get --fix-broken --show-upgraded --assume-yes --quiet -o=Dpkg::Use-Pty=0 -o Dpkg::Options::="--force-confold" -o Dpkg::Options::="--force-confmiss" -o Dpkg::Options::="--force-confdef" dist-upgrade
2021-02-18 20:29:40,778: INFO - + Reading package lists...
2021-02-18 20:29:40,982: INFO - + Building dependency tree...
2021-02-18 20:29:40,984: INFO - + Reading state information...
2021-02-18 20:29:41,587: INFO - + Calculating upgrade...
2021-02-18 20:29:41,588: INFO - + Some packages could not be installed. This may mean that you have
2021-02-18 20:29:41,589: INFO - + requested an impossible situation or if you are using the unstable
2021-02-18 20:29:41,590: INFO - + distribution that some required packages have not yet been created
2021-02-18 20:29:41,598: INFO - + or been moved out of Incoming.
2021-02-18 20:29:41,598: INFO - + The following information may help to resolve the situation:
2021-02-18 20:29:41,599: INFO - + 
2021-02-18 20:29:41,600: INFO - + The following packages have unmet dependencies:
2021-02-18 20:29:41,701: INFO - +  moulinette : Depends: python-argcomplete but it is not going to be installed
2021-02-18 20:29:41,702: WARNING - E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
2021-02-18 20:29:41,702: INFO - +               Depends: python-bottle (>= 0.12) but it is not going to be installed
2021-02-18 20:29:41,703: INFO - +               Depends: python-gevent-websocket but it is not going to be installed
2021-02-18 20:29:41,703: INFO - +               Depends: python-ldap but it is not going to be installed
2021-02-18 20:29:41,704: INFO - +               Depends: python-psutil but it is not going to be installed
2021-02-18 20:29:41,704: INFO - +               Depends: python-toml but it is not going to be installed
2021-02-18 20:29:41,706: INFO - +               Depends: python-tz but it is not going to be installed
2021-02-18 20:29:41,707: INFO - +               Depends: python-yaml but it is not going to be installed
2021-02-18 20:29:41,707: INFO - +               Depends: python:any (< 2.8)
2021-02-18 20:29:41,708: INFO - +               Depends: python:any (>= 2.7.5-5~)
2021-02-18 20:29:41,709: INFO - +  nextcloud-ynh-deps : Depends: smbclient but it is not going to be installed
2021-02-18 20:29:41,709: INFO - +  python3-pyasn1 : Breaks: python3-pysnmp4 (< 4.3.4) but 4.3.2-2 is to be installed
2021-02-18 20:29:41,710: INFO - +  ssowat : Depends: nginx-extras (>= 1.6.2) but it is not going to be installed
2021-02-18 20:29:41,710: INFO - +  yunohost : Depends: python:any (>= 2.7.5-5~)
2021-02-18 20:29:41,711: INFO - +             Depends: python-psutil but it is not going to be installed
2021-02-18 20:29:41,711: INFO - +             Depends: python-requests but it is not going to be installed
2021-02-18 20:29:41,712: INFO - +             Depends: python-dnspython but it is not going to be installed
2021-02-18 20:29:41,713: INFO - +             Depends: python-openssl but it is not going to be installed
2021-02-18 20:29:41,713: INFO - +             Depends: python-miniupnpc but it is not going to be installed
2021-02-18 20:29:41,714: INFO - +             Depends: python-dbus but it is not going to be installed
2021-02-18 20:29:41,714: INFO - +             Depends: python-jinja2 but it is not going to be installed
2021-02-18 20:29:41,715: INFO - +             Depends: python-toml but it is not going to be installed
2021-02-18 20:29:41,715: INFO - +             Depends: python-packaging but it is not going to be installed
2021-02-18 20:29:41,716: INFO - +             Depends: nginx-extras (>= 1.6.2) but it is not going to be installed
2021-02-18 20:29:41,717: INFO - +             Depends: dnsutils but it is not going to be installed
2021-02-18 20:29:41,717: INFO - +             Depends: bind9utils but it is not going to be installed
2021-02-18 20:29:41,718: INFO - +             Depends: libnss-ldapd but it is not going to be installed
2021-02-18 20:29:41,718: INFO - +             Depends: unscd but it is not going to be installed
2021-02-18 20:29:41,719: INFO - +             Depends: libpam-ldapd but it is not going to be installed
2021-02-18 20:29:41,719: INFO - +             Depends: avahi-daemon but it is not going to be installed
2021-02-18 20:29:41,720: INFO - +             Depends: libnss-mdns but it is not going to be installed
2021-02-18 20:29:41,721: INFO - +             Depends: mailutils but it is not going to be installed
2021-02-18 20:29:41,721: INFO - +             Depends: equivs but it is not going to be installed
2021-02-18 20:29:41,722: INFO - +             Depends: python-publicsuffix but it is not going to be installed
2021-02-18 20:29:41,722: INFO - +             Recommends: python-pip but it is not going to be installed
2021-02-18 20:29:41,723: INFO - +             Recommends: libdbd-ldap-perl but it is not going to be installed
2021-02-18 20:29:42,174: WARNING - Impossible de mettre à jour les paquets suivants : acl, acpid, adduser, apt, apt-transport-https, apt-utils, at, autoconf, automake, autopoint, autotools-dev, avahi-daemon, base-files, base-passwd, bash, bash-completion, bind9-host, bind9utils, binutils, blt, bsdmainutils, bsdutils, build-essential, bzip2, ca-certificates, coreutils, cpio, cpp, cron, curl, dash, dbus, debconf, debconf-i18n, debhelper, debian-archive-keyring, debianutils, dh-autoreconf, dh-python, dh-strip-nondeterminism, dialog, diffutils, dirmngr, distro-info-data, dmidecode, dmsetup, dns-root-data, dnsmasq, dnsmasq-base, dnsutils, dovecot-antispam, dovecot-core, dovecot-imapd, dovecot-ldap, dovecot-lmtpd, dovecot-managesieved, dovecot-sieve, dpkg, dpkg-dev, e2fslibs, e2fsprogs, equivs, etckeeper, fail2ban, fakeroot, file, findutils, fontconfig, fontconfig-config, fonts-lyx, fonts-noto-mono, g++, galera-3, gawk, gcc, geoip-database, gettext, gettext-base, ghostscript, gir1.2-glib-2.0, git, git-man, glances, gnupg, gnupg-agent, gnupg1, gnupg1-l10n, gpgv, grep, groff-base, grub-common, grub-pc, grub-pc-bin, grub2-common, gsfonts, guile-2.0-libs, gzip, haveged, hddtemp, hicolor-icon-theme, hostname, ifupdown, imagemagick, imagemagick-6-common, imagemagick-6.q16, init, init-system-helpers, initramfs-tools, initramfs-tools-core, intltool-debian, iproute2, iptables, iputils-ping, irqbalance, isc-dhcp-client, isc-dhcp-common, iso-codes, jq, kbd, klibc-utils, kmod, ldap-utils, less, libacl1, libaio1, libalgorithm-diff-perl, libalgorithm-diff-xs-perl, libapparmor1, libapt-inst2.0, libapt-pkg5.0, libarchive-zip-perl, libarchive13, libassuan0, libatomic1, libattr1, libaudit-common, libaudit1, libavahi-client3, libavahi-common-data, libavahi-common3, libavahi-core7, libblas3, libblkid1, libbsd0, libbz2-1.0, libc-bin, libc-dev-bin, libc6, libc6-dev, libcairo2, libcap-ng0, libcap2, libcc1-0, libcgi-fast-perl, libcgi-pm-perl, libcilkrts5, libcomerr2, libconfig-inifiles-perl, libcroco3, libcups2, libcupsfilters1, libcupsimage2, libcurl3-gnutls, libdaemon0, libdatrie1, libdb5.3, libdbd-mysql-perl, libdbi-perl, libdbus-1-3, libdbus-glib-1-2, libdebconfclient0, libdevmapper1.02.1, libdigest-hmac-perl, libdjvulibre-text, libdjvulibre21, libdpkg-perl, libedit2, libelf1, liberror-perl, libestr0, libexpat1, libexpat1-dev, libexttextcat-2.0-0, libexttextcat-data, libfakeroot, libfastjson4, libfcgi-perl, libfdisk1, libffi6, libfftw3-double3, libfile-fcntllock-perl, libfile-stripnondeterminism-perl, libfontconfig1, libfreetype6, libfribidi0, libfuse2, libgc1c2, libgcc1, libgcrypt20, libgd3, libgdk-pixbuf2.0-0, libgdk-pixbuf2.0-common, libgeoip1, libgirepository-1.0-1, libglib2.0-0, libglib2.0-data, libgmp10, libgnutls30, libgomp1, libgpg-error0, libgpm2, libgraphite2-3, libgs9, libgs9-common, libgssapi-krb5-2, libgssapi-perl, libharfbuzz0b, libhavege1, libhogweed4, libhtml-parser-perl, libhtml-template-perl, libhtml-tree-perl, libhttp-cookies-perl, libhttp-daemon-perl, libhttp-message-perl, libhttp-negotiate-perl, libidn11, libidn2-0, libijs-0.35, libio-socket-ssl-perl, libip4tc0, libip6tc0, libiptc0, libitm1, libjbig2dec0, libjpeg62-turbo, libjq1, libjs-jquery, libjs-jquery-ui, libjs-lodash, libk5crypto3, libkeyutils1, libklibc, libkmod2, libkrb5-3, libkrb5support0, liblapack3, liblcms2-2, libldap-2.4-2, libldap-common, libldb1, liblocale-gettext-perl, liblognorm5, liblqr-1-0, liblsan0, libltdl-dev, libltdl7, libluajit-5.1-2, libluajit-5.1-common, liblwp-protocol-https-perl, liblz4-1, liblzma5, liblzo2-2, libmagic-mgc, libmagic1, libmail-sendmail-perl, libmailutils5, libmcrypt4, libmemcached11, libmemcachedutil2, libmount1, libmpc3, libmpdec2, libmpx2, libncurses5, libncursesw5, libnet-dns-perl, libnet-http-perl, libnet-ip-perl, libnet-ssleay-perl, libnetaddr-ip-perl, libnetfilter-conntrack3, libnettle6, libnewt0.52, libnfnetlink0, libnghttp2-14, libnginx-mod-http-auth-pam, libnginx-mod-http-cache-purge, libnginx-mod-http-dav-ext, libnginx-mod-http-echo, libnginx-mod-http-fancyindex, libnginx-mod-http-geoip, libnginx-mod-http-headers-more-filter, libnginx-mod-http-image-filter, libnginx-mod-http-lua, libnginx-mod-http-ndk, libnginx-mod-http-perl, libnginx-mod-http-subs-filter, libnginx-mod-http-uploadprogress, libnginx-mod-http-upstream-fair, libnginx-mod-http-xslt-filter, libnginx-mod-mail, libnginx-mod-nchan, libnginx-mod-stream, libnpth0, libnss-ldapd, libnss-mdns, libnss-myhostname, libntlm0, libnuma1, libodbc1, libopendbx1, libopendbx1-sqlite3, libopendkim11, libopenjp2-7, libopts25, libp11-kit0, libpam-ldapd, libpam-modules, libpam-modules-bin, libpam-runtime, libpam0g, libpango-1.0-0, libpangocairo-1.0-0, libpangoft2-1.0-0, libpaper-utils, libpaper1, libpcre3, libpipeline1, libpixman-1-0, libpng16-16, libpopt0, libpsl5, libpython-all-dev, libpython-dev, libpython-stdlib, libpython2.7, libpython2.7-dev, libpython2.7-minimal, libpython2.7-stdlib, libpython3-stdlib, libquadmath0, librbl1, libreadline5, libreadline7, librtmp1, libsasl2-2, libsasl2-modules, libsasl2-modules-db, libseccomp2, libselinux1, libsemanage-common, libsemanage1, libsepol1, libsigsegv2, libslang2, libsmartcols1, libsmbclient, libsocket6-perl, libsqlite3-0, libss2, libssh2-1, libssl1.1, libstdc++6, libsystemd0, libtalloc2, libtasn1-6, libtcl8.6, libtdb1, libterm-readkey-perl, libtevent0, libtext-charwidth-perl, libtext-iconv-perl, libthai-data, libthai0, libtiff5, libtimedate-perl, libtinfo5, libtk8.6, libtool, libtsan0, libubsan0, libudev1, libunwind8, liburi-perl, libuuid1, libvbr2, libwbclient0, libwebp6, libwebpdemux2, libwmf0.2-7, libwrap0, libwww-perl, libwww-robotrules-perl, libx11-6, libx11-data, libxapian30, libxau6, libxcb-render0, libxcb-shm0, libxcb1, libxft2, libxml2, libxslt1.1, libxss1, libxtables12, libyaml-0-2, libzip4, linux-base, linux-image-amd64, linux-libc-dev, lm-sensors, login, logrotate, lsb-base, lsb-release, lsof, lua-bitop, lua-event, lua-json, lua-ldap, lua-lpeg, lua-rex-pcre, lua-sec, lua-socket, lua-zlib, m4, mailutils, mailutils-common, make, man-db, manpages, manpages-dev, mariadb-common, mariadb-server, metronome, mime-support, mount, multiarch-support, mysql-common, nano, ncurses-base, ncurses-bin, netbase, netcat-openbsd, nginx-common, nginx-extras, nslcd, nslcd-utils, ntp, opendkim-tools, openssh-client, openssh-server, openssh-sftp-server, passwd, patch, perl, perl-base, php-apcu, php-apcu-bc, php-common, php-curl, php-fpm, php-gd, php-igbinary, php-imagick, php-intl, php-ldap, php-mbstring, php-mysql, php-pear, php-redis, php-xml, pinentry-curses, po-debconf, poppler-data, postfix, postfix-ldap, postfix-pcre, postfix-policyd-spf-perl, postfix-sqlite, postsrsd, procmail, procps, psmisc, publicsuffix, python, python-all, python-all-dev, python-apt, python-apt-common, python-bottle, python-cffi-backend, python-chardet, python-crypto, python-cryptography, python-dbus, python-dev, python-dnspython, python-enum34, python-gevent, python-gi, python-gnupg, python-greenlet, python-idna, python-jinja2, python-keyring, python-keyrings.alt, python-ldap, python-ldb, python-markupsafe, python-matplotlib-data, python-minimal, python-miniupnpc, python-openssl, python-packaging, python-pip, python-pip-whl, python-pkg-resources, python-psutil, python-pyasn1, python-pyparsing, python-requests, python-samba, python-setuptools, python-six, python-talloc, python-tdb, python-tz, python-urllib3, python-wheel, python-xdg, python-yaml, python2.7, python2.7-dev, python2.7-minimal, python3, python3-apt, python3-bottle, python3-chardet, python3-crypto, python3-dateutil, python3-docker, python3-matplotlib, python3-minimal, python3-netifaces, python3-numpy, python3-pil, python3-pkg-resources, python3-psutil, python3-pyasn1, python3-pyparsing, python3-pysnmp4, python3-requests, python3-six, python3-systemd, python3-tk, python3-tz, python3-urllib3, python3-websocket, readline-common, redis-server, redis-tools, rename, rspamd, rsync, rsyslog, samba-common, samba-common-bin, samba-libs, sed, sensible-utils, shared-mime-info, slapd, smbclient, socat, sudo-ldap, systemd, systemd-sysv, sysvinit-utils, tar, tasksel, tasksel-data, tk8.6-blt2.5, tree, tzdata, ucf, udev, unattended-upgrades, unzip, util-linux, vim, vim-common, vim-runtime, vim-tiny, wget, whiptail, whois, xdg-user-dirs, xml-core, xxd, xz-utils, zlib1g
ended_at: 2021-02-18 20:29:42.199453
error: "La migration 0015_migrate_to_buster a \xE9chou\xE9 avec l\u2019exception Impossible\
  \ de mettre \xE0 jour tous les paquets : annulation"
operation: tools_migrations_migrate_forward
started_at: 2021-02-18 20:25:17.148120
success: false
yunohost_version: 3.8.5.9

============

2021-02-18 20:25:17,162: INFO - Exécution de la migration 0015_migrate_to_buster…
2021-02-18 20:25:17,176: INFO - Récupération des mises à jour disponibles pour les paquets du système…
2021-02-18 20:25:17,404: DEBUG - Hit:1 http://forge.yunohost.org/debian stretch InRelease
2021-02-18 20:25:17,406: DEBUG - Hit:2 http://security.debian.org/debian-security stretch/updates InRelease
2021-02-18 20:27:17,598: DEBUG - Get:3 ftp://ftp.fr.debian.org/debian stretch InRelease
2021-02-18 20:27:17,599: DEBUG - Ign:3 ftp://ftp.fr.debian.org/debian stretch InRelease
2021-02-18 20:27:17,599: DEBUG - Hit:4 ftp://ftp.fr.debian.org/debian stretch-updates InRelease
2021-02-18 20:27:17,600: DEBUG - Hit:5 ftp://ftp.fr.debian.org/debian stretch Release
2021-02-18 20:27:19,104: DEBUG - Reading package lists...
2021-02-18 20:27:19,463: DEBUG - Terminé
2021-02-18 20:27:19,464: INFO - Il n’y a rien à faire ! Tout est déjà à jour !
2021-02-18 20:27:19,715: INFO - Démarrage de la migration vers Buster
2021-02-18 20:27:19,786: INFO - Mise à jour du fichier sources.lists …
2021-02-18 20:27:19,803: INFO - Récupération des mises à jour disponibles pour les paquets du système…
2021-02-18 20:27:20,028: DEBUG - Get:1 http://security.debian.org/debian-security buster/updates InRelease [65.4 kB]
2021-02-18 20:27:20,029: DEBUG - Get:2 http://forge.yunohost.org/debian buster InRelease [18.2 kB]
2021-02-18 20:27:20,231: DEBUG - Get:3 http://security.debian.org/debian-security buster/updates/main amd64 Packages [267 kB]
2021-02-18 20:27:20,332: DEBUG - Get:4 http://security.debian.org/debian-security buster/updates/main Translation-en [142 kB]
2021-02-18 20:27:20,432: DEBUG - Get:5 http://forge.yunohost.org/debian buster/stable amd64 Packages [5280 B]
2021-02-18 20:29:20,932: DEBUG - Get:6 ftp://ftp.fr.debian.org/debian buster InRelease [122 kB]
2021-02-18 20:29:21,034: DEBUG - Get:7 ftp://ftp.fr.debian.org/debian buster-updates InRelease [51.9 kB]
2021-02-18 20:29:21,135: DEBUG - Get:8 ftp://ftp.fr.debian.org/debian buster/main amd64 Packages [7907 kB]
2021-02-18 20:29:22,039: DEBUG - Get:9 ftp://ftp.fr.debian.org/debian buster/main Translation-en [5969 kB]
2021-02-18 20:29:22,742: DEBUG - Get:10 ftp://ftp.fr.debian.org/debian buster-updates/main amd64 Packages [9504 B]
2021-02-18 20:29:22,843: DEBUG - Get:11 ftp://ftp.fr.debian.org/debian buster-updates/main Translation-en [6834 B]
2021-02-18 20:29:26,855: DEBUG - Fetched 14.6 MB in 2min 6s (115 kB/s)
2021-02-18 20:29:28,661: DEBUG - Reading package lists...
2021-02-18 20:29:29,100: DEBUG - Terminé
2021-02-18 20:29:30,948: INFO - Commencement de la mise à jour des paquets du système qui doivent être mis à jour séparément …
2021-02-18 20:29:31,047: WARNING - Could not identify which version of unscd to install
2021-02-18 20:29:31,074: DEBUG - Running: LC_ALL=C DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt install --quiet -o=Dpkg::Use-Pty=0 --fix-broken --assume-yes libpam-modules -o Dpkg::Options::="--force-overwrite"
2021-02-18 20:29:31,190: INFO - + Reading package lists...
2021-02-18 20:29:31,192: WARNING - 
2021-02-18 20:29:31,197: WARNING - WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
2021-02-18 20:29:31,198: WARNING - 
2021-02-18 20:29:31,399: INFO - + Building dependency tree...
2021-02-18 20:29:31,400: INFO - + Reading state information...
2021-02-18 20:29:31,801: INFO - + The following packages were automatically installed and are no longer required:
2021-02-18 20:29:31,802: INFO - +   avahi-daemon bind9-host bind9utils dns-root-data dnsmasq dnsmasq-base
2021-02-18 20:29:31,803: INFO - +   dnsutils dovecot-antispam equivs etckeeper fail2ban fake-hwclock fonts-lyx
2021-02-18 20:29:31,803: INFO - +   galera-3 geoip-database gir1.2-glib-2.0 git git-man glances haveged hddtemp
2021-02-18 20:29:31,804: INFO - +   iproute javascript-common jq ldap-utils libaio1 libavahi-core7 libbind9-140
2021-02-18 20:29:31,804: INFO - +   libblas-common libblas3 libcgi-fast-perl libcgi-pm-perl
2021-02-18 20:29:31,807: INFO - +   libconfig-inifiles-perl libdaemon0 libdbd-ldap-perl libdbd-mysql-perl
2021-02-18 20:29:31,808: INFO - +   libdbi-perl libdbus-glib-1-2 libdns162 liberror-perl libevent-2.0-5
2021-02-18 20:29:31,814: INFO - +   libexpat1-dev libfcgi-perl libgeoip1 libgfortran3 libgirepository-1.0-1
2021-02-18 20:29:31,814: INFO - +   libhavege1 libhiredis0.13 libhtml-template-perl libisc160 libisccc140
2021-02-18 20:29:31,815: INFO - +   libisccfg140 libjq1 libjs-angularjs libjs-jquery libjs-jquery-ui
2021-02-18 20:29:31,816: INFO - +   libjs-lodash liblapack3 liblua5.1-0 libluajit-5.1-2 libluajit-5.1-common
2021-02-18 20:29:31,816: INFO - +   liblwres141 libmail-spf-perl libmemcached11 libmemcachedutil2
2021-02-18 20:29:31,817: INFO - +   libnet-dns-perl libnet-ip-perl libnetaddr-ip-perl libnginx-mod-http-auth-pam
2021-02-18 20:29:31,817: INFO - +   libnginx-mod-http-cache-purge libnginx-mod-http-dav-ext
2021-02-18 20:29:31,821: INFO - +   libnginx-mod-http-echo libnginx-mod-http-fancyindex libnginx-mod-http-geoip
2021-02-18 20:29:31,822: INFO - +   libnginx-mod-http-headers-more-filter libnginx-mod-http-image-filter
2021-02-18 20:29:31,823: INFO - +   libnginx-mod-http-lua libnginx-mod-http-ndk libnginx-mod-http-perl
2021-02-18 20:29:31,823: INFO - +   libnginx-mod-http-subs-filter libnginx-mod-http-uploadprogress
2021-02-18 20:29:31,824: INFO - +   libnginx-mod-http-upstream-fair libnginx-mod-http-xslt-filter
2021-02-18 20:29:31,824: INFO - +   libnginx-mod-mail libnginx-mod-nchan libnginx-mod-stream libnss-ldapd
2021-02-18 20:29:31,830: INFO - +   libnss-mdns libnss-myhostname libodbc1 libonig4 libopendbx1
2021-02-18 20:29:31,830: INFO - +   libopendbx1-sqlite3 libopendkim11 libpam-ldapd libpython-all-dev
2021-02-18 20:29:31,831: INFO - +   libpython-dev libpython2.7-dev librbl1 libreadline5 libsensors4
2021-02-18 20:29:31,831: INFO - +   libterm-readkey-perl libunbound2 libunwind8 libvbr2 libwebpdemux2
2021-02-18 20:29:31,832: INFO - +   libwebpmux2 libyaml-0-2 lm-sensors lsof lua-bitop lua-event lua-expat
2021-02-18 20:29:31,832: INFO - +   lua-filesystem lua-json lua-ldap lua-lpeg lua-rex-pcre lua-sec lua-socket
2021-02-18 20:29:31,833: INFO - +   lua-zlib lua5.1 mariadb-client-10.1 mariadb-client-core-10.1 mariadb-common
2021-02-18 20:29:31,833: INFO - +   mariadb-server mariadb-server-10.1 mariadb-server-core-10.1 metronome
2021-02-18 20:29:31,837: INFO - +   moulinette netcat-openbsd nginx-common nginx-extras nslcd nslcd-utils
2021-02-18 20:29:31,838: INFO - +   opendkim-tools php-fpm php-gettext php-mysql php-php-gettext php7.0-mysql
2021-02-18 20:29:31,839: INFO - +   postfix-policyd-spf-perl postsrsd python-all python-all-dev
2021-02-18 20:29:31,839: INFO - +   python-argcomplete python-bottle python-cffi-backend python-chardet
2021-02-18 20:29:31,840: INFO - +   python-cryptography python-dbus python-dev python-dnspython python-enum34
2021-02-18 20:29:31,840: INFO - +   python-gevent python-gevent-websocket python-gi python-gnupg python-greenlet
2021-02-18 20:29:31,841: INFO - +   python-idna python-ipaddress python-jinja2 python-keyring
2021-02-18 20:29:31,842: INFO - +   python-keyrings.alt python-ldap python-markupsafe python-matplotlib-data
2021-02-18 20:29:31,850: WARNING - E: Essential packages were removed and -y was used without --allow-remove-essential.
2021-02-18 20:29:31,851: INFO - +   python-miniupnpc python-openssl python-packaging python-pip python-pip-whl
2021-02-18 20:29:31,851: INFO - +   python-pkg-resources python-psutil python-publicsuffix python-pyasn1
2021-02-18 20:29:31,852: INFO - +   python-pyparsing python-requests python-secretstorage python-setuptools
2021-02-18 20:29:31,852: INFO - +   python-six python-toml python-tz python-urllib3 python-wheel python-xdg
2021-02-18 20:29:31,853: INFO - +   python-yaml python2.7-dev python3-apt python3-bottle python3-chardet
2021-02-18 20:29:31,853: INFO - +   python3-crypto python3-cycler python3-dateutil python3-docker
2021-02-18 20:29:31,854: INFO - +   python3-matplotlib python3-netifaces python3-numpy python3-pil
2021-02-18 20:29:31,854: INFO - +   python3-pkg-resources python3-psutil python3-pyasn1 python3-pyinotify
2021-02-18 20:29:31,855: INFO - +   python3-pyparsing python3-pysnmp4 python3-pystache python3-requests
2021-02-18 20:29:31,855: INFO - +   python3-six python3-systemd python3-tz python3-urllib3 python3-websocket
2021-02-18 20:29:31,856: INFO - +   rspamd rsync slapd socat ssowat sudo-ldap unattended-upgrades unzip
2021-02-18 20:29:31,856: INFO - + Use 'apt autoremove' to remove them.
2021-02-18 20:29:31,857: INFO - + The following additional packages will be installed:
2021-02-18 20:29:31,857: INFO - +   libc-bin libc-dev-bin libc6 libc6-dev libidn2-0 libpam-modules-bin libpam0g
2021-02-18 20:29:31,858: INFO - +   libsasl2-2 libsasl2-modules-db libunistring2 moulinette ssowat
2021-02-18 20:29:31,858: INFO - + Suggested packages:
2021-02-18 20:29:31,859: INFO - +   glibc-doc libc-l10n locales libpam-doc
2021-02-18 20:29:31,859: INFO - + Recommended packages:
2021-02-18 20:29:31,860: INFO - +   libsasl2-modules
2021-02-18 20:29:31,860: INFO - + The following packages will be REMOVED:
2021-02-18 20:29:31,861: INFO - +   unscd yunohost yunohost-admin
2021-02-18 20:29:31,861: INFO - + The following NEW packages will be installed:
2021-02-18 20:29:31,862: INFO - +   libunistring2
2021-02-18 20:29:31,862: INFO - + The following packages will be upgraded:
2021-02-18 20:29:31,863: INFO - +   libc-bin libc-dev-bin libc6 libc6-dev libidn2-0 libpam-modules
2021-02-18 20:29:31,863: INFO - +   libpam-modules-bin libpam0g libsasl2-2 libsasl2-modules-db moulinette ssowat
2021-02-18 20:29:31,864: INFO - + WARNING: The following essential packages will be removed.
2021-02-18 20:29:31,864: INFO - + This should NOT be done unless you know exactly what you are doing!
2021-02-18 20:29:31,865: INFO - +   yunohost unscd (due to yunohost)
2021-02-18 20:29:31,865: INFO - + 12 upgraded, 1 newly installed, 3 to remove and 594 not upgraded.
2021-02-18 20:29:31,967: INFO - Démarrage de la mise à niveau générale …
2021-02-18 20:29:34,941: INFO - Mise à jour des paquets en cours…
2021-02-18 20:29:34,963: INFO - Mise à jour des paquets du système (non liés a YunoHost)…
2021-02-18 20:29:40,654: DEBUG - Running apt command :
DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt-get --fix-broken --show-upgraded --assume-yes --quiet -o=Dpkg::Use-Pty=0 -o Dpkg::Options::="--force-confold" -o Dpkg::Options::="--force-confmiss" -o Dpkg::Options::="--force-confdef" dist-upgrade
2021-02-18 20:29:40,778: INFO - + Reading package lists...
2021-02-18 20:29:40,982: INFO - + Building dependency tree...
2021-02-18 20:29:40,984: INFO - + Reading state information...
2021-02-18 20:29:41,587: INFO - + Calculating upgrade...
2021-02-18 20:29:41,588: INFO - + Some packages could not be installed. This may mean that you have
2021-02-18 20:29:41,589: INFO - + requested an impossible situation or if you are using the unstable
2021-02-18 20:29:41,590: INFO - + distribution that some required packages have not yet been created
2021-02-18 20:29:41,598: INFO - + or been moved out of Incoming.
2021-02-18 20:29:41,598: INFO - + The following information may help to resolve the situation:
2021-02-18 20:29:41,599: INFO - + 
2021-02-18 20:29:41,600: INFO - + The following packages have unmet dependencies:
2021-02-18 20:29:41,701: INFO - +  moulinette : Depends: python-argcomplete but it is not going to be installed
2021-02-18 20:29:41,702: WARNING - E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
2021-02-18 20:29:41,702: INFO - +               Depends: python-bottle (>= 0.12) but it is not going to be installed
2021-02-18 20:29:41,703: INFO - +               Depends: python-gevent-websocket but it is not going to be installed
2021-02-18 20:29:41,703: INFO - +               Depends: python-ldap but it is not going to be installed
2021-02-18 20:29:41,704: INFO - +               Depends: python-psutil but it is not going to be installed
2021-02-18 20:29:41,704: INFO - +               Depends: python-toml but it is not going to be installed
2021-02-18 20:29:41,706: INFO - +               Depends: python-tz but it is not going to be installed
2021-02-18 20:29:41,707: INFO - +               Depends: python-yaml but it is not going to be installed
2021-02-18 20:29:41,707: INFO - +               Depends: python:any (< 2.8)
2021-02-18 20:29:41,708: INFO - +               Depends: python:any (>= 2.7.5-5~)
2021-02-18 20:29:41,709: INFO - +  nextcloud-ynh-deps : Depends: smbclient but it is not going to be installed
2021-02-18 20:29:41,709: INFO - +  python3-pyasn1 : Breaks: python3-pysnmp4 (< 4.3.4) but 4.3.2-2 is to be installed
2021-02-18 20:29:41,710: INFO - +  ssowat : Depends: nginx-extras (>= 1.6.2) but it is not going to be installed
2021-02-18 20:29:41,710: INFO - +  yunohost : Depends: python:any (>= 2.7.5-5~)
2021-02-18 20:29:41,711: INFO - +             Depends: python-psutil but it is not going to be installed
2021-02-18 20:29:41,711: INFO - +             Depends: python-requests but it is not going to be installed
2021-02-18 20:29:41,712: INFO - +             Depends: python-dnspython but it is not going to be installed
2021-02-18 20:29:41,713: INFO - +             Depends: python-openssl but it is not going to be installed
2021-02-18 20:29:41,713: INFO - +             Depends: python-miniupnpc but it is not going to be installed
2021-02-18 20:29:41,714: INFO - +             Depends: python-dbus but it is not going to be installed
2021-02-18 20:29:41,714: INFO - +             Depends: python-jinja2 but it is not going to be installed
2021-02-18 20:29:41,715: INFO - +             Depends: python-toml but it is not going to be installed
2021-02-18 20:29:41,715: INFO - +             Depends: python-packaging but it is not going to be installed
2021-02-18 20:29:41,716: INFO - +             Depends: nginx-extras (>= 1.6.2) but it is not going to be installed
2021-02-18 20:29:41,717: INFO - +             Depends: dnsutils but it is not going to be installed
2021-02-18 20:29:41,717: INFO - +             Depends: bind9utils but it is not going to be installed
2021-02-18 20:29:41,718: INFO - +             Depends: libnss-ldapd but it is not going to be installed
2021-02-18 20:29:41,718: INFO - +             Depends: unscd but it is not going to be installed
2021-02-18 20:29:41,719: INFO - +             Depends: libpam-ldapd but it is not going to be installed
2021-02-18 20:29:41,719: INFO - +             Depends: avahi-daemon but it is not going to be installed
2021-02-18 20:29:41,720: INFO - +             Depends: libnss-mdns but it is not going to be installed
2021-02-18 20:29:41,721: INFO - +             Depends: mailutils but it is not going to be installed
2021-02-18 20:29:41,721: INFO - +             Depends: equivs but it is not going to be installed
2021-02-18 20:29:41,722: INFO - +             Depends: python-publicsuffix but it is not going to be installed
2021-02-18 20:29:41,722: INFO - +             Recommends: python-pip but it is not going to be installed
2021-02-18 20:29:41,723: INFO - +             Recommends: libdbd-ldap-perl but it is not going to be installed
2021-02-18 20:29:42,174: WARNING - Impossible de mettre à jour les paquets suivants : acl, acpid, adduser, apt, apt-transport-https, apt-utils, at, autoconf, automake, autopoint, autotools-dev, avahi-daemon, base-files, base-passwd, bash, bash-completion, bind9-host, bind9utils, binutils, blt, bsdmainutils, bsdutils, build-essential, bzip2, ca-certificates, coreutils, cpio, cpp, cron, curl, dash, dbus, debconf, debconf-i18n, debhelper, debian-archive-keyring, debianutils, dh-autoreconf, dh-python, dh-strip-nondeterminism, dialog, diffutils, dirmngr, distro-info-data, dmidecode, dmsetup, dns-root-data, dnsmasq, dnsmasq-base, dnsutils, dovecot-antispam, dovecot-core, dovecot-imapd, dovecot-ldap, dovecot-lmtpd, dovecot-managesieved, dovecot-sieve, dpkg, dpkg-dev, e2fslibs, e2fsprogs, equivs, etckeeper, fail2ban, fakeroot, file, findutils, fontconfig, fontconfig-config, fonts-lyx, fonts-noto-mono, g++, galera-3, gawk, gcc, geoip-database, gettext, gettext-base, ghostscript, gir1.2-glib-2.0, git, git-man, glances, gnupg, gnupg-agent, gnupg1, gnupg1-l10n, gpgv, grep, groff-base, grub-common, grub-pc, grub-pc-bin, grub2-common, gsfonts, guile-2.0-libs, gzip, haveged, hddtemp, hicolor-icon-theme, hostname, ifupdown, imagemagick, imagemagick-6-common, imagemagick-6.q16, init, init-system-helpers, initramfs-tools, initramfs-tools-core, intltool-debian, iproute2, iptables, iputils-ping, irqbalance, isc-dhcp-client, isc-dhcp-common, iso-codes, jq, kbd, klibc-utils, kmod, ldap-utils, less, libacl1, libaio1, libalgorithm-diff-perl, libalgorithm-diff-xs-perl, libapparmor1, libapt-inst2.0, libapt-pkg5.0, libarchive-zip-perl, libarchive13, libassuan0, libatomic1, libattr1, libaudit-common, libaudit1, libavahi-client3, libavahi-common-data, libavahi-common3, libavahi-core7, libblas3, libblkid1, libbsd0, libbz2-1.0, libc-bin, libc-dev-bin, libc6, libc6-dev, libcairo2, libcap-ng0, libcap2, libcc1-0, libcgi-fast-perl, libcgi-pm-perl, libcilkrts5, libcomerr2, libconfig-inifiles-perl, libcroco3, libcups2, libcupsfilters1, libcupsimage2, libcurl3-gnutls, libdaemon0, libdatrie1, libdb5.3, libdbd-mysql-perl, libdbi-perl, libdbus-1-3, libdbus-glib-1-2, libdebconfclient0, libdevmapper1.02.1, libdigest-hmac-perl, libdjvulibre-text, libdjvulibre21, libdpkg-perl, libedit2, libelf1, liberror-perl, libestr0, libexpat1, libexpat1-dev, libexttextcat-2.0-0, libexttextcat-data, libfakeroot, libfastjson4, libfcgi-perl, libfdisk1, libffi6, libfftw3-double3, libfile-fcntllock-perl, libfile-stripnondeterminism-perl, libfontconfig1, libfreetype6, libfribidi0, libfuse2, libgc1c2, libgcc1, libgcrypt20, libgd3, libgdk-pixbuf2.0-0, libgdk-pixbuf2.0-common, libgeoip1, libgirepository-1.0-1, libglib2.0-0, libglib2.0-data, libgmp10, libgnutls30, libgomp1, libgpg-error0, libgpm2, libgraphite2-3, libgs9, libgs9-common, libgssapi-krb5-2, libgssapi-perl, libharfbuzz0b, libhavege1, libhogweed4, libhtml-parser-perl, libhtml-template-perl, libhtml-tree-perl, libhttp-cookies-perl, libhttp-daemon-perl, libhttp-message-perl, libhttp-negotiate-perl, libidn11, libidn2-0, libijs-0.35, libio-socket-ssl-perl, libip4tc0, libip6tc0, libiptc0, libitm1, libjbig2dec0, libjpeg62-turbo, libjq1, libjs-jquery, libjs-jquery-ui, libjs-lodash, libk5crypto3, libkeyutils1, libklibc, libkmod2, libkrb5-3, libkrb5support0, liblapack3, liblcms2-2, libldap-2.4-2, libldap-common, libldb1, liblocale-gettext-perl, liblognorm5, liblqr-1-0, liblsan0, libltdl-dev, libltdl7, libluajit-5.1-2, libluajit-5.1-common, liblwp-protocol-https-perl, liblz4-1, liblzma5, liblzo2-2, libmagic-mgc, libmagic1, libmail-sendmail-perl, libmailutils5, libmcrypt4, libmemcached11, libmemcachedutil2, libmount1, libmpc3, libmpdec2, libmpx2, libncurses5, libncursesw5, libnet-dns-perl, libnet-http-perl, libnet-ip-perl, libnet-ssleay-perl, libnetaddr-ip-perl, libnetfilter-conntrack3, libnettle6, libnewt0.52, libnfnetlink0, libnghttp2-14, libnginx-mod-http-auth-pam, libnginx-mod-http-cache-purge, libnginx-mod-http-dav-ext, libnginx-mod-http-echo, libnginx-mod-http-fancyindex, libnginx-mod-http-geoip, libnginx-mod-http-headers-more-filter, libnginx-mod-http-image-filter, libnginx-mod-http-lua, libnginx-mod-http-ndk, libnginx-mod-http-perl, libnginx-mod-http-subs-filter, libnginx-mod-http-uploadprogress, libnginx-mod-http-upstream-fair, libnginx-mod-http-xslt-filter, libnginx-mod-mail, libnginx-mod-nchan, libnginx-mod-stream, libnpth0, libnss-ldapd, libnss-mdns, libnss-myhostname, libntlm0, libnuma1, libodbc1, libopendbx1, libopendbx1-sqlite3, libopendkim11, libopenjp2-7, libopts25, libp11-kit0, libpam-ldapd, libpam-modules, libpam-modules-bin, libpam-runtime, libpam0g, libpango-1.0-0, libpangocairo-1.0-0, libpangoft2-1.0-0, libpaper-utils, libpaper1, libpcre3, libpipeline1, libpixman-1-0, libpng16-16, libpopt0, libpsl5, libpython-all-dev, libpython-dev, libpython-stdlib, libpython2.7, libpython2.7-dev, libpython2.7-minimal, libpython2.7-stdlib, libpython3-stdlib, libquadmath0, librbl1, libreadline5, libreadline7, librtmp1, libsasl2-2, libsasl2-modules, libsasl2-modules-db, libseccomp2, libselinux1, libsemanage-common, libsemanage1, libsepol1, libsigsegv2, libslang2, libsmartcols1, libsmbclient, libsocket6-perl, libsqlite3-0, libss2, libssh2-1, libssl1.1, libstdc++6, libsystemd0, libtalloc2, libtasn1-6, libtcl8.6, libtdb1, libterm-readkey-perl, libtevent0, libtext-charwidth-perl, libtext-iconv-perl, libthai-data, libthai0, libtiff5, libtimedate-perl, libtinfo5, libtk8.6, libtool, libtsan0, libubsan0, libudev1, libunwind8, liburi-perl, libuuid1, libvbr2, libwbclient0, libwebp6, libwebpdemux2, libwmf0.2-7, libwrap0, libwww-perl, libwww-robotrules-perl, libx11-6, libx11-data, libxapian30, libxau6, libxcb-render0, libxcb-shm0, libxcb1, libxft2, libxml2, libxslt1.1, libxss1, libxtables12, libyaml-0-2, libzip4, linux-base, linux-image-amd64, linux-libc-dev, lm-sensors, login, logrotate, lsb-base, lsb-release, lsof, lua-bitop, lua-event, lua-json, lua-ldap, lua-lpeg, lua-rex-pcre, lua-sec, lua-socket, lua-zlib, m4, mailutils, mailutils-common, make, man-db, manpages, manpages-dev, mariadb-common, mariadb-server, metronome, mime-support, mount, multiarch-support, mysql-common, nano, ncurses-base, ncurses-bin, netbase, netcat-openbsd, nginx-common, nginx-extras, nslcd, nslcd-utils, ntp, opendkim-tools, openssh-client, openssh-server, openssh-sftp-server, passwd, patch, perl, perl-base, php-apcu, php-apcu-bc, php-common, php-curl, php-fpm, php-gd, php-igbinary, php-imagick, php-intl, php-ldap, php-mbstring, php-mysql, php-pear, php-redis, php-xml, pinentry-curses, po-debconf, poppler-data, postfix, postfix-ldap, postfix-pcre, postfix-policyd-spf-perl, postfix-sqlite, postsrsd, procmail, procps, psmisc, publicsuffix, python, python-all, python-all-dev, python-apt, python-apt-common, python-bottle, python-cffi-backend, python-chardet, python-crypto, python-cryptography, python-dbus, python-dev, python-dnspython, python-enum34, python-gevent, python-gi, python-gnupg, python-greenlet, python-idna, python-jinja2, python-keyring, python-keyrings.alt, python-ldap, python-ldb, python-markupsafe, python-matplotlib-data, python-minimal, python-miniupnpc, python-openssl, python-packaging, python-pip, python-pip-whl, python-pkg-resources, python-psutil, python-pyasn1, python-pyparsing, python-requests, python-samba, python-setuptools, python-six, python-talloc, python-tdb, python-tz, python-urllib3, python-wheel, python-xdg, python-yaml, python2.7, python2.7-dev, python2.7-minimal, python3, python3-apt, python3-bottle, python3-chardet, python3-crypto, python3-dateutil, python3-docker, python3-matplotlib, python3-minimal, python3-netifaces, python3-numpy, python3-pil, python3-pkg-resources, python3-psutil, python3-pyasn1, python3-pyparsing, python3-pysnmp4, python3-requests, python3-six, python3-systemd, python3-tk, python3-tz, python3-urllib3, python3-websocket, readline-common, redis-server, redis-tools, rename, rspamd, rsync, rsyslog, samba-common, samba-common-bin, samba-libs, sed, sensible-utils, shared-mime-info, slapd, smbclient, socat, sudo-ldap, systemd, systemd-sysv, sysvinit-utils, tar, tasksel, tasksel-data, tk8.6-blt2.5, tree, tzdata, ucf, udev, unattended-upgrades, unzip, util-linux, vim, vim-common, vim-runtime, vim-tiny, wget, whiptail, whois, xdg-user-dirs, xml-core, xxd, xz-utils, zlib1g
2021-02-18 20:29:42,179: INFO - <strong>L’opération 'Mettre à jour les paquets du système' a échoué ! Pour obtenir de l’aide, merci de partager le journal de l’opération en <a href="#/tools/logs/20210218-202934-tools_upgrade">cliquant ici</a></strong>
2021-02-18 20:29:42,195: ERROR - La migration 0015_migrate_to_buster a échoué avec l’exception Impossible de mettre à jour tous les paquets : annulation
Traceback (most recent call last):
  File "/usr/lib/moulinette/yunohost/tools.py", line 895, in tools_migrations_migrate
    migration.run()
  File "/usr/lib/moulinette/yunohost/data_migrations/0015_migrate_to_buster.py", line 79, in run
    tools_upgrade(system=True, allow_yunohost_upgrade=False)
  File "/usr/lib/moulinette/yunohost/log.py", line 313, in func_wrapper
    result = func(*args, **kwargs)
  File "/usr/lib/moulinette/yunohost/tools.py", line 615, in tools_upgrade
    raise YunohostError(m18n.n('packages_upgrade_failed'))
YunohostError: Impossible de mettre à jour tous les paquets

sources.list

> cat /etc/apt/sources.list /etc/apt/sources.list.d/*

# Stretch
deb ftp://ftp.fr.debian.org/debian/ buster main
# deb-src ftp://ftp.fr.debian.org/debian/ buster main

# Stretch SECURITY
deb http://security.debian.org/debian-security/ buster/updates main
# deb-src ftp://security.debian.org/debian-security buster/updates main

# Stretch-UPDATES
deb ftp://ftp.fr.debian.org/debian/ buster-updates main
# deb-src ftp://ftp.fr.debian.org/debian/ buster-updates main
deb http://forge.yunohost.org/debian/ buster stable

Arg ouipe, est-ce que tu peux faire un :

apt policy unscd
> apt policy unscd
unscd:
  Installed: 0.53-1+yunohost
  Candidate: 0.53-1+yunohost
  Version table:
 *** 0.53-1+yunohost 100
        100 /var/lib/dpkg/status
     0.53-1+b1 500
        500 ftp://ftp.fr.debian.org/debian buster/main amd64 Packages

Est-ce que je fais comme indiqué ci-dessous ?

Arg oui c’est bien ça qu’il faut faire … je me souviens maintenant avoir déjà vu ce bug : c’est parce que l’url est en ftp:// et pas http:// et du coup le bout de python échoue misérablement à parser la version ¯\_(ツ)_/¯

Ok, j’ai tapé les trois commandes recommandées par Aleks :

> apt install unscd=0.53-1+b1 --allow-downgrades

> apt install libpam-modules -o Dpkg::Options::="--force-overwrite"

> yunohost tools upgrade --system

Avant de lancer la dernière commande yunohost, on peut vérifier dans /etc/apt/sources.list et /etc/apt/sources.list.d/* si les sources proviennent d’un ftp (ftp://), en quel cas il faut les remplacer par http:// !

Ensuite on peut lancer la migration, ça a marché pour moi en tous cas.

Merci Aleks :star_struck:

1 Like