Migration 0021_migrate_to_bullseye did not complete, aborting. Error: Failed to reinstall mariadb-common?

(english/french)

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 4.4.2.14
I have access to my server : Full access
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi there,

Attempted yesterday to migrate to 11, got this error about mariadb

2022-09-18 21:59:33,364: WARNING - postinst called with unknown argument 'triggered'
2022-09-18 21:59:33,524: WARNING - dpkg: error processing package mariadb-server-10.3 (--configure):
2022-09-18 21:59:33,525: WARNING -  installed mariadb-server-10.3 package post-installation script subprocess returned error exit status 1
2022-09-18 21:59:33,620: WARNING - Errors were encountered while processing:
2022-09-18 21:59:33,623: WARNING -  mariadb-server-10.3
2022-09-18 21:59:34,043: WARNING - E: Sub-process /usr/bin/dpkg returned an error code (1)

Full log here: https://paste.yunohost.org/raw/apoxaveliy

I’ve seen other similar topics, where another package is involved, but could not identify any other culprit here.

Also tried

sudo apt --fix-broken install

But there’s nothing to update or fix apparently

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 914 not upgraded.

This seems similar to yours, except I haven’t made any modifications
@unmy any progress?

Yep apparently migration is running ok after a fresh reboot.
Hope it works for you too @unmy

nope, the error actually changed now. :sob:

i skipped the bullseye migration because it looked like i was already on bullseye and i did the other migrations and now it seems that everything looks fine?

You can’t only skip bullseye migration. You have to complete the upgrade yourself.

I had the same error this morning and I solved it in this forum post : Mise à jour vers Debian 11, deuxième serveur .

In quick explain :

$ sudo apt update

$ sudo apt full-upgrade

$ sudo apt autoremove

$ sudo apt update

$ sudo apt full-upgrade

I don’t know why I had to update/full-upgrade two times. After the first round, there was still some upgrade to do (guile-2.2-libs, moulinette/stable 11.0.9, ssowat/stable 11.0.9, yunohost-admin/stable 11.0.10 and yunohost/stable 11.0.9.14).

After that, I could launch the last upgrade parts via the webadmin. (You can do it from CLI too).

thank you for sharing, but that didn’t solve the issue sadly.