Microsoft VS code repository

,

Français
Peut-être aurez-vous remarqué en mettant votre yunohost à jour qu’apt contactait désormais un serveur microsoft ; raspbian a en effet ajouté un dépôt pour VS code. Il est possible de le désactiver en commentant /etc/apt/sources.list.d/vscode.list.

English
You may have noticed that apt connected to a microsoft’s server during your last yunohost update; turns out raspbian added a VS code repo . You may deactivate it by commenting /etc/apt/sources.list.d/vscode.list.

What the fuck ? Is this for real ?

1 Like

Not sure how you got this but I have a RPi and I don’t have this on my side …

I read about it on mastodon then checked my yunohost install. The repo was indeed added without my knowledge and Microsoft’s key added to apt-key. I removed both.

1 Like

source [FR] : John Shaft (ジョン・シャフト) ✅: "Si vous êtes sous Raspbian et que vous découvrez …" - La Quadrature du Net - Mastodon - Media Fédéré

En effet, merci, j’étais en train de le rechercher.

Mouarf ok génial, apparament c’est dans le paquet raspberrypi-sys-mods …?

J’imagine qu’on peut dezinguer ce merdier automagiquement dans notre hook de regen-conf d’apt …

Ça me semblait important de le signaler, d’autant que je ne dois pas être le seul impacté. J’ai eu de la chance de le voir passer sur mastodon c’est tout.
Bon courage pour trouver une solution :sweat:

Actuellement la migration vers Debian 11 échoue de mon côté à cause de raspberrypi-sys-mods qui ne s’installe pas correctement.

Dans le message d’erreur au début:

Paramétrage de raspberrypi-sys-mods (20220901) ...
Fixing previous dhcpcd wait.conf drop-in to prevent double logging...
Removing vscode repo stubs...
Checking if boot partition needs 'flush' option...
dpkg: erreur de traitement du paquet raspberrypi-sys-mods (--configure) :
 installed raspberrypi-sys-mods package post-installation script subprocess returned error exit status 1
Des erreurs ont été rencontrées pendant l'exécution :
 raspberrypi-sys-mods

vscode est mentionné :thinking:. Mais supprimé ? (cf. John Shaft (ジョン・シャフト) ✅: "Ah bah la dernière version de raspberry-sys-mod s…" - La Quadrature du Net - Mastodon - Media Fédéré ?)
Et je n’ai pas ce fichier /etc/apt/sources.list.d/vscode.list.

VSCode n’a pas l’air d’être le problème puisqu’il y a ensuite un autre message sur un autre sujet, juste avant que le truc ne crash, mais malheureusement pas vraiment plus de détails sur pourquoi ça crash …

Je documentais la présence de ce message, je ne cherche pas ici à résoudre le problème :slight_smile:
(résolution du problème: désinstaller le paquet, mettre à niveau vers Debian 11, réinstaller)

1 Like